summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2006-06-22 07:09:53 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2006-06-22 07:09:53 +0000
commitf9d6aea64c9e4f8502fe51321552c3265c57a838 (patch)
treed3568d434c39e024e10ea7d0dcd2da37ea04125c /dev-libs/libxslt
parentAdd /etc/cups/ssl, thanks to Philipp Rosenberger <philipp@iluminat23.org> and... (diff)
downloadgentoo-2-f9d6aea64c9e4f8502fe51321552c3265c57a838.tar.gz
gentoo-2-f9d6aea64c9e4f8502fe51321552c3265c57a838.tar.bz2
gentoo-2-f9d6aea64c9e4f8502fe51321552c3265c57a838.zip
New release: 1.1.17
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'dev-libs/libxslt')
-rw-r--r--dev-libs/libxslt/ChangeLog8
-rw-r--r--dev-libs/libxslt/files/digest-libxslt-1.1.173
-rw-r--r--dev-libs/libxslt/libxslt-1.1.17.ebuild66
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-libs/libxslt/ChangeLog b/dev-libs/libxslt/ChangeLog
index 217e2580a887..b51331bde44f 100644
--- a/dev-libs/libxslt/ChangeLog
+++ b/dev-libs/libxslt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libxslt
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.132 2006/05/19 03:47:54 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.133 2006/06/22 07:09:53 leonardop Exp $
+
+*libxslt-1.1.17 (22 Jun 2006)
+
+ 22 Jun 2006; Leonardo Boshell <leonardop@gentoo.org>
+ +libxslt-1.1.17.ebuild:
+ New release.
*libxslt-1.1.16 (19 May 2006)
diff --git a/dev-libs/libxslt/files/digest-libxslt-1.1.17 b/dev-libs/libxslt/files/digest-libxslt-1.1.17
new file mode 100644
index 000000000000..cb3a60ccf3f7
--- /dev/null
+++ b/dev-libs/libxslt/files/digest-libxslt-1.1.17
@@ -0,0 +1,3 @@
+MD5 af99d7b06eba109ab374ccd7015561c4 libxslt-1.1.17.tar.bz2 1910630
+RMD160 de90b95e5b93df498061d78b85c4ff2a3071d050 libxslt-1.1.17.tar.bz2 1910630
+SHA256 f2ddf1cf7b384f213118bff6403f4465f07e055a52a7bbdadfbe1f67c676de60 libxslt-1.1.17.tar.bz2 1910630
diff --git a/dev-libs/libxslt/libxslt-1.1.17.ebuild b/dev-libs/libxslt/libxslt-1.1.17.ebuild
new file mode 100644
index 000000000000..28526174306c
--- /dev/null
+++ b/dev-libs/libxslt/libxslt-1.1.17.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.17.ebuild,v 1.1 2006/06/22 07:09:53 leonardop Exp $
+
+inherit libtool gnome.org eutils python
+
+DESCRIPTION="XSLT libraries and tools"
+HOMEPAGE="http://www.xmlsoft.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt debug python"
+
+DEPEND=">=dev-libs/libxml2-2.6.25
+ crypt? ( >=dev-libs/libgcrypt-1.1.92 )
+ python? ( dev-lang/python )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # we still require the 1.1.8 patch for the .m4 file, to add
+ # the CXXFLAGS defines <obz@gentoo.org>
+ epatch "${FILESDIR}"/libxslt.m4-${PN}-1.1.8.patch
+
+ # Respect DESTDIR when creating libxslt-plugins directory
+ epatch "${FILESDIR}"/${PN}-1.1.16-destdir.patch
+
+ # Patch Makefile to fix bug #99382 so that html gets installed in ${PF}
+ sed -i -e 's:libxslt-$(VERSION):${PF}:' doc/Makefile.in
+
+ epunt_cxx
+ elibtoolize
+}
+
+src_compile() {
+ # Always pass --with-debugger. It is required by third parties (see
+ # e.g. bug #98345)
+ local myconf="--with-debugger \
+ $(use_with python) \
+ $(use_with crypt crypto) \
+ $(use_with debug) \
+ $(use_with debug mem-debug)"
+
+ econf ${myconf} || die "configure failed"
+
+ # Patching the Makefiles to respect get_libdir
+ # Fixes BUG #86756, please keep this.
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ for x in $(find "${S}" -name "Makefile") ; do
+ sed \
+ -e "s|^\(PYTHON_SITE_PACKAGES\ =\ \/usr\/\).*\(\/python.*\)|\1$(get_libdir)\2|g" \
+ -i ${x} \
+ || die "sed failed"
+ done
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog Copyright FEATURES NEWS README TODO
+}