summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-12-03 09:10:05 +0000
committerNaohiro Aota <naota@gentoo.org>2012-12-03 09:10:05 +0000
commitca3cdf9d7d06b8f710abf72b18473dee79950a0b (patch)
treedf88b0e0bd20cb260d0bb1f06a5af3a6c3a2cfdb /dev-libs/m17n-lib
parentVersion bump wrt #439900 (diff)
downloadgentoo-2-ca3cdf9d7d06b8f710abf72b18473dee79950a0b.tar.gz
gentoo-2-ca3cdf9d7d06b8f710abf72b18473dee79950a0b.tar.bz2
gentoo-2-ca3cdf9d7d06b8f710abf72b18473dee79950a0b.zip
Version bump wrt #439900
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'dev-libs/m17n-lib')
-rw-r--r--dev-libs/m17n-lib/ChangeLog7
-rw-r--r--dev-libs/m17n-lib/m17n-lib-1.6.4.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/dev-libs/m17n-lib/ChangeLog b/dev-libs/m17n-lib/ChangeLog
index 83a00f7593a7..27b4448f8a48 100644
--- a/dev-libs/m17n-lib/ChangeLog
+++ b/dev-libs/m17n-lib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/m17n-lib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/m17n-lib/ChangeLog,v 1.59 2012/12/03 07:13:23 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/m17n-lib/ChangeLog,v 1.60 2012/12/03 09:10:05 naota Exp $
+
+*m17n-lib-1.6.4 (03 Dec 2012)
+
+ 03 Dec 2012; <naota@gentoo.org> +m17n-lib-1.6.4.ebuild:
+ Version bump wrt #439900
03 Dec 2012; <naota@gentoo.org> m17n-lib-1.5.2.ebuild, m17n-lib-1.5.3.ebuild,
m17n-lib-1.5.4.ebuild, m17n-lib-1.5.5.ebuild, m17n-lib-1.6.2.ebuild,
diff --git a/dev-libs/m17n-lib/m17n-lib-1.6.4.ebuild b/dev-libs/m17n-lib/m17n-lib-1.6.4.ebuild
new file mode 100644
index 000000000000..b72914b8eb4c
--- /dev/null
+++ b/dev-libs/m17n-lib/m17n-lib-1.6.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/m17n-lib/m17n-lib-1.6.4.ebuild,v 1.1 2012/12/03 09:10:05 naota Exp $
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="Multilingual Library for Unix/Linux"
+HOMEPAGE="https://savannah.nongnu.org/projects/m17n"
+SRC_URI="http://download.savannah.gnu.org/releases/m17n/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE="anthy athena anthy bidi fontconfig gd spell libotf libxml2 X xft"
+
+RDEPEND="
+ anthy? ( app-i18n/anthy )
+ spell? ( app-text/aspell )
+ libxml2? ( dev-libs/libxml2 )
+ X? (
+ athena? ( x11-libs/libXaw )
+ bidi? ( dev-libs/fribidi )
+ fontconfig? ( media-libs/fontconfig )
+ gd? ( media-libs/gd[png] )
+ libotf? ( >=dev-libs/libotf-0.9.4 )
+ xft? (
+ >=media-libs/freetype-2.1
+ x11-libs/libXft )
+ x11-libs/libX11
+ )
+ ~dev-db/m17n-db-${PV}"
+# athena? ( x11-libs/libXaw )
+# athena shoud be enabled to build m17n-edit properly when X is enabled.
+
+# linguas_th? ( || ( app-i18n/libthai app-i18n/wordcut ) )
+#
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.6.2-gui.patch \
+ "${FILESDIR}"/${PN}-1.6.3-parallel-make.patch \
+ "${FILESDIR}"/${PN}-1.6.3-configure.patch \
+ "${FILESDIR}"/${PN}-1.6.3-ispell.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="$(use_with anthy) $(use_with spell ispell) $(use_with libxml2)"
+
+ if use X; then
+ myconf+=" --with-x --enable-gui $(use_with athena) $(use_with bidi fribidi)
+$(use_with fontconfig) $(use_with xft freetype) $(use_with gd) $(use_with libotf)
+$(use_with xft)"
+ else
+ myconf+=" --without-x --disable-gui --without-athena --without-fribidi
+--without-fontconfig --without-freetype --without-gd --without-libotf
+--without-xft"
+ fi
+
+ econf ${myconf} || die
+}
+
+src_install() {
+ # bug #363239
+ emake -j1 DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}