summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-19 04:19:14 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-19 04:19:14 +0000
commit1e644f45746e6e7d4677d2adfbcce74afa2655e9 (patch)
tree3660735891644d45d2d382149b04f85c966fd08a /dev-libs/mpfr/mpfr-2.2.0_p4.ebuild
parentVersion bump. (diff)
downloadgentoo-2-1e644f45746e6e7d4677d2adfbcce74afa2655e9.tar.gz
gentoo-2-1e644f45746e6e7d4677d2adfbcce74afa2655e9.tar.bz2
gentoo-2-1e644f45746e6e7d4677d2adfbcce74afa2655e9.zip
split mpfr out from gmp
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'dev-libs/mpfr/mpfr-2.2.0_p4.ebuild')
-rw-r--r--dev-libs/mpfr/mpfr-2.2.0_p4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/mpfr/mpfr-2.2.0_p4.ebuild b/dev-libs/mpfr/mpfr-2.2.0_p4.ebuild
new file mode 100644
index 000000000000..b4bd04b9c7da
--- /dev/null
+++ b/dev-libs/mpfr/mpfr-2.2.0_p4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpfr/mpfr-2.2.0_p4.ebuild,v 1.1 2005/10/19 04:19:14 vapier Exp $
+
+inherit eutils
+
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
+PLEVEL=${PV/*p}
+DESCRIPTION="library for multiple-precision floating-point computations with exact rounding"
+HOMEPAGE="http://www.mpfr.org/"
+SRC_URI="http://www.mpfr.org/mpfr-current/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-libs/gmp-4.1.0"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ for ((i=1; i<=PLEVEL; ++i)) ; do
+ epatch "${FILESDIR}"/${MY_PV}/patch$(printf '%02d' ${i})
+ done
+}
+
+src_compile() {
+ econf \
+ --enable-shared \
+ --enable-static \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+ dohtml *.html
+}