summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-29 10:52:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-29 10:52:52 +0000
commit51cee15e7ae80497f46c09ec3d446bc53e473c17 (patch)
treeb13732d24327cd39da3bc8750999b24b5ca413d0 /dev-libs/nettle/nettle-2.0.ebuild
parentamd64 stable, bug 311837 (diff)
downloadgentoo-2-51cee15e7ae80497f46c09ec3d446bc53e473c17.tar.gz
gentoo-2-51cee15e7ae80497f46c09ec3d446bc53e473c17.tar.bz2
gentoo-2-51cee15e7ae80497f46c09ec3d446bc53e473c17.zip
Fix building with -Wl,--as-needed wrt #285747 by Kacper Kowalik.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/nettle/nettle-2.0.ebuild')
-rw-r--r--dev-libs/nettle/nettle-2.0.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-libs/nettle/nettle-2.0.ebuild b/dev-libs/nettle/nettle-2.0.ebuild
index 3d82e56a507e..c910510b1444 100644
--- a/dev-libs/nettle/nettle-2.0.ebuild
+++ b/dev-libs/nettle/nettle-2.0.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.0.ebuild,v 1.7 2010/01/14 21:26:17 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.0.ebuild,v 1.8 2010/03/29 10:52:52 ssuominen Exp $
-EAPI="2"
-
-inherit autotools
+EAPI=2
+inherit autotools eutils
DESCRIPTION="cryptographic library that is designed to fit easily in any context"
HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
@@ -21,9 +20,10 @@ DEPEND="gmp? ( dev-libs/gmp )
RDEPEND="${DEPEND}"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
sed -i \
-e '/CFLAGS/s:-ggdb3::' \
- configure.ac || die "sed configure.ac failed"
+ configure.ac || die
eautoreconf
}
@@ -35,6 +35,6 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS README
}