summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2014-12-03 11:17:39 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2014-12-03 11:17:39 +0000
commit52838b178873829d1d8190fe923b0fd3f61f864f (patch)
tree2bc209ce09877c500b591d6c7f726dc117b0f143 /dev-libs/nettle
parentapp-text/pdfgrep: Version BUmp, #531428 (diff)
downloadgentoo-2-52838b178873829d1d8190fe923b0fd3f61f864f.tar.gz
gentoo-2-52838b178873829d1d8190fe923b0fd3f61f864f.tar.bz2
gentoo-2-52838b178873829d1d8190fe923b0fd3f61f864f.zip
Use autotools-utils to perform autoreconf, add einstalldocs at multilib, bug#531522
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'dev-libs/nettle')
-rw-r--r--dev-libs/nettle/ChangeLog8
-rw-r--r--dev-libs/nettle/nettle-2.7.1-r2.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-libs/nettle/ChangeLog b/dev-libs/nettle/ChangeLog
index 7fd1a57a50ee..a1cf62a05550 100644
--- a/dev-libs/nettle/ChangeLog
+++ b/dev-libs/nettle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/nettle
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.112 2014/12/02 21:21:38 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.113 2014/12/03 11:17:39 alonbl Exp $
+
+*nettle-2.7.1-r2 (03 Dec 2014)
+
+ 03 Dec 2014; Alon Bar-Lev <alonbl@gentoo.org> +nettle-2.7.1-r2.ebuild:
+ Use autotools-utils to perform autoreconf, add einstalldocs at multilib,
+ bug#531522
*nettle-1.15 (02 Dec 2014)
diff --git a/dev-libs/nettle/nettle-2.7.1-r2.ebuild b/dev-libs/nettle/nettle-2.7.1-r2.ebuild
new file mode 100644
index 000000000000..9dd20c294025
--- /dev/null
+++ b/dev-libs/nettle/nettle-2.7.1-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.7.1-r2.ebuild,v 1.1 2014/12/03 11:17:39 alonbl Exp $
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=yes
+
+inherit eutils autotools-multilib multilib toolchain-funcs
+
+DESCRIPTION="Low-level cryptographic library"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
+SRC_URI="http://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 LGPL-2.1 )"
+SLOT="0/4" # subslot = libnettle soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x86-solaris"
+IUSE="doc +gmp neon static-libs test"
+
+DEPEND="gmp? ( dev-libs/gmp )"
+RDEPEND="${DEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20131008-r17
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+
+src_prepare() {
+ tc-is-static-only || epatch "${FILESDIR}"/${PN}-2.7-shared.patch
+
+ sed -e '/CFLAGS=/s: -ggdb3::' \
+ -e 's/solaris\*)/sunldsolaris*)/' \
+ -i configure.ac || die
+
+ # conditionally build tests and examples required by tests
+ use test || sed -i '/SUBDIRS/s/testsuite examples//' Makefile.in || die
+
+ autotools-utils_src_prepare
+}
+
+multilib_src_configure() {
+ # --disable-openssl bug #427526
+ ECONF_SOURCE="${S}" econf \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ $(use_enable gmp public-key) \
+ $(use_enable static-libs static) \
+ --disable-openssl \
+ $(tc-is-static-only && echo --disable-shared) \
+ $(use_enable doc documentation) \
+ $(use_enable neon arm-neon)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ if use doc ; then
+ dohtml nettle.html
+ dodoc nettle.pdf
+ fi
+}