summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-11-15 13:28:00 +0000
committerMichael Weber <xmw@gentoo.org>2014-11-15 13:28:00 +0000
commit5919f5c1b2da4934d6e02ae65201093e242c8755 (patch)
treeb26a8cdcf14c23c94ec16ca105c3ebbdf62a5fb7 /dev-libs/nsgenbind
parentStable for HPPA (bug #529240). (diff)
downloadgentoo-2-5919f5c1b2da4934d6e02ae65201093e242c8755.tar.gz
gentoo-2-5919f5c1b2da4934d6e02ae65201093e242c8755.tar.bz2
gentoo-2-5919f5c1b2da4934d6e02ae65201093e242c8755.zip
Version bump, buildsystem bump, glibc-2.20 issue, respect USE-flags (thanks mgorny, bug 513598)
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'dev-libs/nsgenbind')
-rw-r--r--dev-libs/nsgenbind/ChangeLog11
-rw-r--r--dev-libs/nsgenbind/files/nsgenbind-0.1.1-glibc2.20.patch17
-rw-r--r--dev-libs/nsgenbind/nsgenbind-0.1.1.ebuild20
3 files changed, 46 insertions, 2 deletions
diff --git a/dev-libs/nsgenbind/ChangeLog b/dev-libs/nsgenbind/ChangeLog
index fb0f69b336cd..c8fa97bf0c58 100644
--- a/dev-libs/nsgenbind/ChangeLog
+++ b/dev-libs/nsgenbind/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/nsgenbind
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nsgenbind/ChangeLog,v 1.2 2013/06/23 16:46:30 xmw Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nsgenbind/ChangeLog,v 1.3 2014/11/15 13:28:00 xmw Exp $
+
+*nsgenbind-0.1.1 (15 Nov 2014)
+
+ 15 Nov 2014; Michael Weber <xmw@gentoo.org>
+ +files/nsgenbind-0.1.1-glibc2.20.patch, +nsgenbind-0.1.1.ebuild:
+ Version bump, buildsystem bump, glibc-2.20 issue, respect USE-flags (thanks
+ mgorny, bug 513598)
23 Jun 2013; Michael Weber <xmw@gentoo.org> nsgenbind-0.0.1.ebuild:
Migrate to netsurf.eclass
diff --git a/dev-libs/nsgenbind/files/nsgenbind-0.1.1-glibc2.20.patch b/dev-libs/nsgenbind/files/nsgenbind-0.1.1-glibc2.20.patch
new file mode 100644
index 000000000000..05e0a3b962fb
--- /dev/null
+++ b/dev-libs/nsgenbind/files/nsgenbind-0.1.1-glibc2.20.patch
@@ -0,0 +1,17 @@
+--- nsgenbind-0.1.1/Makefile
++++ nsgenbind-0.1.1/Makefile
+@@ -16,13 +16,7 @@
+ WARNFLAGS := -Wall -W -Wundef -Wpointer-arith -Wcast-align \
+ -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes \
+ -Wmissing-declarations -Wnested-externs
+-# BeOS/Haiku/AmigaOS have standard library errors that issue warnings.
+-ifneq ($(TARGET),beos)
+- ifneq ($(TARGET),amiga)
+-# WARNFLAGS := $(WARNFLAGS) -Werror
+- endif
+-endif
+-CFLAGS := -D_BSD_SOURCE -D_POSIX_C_SOURCE=200809L -I$(CURDIR)/include/ \
++CFLAGS := -D_DEFAULT_SOURCE -D_POSIX_C_SOURCE=200809L -I$(CURDIR)/include/ \
+ -I$(CURDIR)/src $(WARNFLAGS) $(CFLAGS)
+ ifneq ($(GCCVER),2)
+ CFLAGS := $(CFLAGS) -std=c99
diff --git a/dev-libs/nsgenbind/nsgenbind-0.1.1.ebuild b/dev-libs/nsgenbind/nsgenbind-0.1.1.ebuild
new file mode 100644
index 000000000000..fc0fcc3cf5cb
--- /dev/null
+++ b/dev-libs/nsgenbind/nsgenbind-0.1.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nsgenbind/nsgenbind-0.1.1.ebuild,v 1.1 2014/11/15 13:28:00 xmw Exp $
+
+EAPI=5
+NETSURF_COMPONENT_TYPE=binary
+NETSURF_BUILDSYSTEM=buildsystem-1.2
+inherit netsurf
+
+DESCRIPTION="generate javascript to dom bindings from w3c webidl files"
+HOMEPAGE="http://www.netsurf-browser.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+DEPEND="virtual/yacc"
+
+PATCHES=( "${FILESDIR}"/${P}-glibc2.20.patch )