summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-04-29 20:56:27 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-04-29 20:56:27 +0000
commit7ce836432b3190c1aa24ccccc8dc4adf670bd426 (patch)
tree3789a80c6f9839af9bae7adbe0497683db03c80e /dev-libs/nspr/nspr-4.7.3.ebuild
parentadd missing dependency on app-text/gnome-doc-utils (diff)
downloadgentoo-2-7ce836432b3190c1aa24ccccc8dc4adf670bd426.tar.gz
gentoo-2-7ce836432b3190c1aa24ccccc8dc4adf670bd426.tar.bz2
gentoo-2-7ce836432b3190c1aa24ccccc8dc4adf670bd426.zip
make repoman happy and set RDEPEND explicitly
(Portage version: 2.1.6.11/cvs/Linux i686)
Diffstat (limited to 'dev-libs/nspr/nspr-4.7.3.ebuild')
-rw-r--r--dev-libs/nspr/nspr-4.7.3.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-libs/nspr/nspr-4.7.3.ebuild b/dev-libs/nspr/nspr-4.7.3.ebuild
index a2f79d79c8b3..d076b958c233 100644
--- a/dev-libs/nspr/nspr-4.7.3.ebuild
+++ b/dev-libs/nspr/nspr-4.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.7.3.ebuild,v 1.8 2009/04/12 14:56:15 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.7.3.ebuild,v 1.9 2009/04/29 20:56:27 fauli Exp $
inherit eutils multilib toolchain-funcs
@@ -14,6 +14,7 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="ipv6 debug"
DEPEND=">=dev-db/sqlite-3.5"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
@@ -35,9 +36,9 @@ src_compile() {
echo > "${T}"/test.c
$(tc-getCC) -c "${T}"/test.c -o "${T}"/test.o
case $(file "${T}"/test.o) in
- *64-bit*) myconf="${myconf} --enable-64bit";;
- *32-bit*) ;;
- *) die "Failed to detect whether your arch is 64bits or 32bits, disable distcc if you're using it, please";;
+ *64-bit*) myconf="${myconf} --enable-64bit";;
+ *32-bit*) ;;
+ *) die "Failed to detect whether your arch is 64bits or 32bits, disable distcc if you're using it, please";;
esac
if use ipv6; then