summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2012-12-15 21:25:32 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2012-12-15 21:25:32 +0000
commit9ef48d749d5e85d9571f5f099242b542e90c6073 (patch)
tree093ba90b374f37d7df1024ece0ae4ae4eb71c0a9 /dev-libs/opencryptoki
parentUpdate LICENSE, see license notices in source files. (diff)
downloadgentoo-2-9ef48d749d5e85d9571f5f099242b542e90c6073.tar.gz
gentoo-2-9ef48d749d5e85d9571f5f099242b542e90c6073.tar.bz2
gentoo-2-9ef48d749d5e85d9571f5f099242b542e90c6073.zip
Version bump
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/opencryptoki')
-rw-r--r--dev-libs/opencryptoki/ChangeLog9
-rw-r--r--dev-libs/opencryptoki/files/opencryptoki-2.4.2-destdir.patch26
-rw-r--r--dev-libs/opencryptoki/opencryptoki-2.4.2.ebuild100
3 files changed, 133 insertions, 2 deletions
diff --git a/dev-libs/opencryptoki/ChangeLog b/dev-libs/opencryptoki/ChangeLog
index bd4304f28952..bde415388818 100644
--- a/dev-libs/opencryptoki/ChangeLog
+++ b/dev-libs/opencryptoki/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/opencryptoki
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/opencryptoki/ChangeLog,v 1.23 2012/06/06 03:43:03 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/opencryptoki/ChangeLog,v 1.24 2012/12/15 21:25:32 alonbl Exp $
+
+*opencryptoki-2.4.2 (15 Dec 2012)
+
+ 15 Dec 2012; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/opencryptoki-2.4.2-destdir.patch, +opencryptoki-2.4.2.ebuild:
+ Version bump
06 Jun 2012; Zac Medico <zmedico@gentoo.org> opencryptoki-2.3.3-r5.ebuild:
inherit user for enewgroup
@@ -126,4 +132,3 @@
03 Jun 2006; Petre Rodan <kaiowas@gentoo.org> +files/pkcsslotd.init,
+metadata.xml, +opencryptoki-2.2.4-r1.ebuild:
initial commit
-
diff --git a/dev-libs/opencryptoki/files/opencryptoki-2.4.2-destdir.patch b/dev-libs/opencryptoki/files/opencryptoki-2.4.2-destdir.patch
new file mode 100644
index 000000000000..e1375c7130bc
--- /dev/null
+++ b/dev-libs/opencryptoki/files/opencryptoki-2.4.2-destdir.patch
@@ -0,0 +1,26 @@
+From fcc24176398ab2f40c33ebc686c2f803782af8d6 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Sat, 15 Dec 2012 22:13:56 +0200
+Subject: [PATCH] Always use DESTDIR when installing
+
+---
+ usr/Makefile.am | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/usr/Makefile.am b/usr/Makefile.am
+index bced120..20352d5 100644
+--- a/usr/Makefile.am
++++ b/usr/Makefile.am
+@@ -5,6 +5,6 @@ endif
+ SUBDIRS = lib $(DAEMONDIRS)
+
+ install-data-hook:
+- $(MKDIR_P) $(lockdir)
+- $(CHGRP) pkcs11 $(lockdir)
+- $(CHMOD) 0770 $(lockdir)
++ $(MKDIR_P) $(DESTDIR)$(lockdir)
++ $(CHGRP) pkcs11 $(DESTDIR)$(lockdir)
++ $(CHMOD) 0770 $(DESTDIR)$(lockdir)
+--
+1.7.8.6
+
diff --git a/dev-libs/opencryptoki/opencryptoki-2.4.2.ebuild b/dev-libs/opencryptoki/opencryptoki-2.4.2.ebuild
new file mode 100644
index 000000000000..62b2bc7ddafb
--- /dev/null
+++ b/dev-libs/opencryptoki/opencryptoki-2.4.2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/opencryptoki/opencryptoki-2.4.2.ebuild,v 1.1 2012/12/15 21:25:32 alonbl Exp $
+
+EAPI="2"
+
+inherit autotools eutils multilib flag-o-matic user
+
+DESCRIPTION="PKCS#11 provider cryptographic hardware"
+HOMEPAGE="http://sourceforge.net/projects/opencryptoki"
+SRC_URI="mirror://sourceforge/opencryptoki/${P}.tar.gz"
+
+# Upstream is looking into relicensing it into CPL-1.0 entirely; the CCA
+# token sources are under CPL-1.0 already.
+LICENSE="CPL-0.5"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="tpm? ( app-crypt/trousers )
+ dev-libs/openssl"
+DEPEND="${RDEPEND}"
+
+IUSE="+tpm debug"
+
+# tests right now basically don't exist; the only available thing would
+# test against an installed copy and would kill a running pcscd, all
+# things that we're not interested to.
+RESTRICT=test
+
+pkg_setup() {
+ enewgroup pkcs11
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-destdir.patch"
+ eautoreconf
+}
+
+src_configure() {
+ # package uses ${localstatedir}/lib as the default path, so if we
+ # leave it to econf, it'll create /var/lib/lib.
+
+ # Since upstream by default seem to enable any possible token, even
+ # when they don't seem to be used, we limit ourselves to the
+ # software emulation token (swtok) and if the user enabled the tpm
+ # USE flag, tpmtok. The rest of the tokens seem to be hardware- or
+ # software-dependent even when they build fine without their
+ # requirements, but until somebody asks for those, I'd rather not
+ # enable them.
+
+ # We don't use --enable-debug because that tinkers with the CFLAGS
+ # and we don't want that. Instead we append -DDEBUG which enables
+ # debug information.
+ use debug && append-flags -DDEBUG
+
+ econf \
+ --localstatedir=/var \
+ --enable-fast-install \
+ --disable-dependency-tracking \
+ --disable-debug \
+ --enable-daemon \
+ --enable-library \
+ --disable-icatok \
+ --enable-swtok \
+ $(use_enable tpm tpmtok) \
+ --disable-aeptok \
+ --disable-bcomtok \
+ --disable-ccatok \
+ --disable-crtok \
+ --disable-icctok \
+ --disable-pkcscca_migrate
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ # Install libopencryptoki in the standard directory for libraries.
+ mv "${D}"/usr/$(get_libdir)/opencryptoki/libopencryptoki.so* "${D}"/usr/$(get_libdir) || die
+ rm "${D}"/usr/$(get_libdir)/pkcs11/libopencryptoki.so
+ dosym ../libopencryptoki.so /usr/$(get_libdir)/pkcs11/libopencryptoki.so
+
+ # Remove compatibility symlinks as we _never_ required those and
+ # they seem unused even upstream.
+ find "${D}" -name 'PKCS11_*' -delete
+
+ # doesn't use libltdl; only dlopen()-based interfaces
+ find "${D}" -name '*.la' -delete
+
+ # We replace their ld.so and init files (mostly designed for RedHat
+ # as far as I can tell) with our own replacements.
+ rm -rf "${D}"/etc/ld.so.conf.d "${D}"/etc/rc.d
+
+ # make sure that we don't modify the init script if the USE flags
+ # are enabled for the needed services.
+ cp "${FILESDIR}"/pkcsslotd.init.2 "${T}"/pkcsslotd.init
+ use tpm || sed -i -e '/use tcsd/d' "${T}"/pkcsslotd.init
+ newinitd "${T}/pkcsslotd.init" pkcsslotd
+
+ dodoc README AUTHORS FAQ TODO doc/openCryptoki-HOWTO.pdf || die
+}