summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2009-03-21 11:58:42 +0000
committerTiziano Müller <dev-zero@gentoo.org>2009-03-21 11:58:42 +0000
commit0619a9b979061d37c91fad5b633e421fcc2eb03e (patch)
treefffbeb57855b06c5740796edf5ad40603d4eb2bf /dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild
parentRe-add ~alpha/~ia64 since qt-webkit needs it (diff)
downloadgentoo-2-0619a9b979061d37c91fad5b633e421fcc2eb03e.tar.gz
gentoo-2-0619a9b979061d37c91fad5b633e421fcc2eb03e.tar.bz2
gentoo-2-0619a9b979061d37c91fad5b633e421fcc2eb03e.zip
Version bump.
(Portage version: 2.1.6.8/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild')
-rw-r--r--dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild b/dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild
new file mode 100644
index 000000000000..75275448bd58
--- /dev/null
+++ b/dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild,v 1.1 2009/03/21 11:58:42 dev-zero Exp $
+
+EAPI="1"
+
+PHP_EXT_NAME="uuid"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_VERSION="5"
+
+inherit eutils multilib php-ext-source-r1 depend.php
+
+MY_P="uuid-${PV}"
+
+DESCRIPTION="An ISO-C:1999 API and corresponding CLI for the generation of DCE 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant UUID."
+HOMEPAGE="http://www.ossp.org/pkg/lib/uuid/"
+SRC_URI="ftp://ftp.ossp.org/pkg/lib/uuid/${MY_P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="+cxx php"
+
+DEPEND="php? ( dev-lang/php:5 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ if use php; then
+ cd php
+ php-ext-source-r1_phpize
+ fi
+}
+
+src_compile() {
+ # Notes:
+ # * collides with e2fstools libs and includes if not moved around
+ # * perl-bindings are broken
+ # * pgsql-bindings need PostgreSQL-sources and are included since PostgreSQL 8.3
+ econf \
+ --includedir=/usr/include/ossp \
+ --with-dce \
+ --without-pgsql \
+ --without-perl \
+ --without-php \
+ $(use_with cxx) \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ if use php; then
+ cd php
+ php-ext-source-r1_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BINDINGS ChangeLog HISTORY NEWS OVERVIEW PORTING README SEEALSO THANKS TODO USERS
+
+ if use php ; then
+ cd php
+ php-ext-source-r1_src_install
+ insinto /usr/share/php5
+ newins uuid.php5 uuid.php
+ fi
+
+ mv "${D}/usr/$(get_libdir)/pkgconfig"/{,ossp-}uuid.pc
+ mv "${D}/usr/share/man/man3"/uuid.3{,ossp}
+ mv "${D}/usr/share/man/man3"/uuid++.3{,ossp}
+}
+
+src_test() {
+ emake check || die "emake check failed"
+ # Tests for the php-bindings would be available
+}