summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-28 22:08:55 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-28 22:08:55 +0000
commitea55e95efbd423c8356883ecb5688e6d2b08ef8b (patch)
treeef63c3c60c0c0680be4ec36eeb530139da2ad232 /dev-libs/pth
parentBump dejavu to last version, use versionator to support 3-parts versions (the... (diff)
downloadgentoo-2-ea55e95efbd423c8356883ecb5688e6d2b08ef8b.tar.gz
gentoo-2-ea55e95efbd423c8356883ecb5688e6d2b08ef8b.tar.bz2
gentoo-2-ea55e95efbd423c8356883ecb5688e6d2b08ef8b.zip
Add patch to respect ldflags and run elibtoolize, bug #127916.
(Portage version: 2.1_pre7-r2)
Diffstat (limited to 'dev-libs/pth')
-rw-r--r--dev-libs/pth/ChangeLog6
-rw-r--r--dev-libs/pth/files/pth-2.0.6-ldflags.patch17
-rw-r--r--dev-libs/pth/pth-2.0.6.ebuild8
3 files changed, 28 insertions, 3 deletions
diff --git a/dev-libs/pth/ChangeLog b/dev-libs/pth/ChangeLog
index 5d2da40152e7..f31af6b95be4 100644
--- a/dev-libs/pth/ChangeLog
+++ b/dev-libs/pth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/pth
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/ChangeLog,v 1.36 2006/02/06 00:10:21 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/ChangeLog,v 1.37 2006/03/28 22:08:55 flameeyes Exp $
+
+ 28 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/pth-2.0.6-ldflags.patch, pth-2.0.6.ebuild:
+ Add patch to respect ldflags and run elibtoolize, bug #127916.
*pth-2.0.6 (06 Feb 2006)
diff --git a/dev-libs/pth/files/pth-2.0.6-ldflags.patch b/dev-libs/pth/files/pth-2.0.6-ldflags.patch
new file mode 100644
index 000000000000..7a4a5ab30000
--- /dev/null
+++ b/dev-libs/pth/files/pth-2.0.6-ldflags.patch
@@ -0,0 +1,17 @@
+Index: pth-2.0.6/Makefile.in
+===================================================================
+--- pth-2.0.6.orig/Makefile.in
++++ pth-2.0.6/Makefile.in
+@@ -168,10 +168,10 @@ pth_p.h: $(S)pth_p.h.in
+
+ # build the static and possibly shared libraries
+ libpth.la: $(LOBJS)
+- $(LIBTOOL) --mode=link --quiet $(CC) -o libpth.la $(LOBJS) \
++ $(LIBTOOL) --mode=link --quiet $(CC) $(LDFLAGS) -o libpth.la $(LOBJS) \
+ -rpath $(libdir) -version-info `$(SHTOOL) version -lc -dlibtool $(_VERSION_FILE)`
+ libpthread.la: pthread.lo $(LOBJS)
+- $(LIBTOOL) --mode=link --quiet $(CC) -o libpthread.la pthread.lo $(LOBJS) \
++ $(LIBTOOL) --mode=link --quiet $(CC) $(LDFLAGS) -o libpthread.la pthread.lo $(LOBJS) \
+ -rpath $(libdir) -version-info `$(SHTOOL) version -lc -dlibtool $(_VERSION_FILE)`
+
+ # build the manual pages
diff --git a/dev-libs/pth/pth-2.0.6.ebuild b/dev-libs/pth/pth-2.0.6.ebuild
index d02648f02adf..f38591b964f0 100644
--- a/dev-libs/pth/pth-2.0.6.ebuild
+++ b/dev-libs/pth/pth-2.0.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-2.0.6.ebuild,v 1.1 2006/02/06 00:10:21 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-2.0.6.ebuild,v 1.2 2006/03/28 22:08:55 flameeyes Exp $
-inherit eutils fixheadtails
+inherit eutils fixheadtails libtool
DESCRIPTION="GNU Portable Threads"
HOMEPAGE="http://www.gnu.org/software/pth/"
@@ -19,7 +19,11 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-2.0.5-parallelfix.patch
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+
ht_fix_file aclocal.m4 configure
+
+ elibtoolize
}
src_install() {