summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2009-11-08 17:11:53 +0000
committerDominik Kapusta <ayoy@gentoo.org>2009-11-08 17:11:53 +0000
commita6a6e5d950a9f1a808ad56d8f71f7302d393a7fb (patch)
tree084f0de1a5801c6181164e3fa617f27f05a1dfa9 /dev-libs/qjson/qjson-0.6.3.ebuild
parentStable on alpha, bug #289960 (diff)
downloadgentoo-2-a6a6e5d950a9f1a808ad56d8f71f7302d393a7fb.tar.gz
gentoo-2-a6a6e5d950a9f1a808ad56d8f71f7302d393a7fb.tar.bz2
gentoo-2-a6a6e5d950a9f1a808ad56d8f71f7302d393a7fb.zip
Version bump, remove old ebuilds
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/qjson/qjson-0.6.3.ebuild')
-rw-r--r--dev-libs/qjson/qjson-0.6.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/qjson/qjson-0.6.3.ebuild b/dev-libs/qjson/qjson-0.6.3.ebuild
new file mode 100644
index 000000000000..aaaf299f83ee
--- /dev/null
+++ b/dev-libs/qjson/qjson-0.6.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qjson/qjson-0.6.3.ebuild,v 1.1 2009/11/08 17:11:53 ayoy Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="A library for mapping JSON data to QVariant objects"
+HOMEPAGE="http://qjson.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="debug doc test"
+
+RDEPEND="x11-libs/qt-core:4"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( x11-libs/qt-test:4 )"
+
+S="${WORKDIR}/${PN}"
+DOCS=( "${S}/README" )
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use test QJSON_BUILD_TESTS)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ if use doc; then
+ cd "${S}/doc"
+ doxygen Doxyfile || die "Generating documentation failed"
+ HTML_DOCS=( "${S}/doc/html/*" )
+ fi
+
+ cmake-utils_src_install
+}