summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Anderson <gentoofan23@gentoo.org>2009-05-23 10:54:17 +0000
committerThomas Anderson <gentoofan23@gentoo.org>2009-05-23 10:54:17 +0000
commit07327df33dba9936a68332ade0e7069781823a64 (patch)
tree48757aba361f04341449b513e1cc5a437fc2375f /dev-libs/stfl
parentx86 stable, bug #270811 (diff)
downloadgentoo-2-07327df33dba9936a68332ade0e7069781823a64.tar.gz
gentoo-2-07327df33dba9936a68332ade0e7069781823a64.tar.bz2
gentoo-2-07327df33dba9936a68332ade0e7069781823a64.zip
Remove mention of stfl.pyc from Makefiles and stop automatic generation of stfl.pyc by doing 'python -c stfl' in the buildsystem. Also fix a parallel build bug produced (partly) by the stfl.pyc stuff. Thanks to Christian Weiske for the report in bug #262006 and Ihar Hrachyshka for the initial patch.
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/stfl')
-rw-r--r--dev-libs/stfl/ChangeLog10
-rw-r--r--dev-libs/stfl/files/stfl-0.19-multilib.patch55
-rw-r--r--dev-libs/stfl/stfl-0.19.ebuild11
3 files changed, 59 insertions, 17 deletions
diff --git a/dev-libs/stfl/ChangeLog b/dev-libs/stfl/ChangeLog
index 6bae3551f6c2..0182d56b4659 100644
--- a/dev-libs/stfl/ChangeLog
+++ b/dev-libs/stfl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/stfl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/ChangeLog,v 1.21 2009/03/07 19:23:13 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/ChangeLog,v 1.22 2009/05/23 10:54:17 gentoofan23 Exp $
+
+ 23 May 2009; Thomas Anderson <gentoofan23@gentoo.org>
+ files/stfl-0.19-multilib.patch, stfl-0.19.ebuild:
+ Remove mention of stfl.pyc from Makefiles and stop automatic generation of
+ stfl.pyc by doing 'python -c stfl' in the buildsystem. Also fix a parallel
+ build bug produced (partly) by the stfl.pyc stuff. Thanks to Christian
+ Weiske for the report in bug #262006 and Ihar Hrachyshka for the initial
+ patch.
07 Mar 2009; Thomas Anderson <gentoofan23@gentoo.org> stfl-0.17.ebuild,
stfl-0.18.ebuild, stfl-0.19.ebuild:
diff --git a/dev-libs/stfl/files/stfl-0.19-multilib.patch b/dev-libs/stfl/files/stfl-0.19-multilib.patch
index a32b09f0f566..d1c01e7c2e3d 100644
--- a/dev-libs/stfl/files/stfl-0.19-multilib.patch
+++ b/dev-libs/stfl/files/stfl-0.19-multilib.patch
@@ -1,7 +1,17 @@
-diff -aur stfl-0.19-orig/Makefile stfl-0.19/Makefile
---- stfl-0.19-orig/Makefile 2007-09-19 19:24:14.000000000 -0400
-+++ stfl-0.19/Makefile 2008-09-02 20:05:10.000000000 -0400
-@@ -50,9 +50,9 @@
+diff --git stfl-0.19/Makefile stfl-0.19-ta/Makefile
+index f098187..80dd338 100644
+--- stfl-0.19/Makefile
++++ stfl-0.19-ta/Makefile
+@@ -39,7 +39,7 @@ clean:
+ rm -f widgets/*.o spl/mod_stfl.so spl/example.db
+ cd perl5 && perl Makefile.PL && make clean && rm -f Makefile.old
+ rm -f perl5/stfl_wrap.c perl5/stfl.pm perl5/build_ok
+- rm -f python/stfl.py python/stfl.pyc python/_stfl.so
++ rm -f python/stfl.py python/_stfl.so
+ rm -f python/stfl_wrap.c python/stfl_wrap.o
+ rm -f ruby/Makefile ruby/stfl_wrap.c ruby/stfl_wrap.o
+ rm -f ruby/stfl.so ruby/build_ok Makefile.deps_new
+@@ -50,9 +50,9 @@ Makefile.deps: *.c widgets/*.c *.h
mv -f Makefile.deps_new Makefile.deps
install: all
@@ -13,26 +23,41 @@ diff -aur stfl-0.19-orig/Makefile stfl-0.19/Makefile
install -m 644 stfl.h $(DESTDIR)$(prefix)/include/
ifeq ($(FOUND_SPL),1)
-diff -aur stfl-0.19-orig/python/Makefile.snippet stfl-0.19/python/Makefile.snippet
---- stfl-0.19-orig/python/Makefile.snippet 2007-09-03 12:13:04.000000000 -0400
-+++ stfl-0.19/python/Makefile.snippet 2008-09-02 20:00:40.000000000 -0400
-@@ -32,8 +32,8 @@
- cd python && python -c 'import stfl'
+diff --git stfl-0.19/python/Makefile.snippet stfl-0.19-ta/python/Makefile.snippet
+index 65e7a3d..a8d830c 100644
+--- stfl-0.19/python/Makefile.snippet
++++ stfl-0.19-ta/python/Makefile.snippet
+@@ -21,19 +21,17 @@
- install_python: python/_stfl.so python/stfl.py python/stfl.pyc
+ PYTHON_VERSION = $(shell python -V 2>&1 | cut -f2 -d' ' | cut -f1-2 -d'.')
+
+-all: python/_stfl.so python/stfl.py python/stfl.pyc
++all: python/_stfl.so python/stfl.py
+
+ install: install_python
+
+-python/_stfl.so python/stfl.py python/stfl.pyc: libstfl.a stfl.h python/stfl.i swig/*.i
++python/_stfl.so python/stfl.py: libstfl.a stfl.h python/stfl.i swig/*.i
+ cd python && swig -python stfl.i
+ gcc -shared -pthread -fPIC python/stfl_wrap.c -I/usr/include/python$(PYTHON_VERSION) \
+ -I. libstfl.a -lncursesw -o python/_stfl.so
+- cd python && python -c 'import stfl'
+
+-install_python: python/_stfl.so python/stfl.py python/stfl.pyc
- mkdir -p $(DESTDIR)$(prefix)/lib/python$(PYTHON_VERSION)/lib-dynload/
- cp python/_stfl.so $(DESTDIR)$(prefix)/lib/python$(PYTHON_VERSION)/lib-dynload/
- cp python/stfl.pyc $(DESTDIR)$(prefix)/lib/python$(PYTHON_VERSION)/
- cp python/stfl.py $(DESTDIR)$(prefix)/lib/python$(PYTHON_VERSION)/
++install_python: python/_stfl.so python/stfl.py
+ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/python$(PYTHON_VERSION)/lib-dynload/
+ cp python/_stfl.so $(DESTDIR)$(prefix)/$(LIBDIR)/python$(PYTHON_VERSION)/lib-dynload/
-+ cp python/stfl.pyc $(DESTDIR)$(prefix)/$(LIBDIR)/python$(PYTHON_VERSION)/
+ cp python/stfl.py $(DESTDIR)$(prefix)/$(LIBDIR)/python$(PYTHON_VERSION)/
-diff -aur stfl-0.19-orig/ruby/Makefile.snippet stfl-0.19/ruby/Makefile.snippet
---- stfl-0.19-orig/ruby/Makefile.snippet 2007-09-03 12:13:04.000000000 -0400
-+++ stfl-0.19/ruby/Makefile.snippet 2008-09-02 20:02:40.000000000 -0400
-@@ -25,9 +25,9 @@
+diff --git stfl-0.19/ruby/Makefile.snippet stfl-0.19-ta/ruby/Makefile.snippet
+index 74dfa9b..f0ced6f 100644
+--- stfl-0.19/ruby/Makefile.snippet
++++ stfl-0.19-ta/ruby/Makefile.snippet
+@@ -25,9 +25,9 @@ install: install_ruby
ruby/build_ok: libstfl.a stfl.h ruby/stfl.i swig/*.i
cd ruby && swig -ruby stfl.i && ruby extconf.rb
diff --git a/dev-libs/stfl/stfl-0.19.ebuild b/dev-libs/stfl/stfl-0.19.ebuild
index cafad55a0bfc..e90bb52e3f32 100644
--- a/dev-libs/stfl/stfl-0.19.ebuild
+++ b/dev-libs/stfl/stfl-0.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/stfl-0.19.ebuild,v 1.4 2009/03/07 19:23:13 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/stfl-0.19.ebuild,v 1.5 2009/05/23 10:54:17 gentoofan23 Exp $
EAPI="2"
inherit eutils multilib perl-module python toolchain-funcs
@@ -54,6 +54,7 @@ src_compile() {
}
src_install() {
+ python_version
emake prefix="/usr" DESTDIR="${D}" LIBDIR="$(get_libdir)" install || die "make install failed"
dodoc README
@@ -78,3 +79,11 @@ src_install() {
## Remove some empty directories
rm -fr "${D}/usr/$(get_libdir)/perl5/5.8.8/" || die "Perl directory cleanup failed"
}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/stfl.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}