summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-03-01 03:28:58 +0000
committerTim Harder <radhermit@gentoo.org>2014-03-01 03:28:58 +0000
commitda302dbc25f02343787663cee9ec2aa4d1faf034 (patch)
tree998f9a6918021e8b3afaf0eb15295268b0cacdcf /dev-libs/userspace-rcu
parentVersion bump. (diff)
downloadgentoo-2-da302dbc25f02343787663cee9ec2aa4d1faf034.tar.gz
gentoo-2-da302dbc25f02343787663cee9ec2aa4d1faf034.tar.bz2
gentoo-2-da302dbc25f02343787663cee9ec2aa4d1faf034.zip
Version bumps.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-libs/userspace-rcu')
-rw-r--r--dev-libs/userspace-rcu/ChangeLog11
-rw-r--r--dev-libs/userspace-rcu/userspace-rcu-0.7.10.ebuild28
-rw-r--r--dev-libs/userspace-rcu/userspace-rcu-0.8.2.ebuild28
3 files changed, 65 insertions, 2 deletions
diff --git a/dev-libs/userspace-rcu/ChangeLog b/dev-libs/userspace-rcu/ChangeLog
index 99891d149a9e..ad654a13a204 100644
--- a/dev-libs/userspace-rcu/ChangeLog
+++ b/dev-libs/userspace-rcu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/userspace-rcu
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/userspace-rcu/ChangeLog,v 1.11 2013/11/23 23:34:05 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/userspace-rcu/ChangeLog,v 1.12 2014/03/01 03:28:58 radhermit Exp $
+
+*userspace-rcu-0.8.2 (01 Mar 2014)
+*userspace-rcu-0.7.10 (01 Mar 2014)
+
+ 01 Mar 2014; Tim Harder <radhermit@gentoo.org> +userspace-rcu-0.7.10.ebuild,
+ +userspace-rcu-0.8.2.ebuild:
+ Version bumps.
23 Nov 2013; Tim Harder <radhermit@gentoo.org> -userspace-rcu-0.7.6.ebuild,
-userspace-rcu-0.7.7.ebuild:
diff --git a/dev-libs/userspace-rcu/userspace-rcu-0.7.10.ebuild b/dev-libs/userspace-rcu/userspace-rcu-0.7.10.ebuild
new file mode 100644
index 000000000000..9e884e6d30de
--- /dev/null
+++ b/dev-libs/userspace-rcu/userspace-rcu-0.7.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/userspace-rcu/userspace-rcu-0.7.10.ebuild,v 1.1 2014/03/01 03:28:58 radhermit Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="userspace RCU (read-copy-update) library"
+HOMEPAGE="http://lttng.org/urcu"
+SRC_URI="http://lttng.org/files/urcu/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+DEPEND="test? ( sys-process/time )"
+
+# tests fail with separate build dir
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ )
+ autotools-utils_src_configure
+}
diff --git a/dev-libs/userspace-rcu/userspace-rcu-0.8.2.ebuild b/dev-libs/userspace-rcu/userspace-rcu-0.8.2.ebuild
new file mode 100644
index 000000000000..7761255ba2fb
--- /dev/null
+++ b/dev-libs/userspace-rcu/userspace-rcu-0.8.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/userspace-rcu/userspace-rcu-0.8.2.ebuild,v 1.1 2014/03/01 03:28:58 radhermit Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="userspace RCU (read-copy-update) library"
+HOMEPAGE="http://lttng.org/urcu"
+SRC_URI="http://lttng.org/files/urcu/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0/2" # subslot = soname version
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+DEPEND="test? ( sys-process/time )"
+
+# tests fail with separate build dir
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ )
+ autotools-utils_src_configure
+}