summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-10-22 21:28:51 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-10-22 21:28:51 +0000
commitea481eb9486f392cc492541a7718d27c9b5dfea4 (patch)
tree640f55ce97ef8431b18791dcaccfc6880d026261 /dev-libs/xapian-bindings
parentgrub:0 - undid the ugly patch-based hacks for forcing ld.bfd, thanks to vapie... (diff)
downloadgentoo-2-ea481eb9486f392cc492541a7718d27c9b5dfea4.tar.gz
gentoo-2-ea481eb9486f392cc492541a7718d27c9b5dfea4.tar.bz2
gentoo-2-ea481eb9486f392cc492541a7718d27c9b5dfea4.zip
Fix multiple PHP_TARGETS, thanks Arfrever
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-libs/xapian-bindings')
-rw-r--r--dev-libs/xapian-bindings/ChangeLog6
-rw-r--r--dev-libs/xapian-bindings/xapian-bindings-1.2.19.ebuild66
2 files changed, 54 insertions, 18 deletions
diff --git a/dev-libs/xapian-bindings/ChangeLog b/dev-libs/xapian-bindings/ChangeLog
index 46bf1db3acc3..a294d2ee07fe 100644
--- a/dev-libs/xapian-bindings/ChangeLog
+++ b/dev-libs/xapian-bindings/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/xapian-bindings
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/ChangeLog,v 1.82 2014/10/21 21:25:16 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/ChangeLog,v 1.83 2014/10/22 21:28:51 blueness Exp $
+
+ 22 Oct 2014; Anthony G. Basile <blueness@gentoo.org>
+ xapian-bindings-1.2.19.ebuild:
+ Fix multiple PHP_TARGETS, thanks Arfrever
21 Oct 2014; Andreas K. Huettel <dilfridge@gentoo.org>
xapian-bindings-1.2.19.ebuild:
diff --git a/dev-libs/xapian-bindings/xapian-bindings-1.2.19.ebuild b/dev-libs/xapian-bindings/xapian-bindings-1.2.19.ebuild
index 31b3c5615427..df74377e5c71 100644
--- a/dev-libs/xapian-bindings/xapian-bindings-1.2.19.ebuild
+++ b/dev-libs/xapian-bindings/xapian-bindings-1.2.19.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/xapian-bindings-1.2.19.ebuild,v 1.2 2014/10/21 21:25:16 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/xapian-bindings-1.2.19.ebuild,v 1.3 2014/10/22 21:28:51 blueness Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-USE_PYTHON='2.6 2.7'
-USE_PHP="php5-4"
+USE_PHP="php5-4 php5-5 php5-6"
PHP_EXT_NAME="xapian"
PHP_EXT_INI="yes"
@@ -45,6 +44,10 @@ pkg_setup() {
java-pkg-opt-2_pkg_setup
}
+src_unpack() {
+ default
+}
+
src_prepare() {
java-pkg-opt-2_src_prepare
if use java; then
@@ -85,13 +88,26 @@ src_configure() {
$(use_with tcl)
# $(use_with mono csharp) \
- # Python bindings are built/tested/installed manually.
+ # PHP and Python bindings are built/tested/installed manually.
+ sed -e "/SUBDIRS =/s/ php//" -i Makefile || die "sed Makefile"
sed -e "/SUBDIRS =/s/ python//" -i Makefile || die "sed Makefile"
}
src_compile() {
default
+ if use php; then
+ local php_slot
+ for php_slot in $(php_get_slots); do
+ cp -r php php-${php_slot}
+ emake -C php-${php_slot} \
+ PHP="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php" \
+ PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" \
+ PHP_EXTENSION_DIR="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --extension-dir)" \
+ PHP_INC="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --includes)"
+ done
+ fi
+
if use python; then
python_copy_sources
# building() {
@@ -115,6 +131,18 @@ src_compile() {
src_test() {
default
+ if use php; then
+ local php_slot
+ for php_slot in $(php_get_slots); do
+ emake -C php-${php_slot} \
+ PHP="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php" \
+ PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" \
+ PHP_EXTENSION_DIR="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --extension-dir)" \
+ PHP_INC="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --includes)" \
+ check
+ done
+ fi
+
if use python; then
testing() {
emake -C python \
@@ -128,7 +156,7 @@ src_test() {
}
src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install
if use java; then
java-pkg_dojar java/built/xapian_jni.jar
@@ -139,6 +167,20 @@ src_install () {
rmdir -p "${D}/${S}/java/native"
fi
+ if use php; then
+ local php_slot
+ for php_slot in $(php_get_slots); do
+ emake DESTDIR="${D}" -C php-${php_slot} \
+ PHP="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php" \
+ PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" \
+ PHP_EXTENSION_DIR="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --extension-dir)" \
+ PHP_INC="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --includes)" \
+ install
+ done
+
+ php-ext-source-r2_createinifiles
+ fi
+
if use python; then
installation() {
emake -C python \
@@ -151,20 +193,10 @@ src_install () {
python_foreach_impl installation
fi
- if use php; then
- php-ext-source-r2_createinifiles
- fi
-
# For some USE combinations this directory is not created
if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then
mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}"
fi
- dodoc AUTHORS HACKING NEWS TODO README || die "dodoc failed"
-}
-
-pkg_postinst() {
- if use php_targets_php5-4; then
- ewarn "Note: subclassing Xapian classes in PHP currently doesn't work with PHP 5.4"
- fi
+ dodoc AUTHORS HACKING NEWS TODO README
}