summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-11-29 17:18:23 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-11-29 17:18:23 +0000
commit64ae8890bf2d8f53e83d7ef83e57d14187bd5ddf (patch)
tree9b16478ae8d0c499307c4e479b6d431ba2882a2f /dev-libs/xmlrpc-c
parentppc stable, bug #249134 (diff)
downloadgentoo-2-64ae8890bf2d8f53e83d7ef83e57d14187bd5ddf.tar.gz
gentoo-2-64ae8890bf2d8f53e83d7ef83e57d14187bd5ddf.tar.bz2
gentoo-2-64ae8890bf2d8f53e83d7ef83e57d14187bd5ddf.zip
Bump, bug 246083. Also solves bug 235989 (!!).
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc4 x86_64)
Diffstat (limited to 'dev-libs/xmlrpc-c')
-rw-r--r--dev-libs/xmlrpc-c/ChangeLog11
-rw-r--r--dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-abyss-disable.patch23
-rw-r--r--dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-compile.patch28
-rw-r--r--dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-cpplinking.patch16
-rw-r--r--dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-linking-order.patch71
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.16.04.ebuild89
6 files changed, 237 insertions, 1 deletions
diff --git a/dev-libs/xmlrpc-c/ChangeLog b/dev-libs/xmlrpc-c/ChangeLog
index 1b84f7279723..6c6fac50178e 100644
--- a/dev-libs/xmlrpc-c/ChangeLog
+++ b/dev-libs/xmlrpc-c/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/xmlrpc-c
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/ChangeLog,v 1.72 2008/08/24 19:50:12 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/ChangeLog,v 1.73 2008/11/29 17:18:22 loki_val Exp $
+
+*xmlrpc-c-1.16.04 (29 Nov 2008)
+
+ 29 Nov 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/xmlrpc-c-1.16.04-abyss-disable.patch,
+ +files/xmlrpc-c-1.16.04-compile.patch,
+ +files/xmlrpc-c-1.16.04-cpplinking.patch,
+ +files/xmlrpc-c-1.16.04-linking-order.patch, +xmlrpc-c-1.16.04.ebuild:
+ Bump, bug 246083. Also solves bug 235989 (!!).
*xmlrpc-c-1.15.05 (24 Aug 2008)
diff --git a/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-abyss-disable.patch b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-abyss-disable.patch
new file mode 100644
index 000000000000..baa4d1a6f5c9
--- /dev/null
+++ b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-abyss-disable.patch
@@ -0,0 +1,23 @@
+diff -NrU5 xmlrpc-c-1.16.04.orig/src/cpp/Makefile xmlrpc-c-1.16.04/src/cpp/Makefile
+--- xmlrpc-c-1.16.04.orig/src/cpp/Makefile 2008-11-29 14:34:40.000000000 +0100
++++ xmlrpc-c-1.16.04/src/cpp/Makefile 2008-11-29 14:36:19.000000000 +0100
+@@ -15,15 +15,18 @@
+
+ TARGET_LIB_NAMES_PP = \
+ libxmlrpc_cpp \
+ lib$(LIBXMLRPCPP_NAME) \
+ libxmlrpc_server++ \
+- libxmlrpc_server_abyss++ \
+ libxmlrpc_server_cgi++ \
+ libxmlrpc_server_pstream++ \
+ libxmlrpc_packetsocket \
+
++ifeq ($(ENABLE_ABYSS_SERVER),yes)
++ TARGET_LIB_NAMES_PP += libxmlrpc_server_abyss++
++endif
++
+ ifeq ($(MUST_BUILD_CLIENT),yes)
+ TARGET_LIB_NAMES_PP += libxmlrpc_client++
+ endif
+
+ STATIC_LIBRARIES_TO_INSTALL = $(TARGET_STATIC_LIBRARIES)
diff --git a/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-compile.patch b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-compile.patch
new file mode 100644
index 000000000000..42ceee9c34f5
--- /dev/null
+++ b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-compile.patch
@@ -0,0 +1,28 @@
+diff -NrU5 xmlrpc-c-1.16.04.orig/src/cpp/server_cgi.cpp xmlrpc-c-1.16.04/src/cpp/server_cgi.cpp
+--- xmlrpc-c-1.16.04.orig/src/cpp/server_cgi.cpp 2008-11-29 17:31:12.000000000 +0100
++++ xmlrpc-c-1.16.04/src/cpp/server_cgi.cpp 2008-11-29 17:32:20.000000000 +0100
+@@ -12,10 +12,11 @@
+ Contributed to the public domain by its author.
+ =============================================================================*/
+
+ #include <memory>
+ #include <stdio.h>
++#include <cstdlib>
+
+ #include "xmlrpc-c/girerr.hpp"
+ using girerr::throwf;
+ #include "xmlrpc-c/server_cgi.hpp"
+
+@@ -34,11 +35,11 @@
+ unsigned int contentLength;
+ bool contentLengthPresent;
+ bool authCookiePresent;
+ string authCookie;
+
+- httpInfo::httpInfo() {
++ httpInfo() {
+
+ const char * const requestMethodC = getenv("REQUEST_METHOD");
+ const char * const contentTypeC = getenv("CONTENT_TYPE");
+ const char * const contentLengthC = getenv("CONTENT_LENGTH");
+ const char * const authCookieC = getenv("HTTP_COOKIE_AUTH");
diff --git a/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-cpplinking.patch b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-cpplinking.patch
new file mode 100644
index 000000000000..67e58f0120be
--- /dev/null
+++ b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-cpplinking.patch
@@ -0,0 +1,16 @@
+diff -NrU5 xmlrpc-c-1.16.04.orig/common.mk xmlrpc-c-1.16.04/common.mk
+--- xmlrpc-c-1.16.04.orig/common.mk 2008-11-29 17:37:48.000000000 +0100
++++ xmlrpc-c-1.16.04/common.mk 2008-11-29 17:38:06.000000000 +0100
+@@ -265,11 +265,11 @@
+
+ $(TARGET_MODS:%=%.osh):%.osh:%.c
+ $(CC) -c -o $@ $(INCLUDES) $(CFLAGS) $(CFLAGS_SHLIB) $<
+
+ $(TARGET_MODS_PP:%=%.o):%.o:%.cpp
+- $(CXX) -c -o $@ $(INCLUDES) $(CXXFLAGS) $<
++ $(CXX) -c -o $@ $(INCLUDES) $(CFLAGS_SHLIB) $(CXXFLAGS) $<
+
+ $(TARGET_MODS_PP:%=%.osh): CXXFLAGS_COMMON += $(CFLAGS_SHLIB)
+
+ $(TARGET_MODS_PP:%=%.osh):%.osh:%.cpp
+ $(CXX) -c -o $@ $(INCLUDES) $(CXXFLAGS) $<
diff --git a/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-linking-order.patch b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-linking-order.patch
new file mode 100644
index 000000000000..cd169c5f4fd6
--- /dev/null
+++ b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.04-linking-order.patch
@@ -0,0 +1,71 @@
+diff -NrU5 xmlrpc-c-1.16.04.orig/common.mk xmlrpc-c-1.16.04/common.mk
+--- xmlrpc-c-1.16.04.orig/common.mk 2008-11-29 17:31:12.000000000 +0100
++++ xmlrpc-c-1.16.04/common.mk 2008-11-29 17:35:25.000000000 +0100
+@@ -134,14 +134,14 @@
+ TARGET_SHARED_LE_LIBS =
+ endif
+
+ #------ the actual rules ----------------------------------------------------
+ $(TARGET_SHARED_LIBRARIES) dummyshlib:
+- $(CCLD) $(LDFLAGS_SHLIB) $(LIBDEP) -o $@ $(LIBOBJECTS) $(LADD)
++ $(CCLD) $(LADD) $(LDFLAGS_SHLIB) $(LIBOBJECTS) $(LIBDEP) -o $@
+
+ $(TARGET_SHARED_LIBS_PP) dummyshlibpp:
+- $(CXXLD) $(LDFLAGS_SHLIB) $(LIBDEP) -o $@ $(LIBOBJECTS) $(LADD)
++ $(CXXLD) $(LADD) $(LDFLAGS_SHLIB) $(LIBOBJECTS) $(LIBDEP) -o $@
+ #----------------------------------------------------------------------------
+
+ LIBXMLRPC_UTIL_DIR = $(BLDDIR)/lib/libutil
+
+ ifneq ($(OMIT_LIBXMLRPC_UTIL_RULE),Y)
+diff -NrU5 xmlrpc-c-1.16.04.orig/dylib-common.make xmlrpc-c-1.16.04/dylib-common.make
+--- xmlrpc-c-1.16.04.orig/dylib-common.make 2008-11-29 17:31:12.000000000 +0100
++++ xmlrpc-c-1.16.04/dylib-common.make 2008-11-29 17:35:25.000000000 +0100
+@@ -3,13 +3,13 @@
+ # See unix-common.make for an explanation of this file. This file is
+ # analogous to unix-common.make, but is for an Irix system.
+
+ SONAME = $(@:%.$(MIN)=%)
+
+-SHLIB_CMD = $(CCLD) $(LDFLAGS_SHLIB) -o $@ $^ $(LADD)
++SHLIB_CMD = $(CCLD) $(LADD) $(LDFLAGS_SHLIB) -o $@ $^
+
+-SHLIBPP_CMD = $(CXXLD) $(LDFLAGS_SHLIB) -o $@ $^ $(LADD)
++SHLIBPP_CMD = $(CXXLD) $(LADD) $(LDFLAGS_SHLIB) -o $@ $^
+
+ SHLIB_LE_TARGETS = $(call shliblefn, $(SHARED_LIBS_TO_BUILD))
+
+ $(SHLIB_LE_TARGETS):%.$(SHLIB_SUFFIX):%.$(MAJ).$(MIN).$(SHLIB_SUFFIX)
+ rm -f $@
+diff -NrU5 xmlrpc-c-1.16.04.orig/irix-common.make xmlrpc-c-1.16.04/irix-common.make
+--- xmlrpc-c-1.16.04.orig/irix-common.make 2008-11-29 17:31:12.000000000 +0100
++++ xmlrpc-c-1.16.04/irix-common.make 2008-11-29 17:35:25.000000000 +0100
+@@ -3,11 +3,11 @@
+ # See unix-common.make for an explanation of this file. This file is
+ # analogous to unix-common.make, but is for an Irix system.
+
+ SONAME = $(@:%.$(MAJ):%)
+
+-SHLIB_CMD = $(CCLD) $(LDFLAGS_SHLIB) -o $@ $^ $(LADD)
++SHLIB_CMD = $(CCLD) $(LADD) $(LDFLAGS_SHLIB) -o $@ $^
+
+ SHLIB_LE_TARGETS = $(call shliblefn, $(SHARED_LIBS_TO_BUILD))
+
+ $(SHLIB_LE_TARGETS):%:%.$(MAJ)
+ rm -f $@
+diff -NrU5 xmlrpc-c-1.16.04.orig/unix-common.make xmlrpc-c-1.16.04/unix-common.make
+--- xmlrpc-c-1.16.04.orig/unix-common.make 2008-11-29 17:31:12.000000000 +0100
++++ xmlrpc-c-1.16.04/unix-common.make 2008-11-29 17:35:25.000000000 +0100
+@@ -49,11 +49,11 @@
+ # SONAME is the name of the library file being built, with the minor
+ # version number cut off. E.g. if we're building libfoo.so.1.2, SONAME
+ # is libfoo.so.1 .
+ SONAME = $(@:%.$(MIN)=%)
+
+-SHLIB_CMD = $(CCLD) $(LDFLAGS_SHLIB) -o $@ $^ $(LADD)
++SHLIB_CMD = $(CCLD) $(LADD) $(LDFLAGS_SHLIB) -o $@ $^
+
+ SHLIB_LE_TARGETS = $(call shliblefn, $(SHARED_LIBS_TO_BUILD))
+
+ $(SHLIB_LE_TARGETS):%:%.$(MAJ).$(MIN)
+ rm -f $@
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.16.04.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.16.04.ebuild
new file mode 100644
index 000000000000..f9d5aa1592b6
--- /dev/null
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.16.04.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/xmlrpc-c-1.16.04.ebuild,v 1.1 2008/11/29 17:18:22 loki_val Exp $
+
+EAPI=1
+
+inherit eutils multilib base
+
+DESCRIPTION="A lightweigt RPC library based on XML and HTTP"
+SRC_URI="mirror://gentoo/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://xmlrpc-c.sourceforge.net/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="+curl +cxx"
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="dev-libs/libxml2
+ curl? ( net-misc/curl )"
+
+pkg_setup() {
+ if ! use curl
+ then
+ ewarn "Curl support disabled: No client library will be be built"
+ fi
+}
+
+#FAIL
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${P}-abyss-disable.patch"
+ "${FILESDIR}/${P}-compile.patch"
+ "${FILESDIR}/${P}-linking-order.patch"
+ "${FILESDIR}/${P}-cpplinking.patch" )
+
+src_unpack() {
+ base_src_unpack
+ cd "${S}"
+ # Respect the user's CFLAGS/CXXFLAGS.
+ sed -i \
+ -e "/CFLAGS_COMMON/s:-g -O3$:${CFLAGS}:" \
+ -e "/CXXFLAGS_COMMON/s:-g$:${CXXFLAGS}:" \
+ "${S}"/common.mk || die "404. File not found while sedding"
+
+ sed -i \
+ -e "/^LIBINST_DIR = / s:\$(PREFIX)/lib:\$(PREFIX)/$(get_libdir):" \
+ config.mk.in
+}
+
+src_compile() {
+ #Bug 214137: We need to filter this.
+ unset SRCDIR
+
+ # Respect the user's LDFLAGS.
+ export LADD=${LDFLAGS}
+ econf --disable-wininet-client \
+ --enable-libxml2-backend \
+ --disable-libwww-client \
+ --disable-abyss-server \
+ --enable-cgi-server \
+ --disable-abyss-threads \
+ $(use_enable cxx cplusplus) \
+ $(use_enable curl curl-client) \
+ || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_test() {
+ unset LDFLAGS LADD SRCDIR
+ cd "${S}"/src/test/
+ einfo "Building general tests"
+ make || die "Make of general tests failed"
+ einfo "Running general tests"
+ ./test || die "General tests failed"
+
+ cd "${S}"/src/cpp/test
+ einfo "Building C++ tests"
+ make || die "Make of C++ tests failed"
+ einfo "Running C++ tests"
+ ./test || die "C++ tests failed"
+}
+
+src_install() {
+ unset SRCDIR
+ emake -j1 DESTDIR="${D}" install || die "installation failed"
+
+ dodoc README doc/CREDITS doc/DEVELOPING doc/HISTORY doc/SECURITY doc/TESTING \
+ doc/TODO || die "installing docs failed"
+}