summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-04-14 23:35:38 +0000
committerMike Frysinger <vapier@gentoo.org>2010-04-14 23:35:38 +0000
commit28392fba3d4255d8bb56bb1aaeacaef8cfe422d5 (patch)
tree495c4028cf082ace3255e59cd55243aa2748bc5e /dev-libs/zziplib
parentdev-python/fuse-python: Bump to 0.2.1 (diff)
downloadgentoo-2-28392fba3d4255d8bb56bb1aaeacaef8cfe422d5.tar.gz
gentoo-2-28392fba3d4255d8bb56bb1aaeacaef8cfe422d5.tar.bz2
gentoo-2-28392fba3d4255d8bb56bb1aaeacaef8cfe422d5.zip
Version bump #315019 by Samuli Suominen.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/zziplib')
-rw-r--r--dev-libs/zziplib/ChangeLog7
-rw-r--r--dev-libs/zziplib/zziplib-0.13.59.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-libs/zziplib/ChangeLog b/dev-libs/zziplib/ChangeLog
index 16d8125db13b..4a8ed2252c8e 100644
--- a/dev-libs/zziplib/ChangeLog
+++ b/dev-libs/zziplib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/zziplib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/ChangeLog,v 1.72 2010/03/14 20:22:32 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/ChangeLog,v 1.73 2010/04/14 23:35:37 vapier Exp $
+
+*zziplib-0.13.59 (14 Apr 2010)
+
+ 14 Apr 2010; Mike Frysinger <vapier@gentoo.org> +zziplib-0.13.59.ebuild:
+ Version bump #315019 by Samuli Suominen.
*zziplib-0.13.58-r1 (14 Mar 2010)
diff --git a/dev-libs/zziplib/zziplib-0.13.59.ebuild b/dev-libs/zziplib/zziplib-0.13.59.ebuild
new file mode 100644
index 000000000000..a345b155f522
--- /dev/null
+++ b/dev-libs/zziplib/zziplib-0.13.59.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/zziplib-0.13.59.ebuild,v 1.1 2010/04/14 23:35:38 vapier Exp $
+
+EAPI="2"
+
+inherit libtool eutils flag-o-matic
+
+DESCRIPTION="Lightweight library used to easily extract data from files archived in a single zip file"
+HOMEPAGE="http://zziplib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zziplib/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc sdl static-libs test"
+
+RDEPEND="sys-libs/zlib
+ sdl? ( >=media-libs/libsdl-1.2.6 )"
+DEPEND="${RDEPEND}
+ >=dev-lang/python-2.4
+ dev-util/pkgconfig
+ test? ( app-arch/zip )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.13.49-SDL-test.patch
+ # zziplib tries to install backwards compat symlinks we dont want
+ sed -i -e '/^zzip-postinstall:/s|$|\ndisable-this:|' Makefile.in || die
+ sed -i -e '/^install-exec-local:/s|$|\ndisable-this:|' zzip/Makefile.in || die
+ elibtoolize
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing # bug reported upstream
+ export ac_cv_path_XMLTO= # man pages are bundled in .tar's
+ econf \
+ $(use_enable sdl) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ # need this because `make test` will always return true
+ # tests fail with -j > 1 (bug #241186)
+ emake -j1 check || die "make check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + \
+ || die "la removal failed"
+ fi
+
+ dodoc ChangeLog README TODO
+
+ if use doc ; then
+ dohtml -r docs/* || die 'dohtml failed'
+ fi
+}