summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-16 21:23:20 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-16 21:23:20 +0000
commit01248ef9bcca68c1425d9219a7cf4cdd785f7101 (patch)
tree64865a15a7ff73d897745aba9ff796d824b258f2 /dev-libs
parentverbose build for bug #447488 and clean out old/unneeded ebuilds (diff)
downloadgentoo-2-01248ef9bcca68c1425d9219a7cf4cdd785f7101.tar.gz
gentoo-2-01248ef9bcca68c1425d9219a7cf4cdd785f7101.tar.bz2
gentoo-2-01248ef9bcca68c1425d9219a7cf4cdd785f7101.zip
Port to python-single-r1.eclass and EAPI5. Drop old.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libpeas/ChangeLog10
-rw-r--r--dev-libs/libpeas/files/libpeas-1.2.0-PeasPluginInfo-annotation.patch57
-rw-r--r--dev-libs/libpeas/files/libpeas-1.4.0-pkgconfig.patch25
-rw-r--r--dev-libs/libpeas/libpeas-1.6.0.ebuild73
-rw-r--r--dev-libs/libpeas/libpeas-1.6.2-r1.ebuild (renamed from dev-libs/libpeas/libpeas-1.6.1.ebuild)28
5 files changed, 17 insertions, 176 deletions
diff --git a/dev-libs/libpeas/ChangeLog b/dev-libs/libpeas/ChangeLog
index 758438c680e7..a819debae7cb 100644
--- a/dev-libs/libpeas/ChangeLog
+++ b/dev-libs/libpeas/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/libpeas
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpeas/ChangeLog,v 1.9 2012/11/25 21:21:45 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpeas/ChangeLog,v 1.10 2012/12/16 21:23:19 tetromino Exp $
+
+*libpeas-1.6.2-r1 (16 Dec 2012)
+
+ 16 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -files/libpeas-1.2.0-PeasPluginInfo-annotation.patch,
+ -files/libpeas-1.4.0-pkgconfig.patch, -libpeas-1.6.0.ebuild,
+ -libpeas-1.6.1.ebuild, +libpeas-1.6.2-r1.ebuild:
+ Port to python-single-r1.eclass and EAPI5. Drop old.
*libpeas-1.6.2 (25 Nov 2012)
diff --git a/dev-libs/libpeas/files/libpeas-1.2.0-PeasPluginInfo-annotation.patch b/dev-libs/libpeas/files/libpeas-1.2.0-PeasPluginInfo-annotation.patch
deleted file mode 100644
index 3a2e9b4c88d8..000000000000
--- a/dev-libs/libpeas/files/libpeas-1.2.0-PeasPluginInfo-annotation.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From afa50c526ce1aab53eff3c3373a97180fc90abe2 Mon Sep 17 00:00:00 2001
-From: Garrett Regier <garrettregier@gmail.com>
-Date: Thu, 29 Sep 2011 15:46:49 -0700
-Subject: [PATCH] Annotate PeasPluginInfo return values as transfer none
-
-Otherwise GObject-Introspection says that it is transfer full.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=660524
----
- libpeas-gtk/peas-gtk-plugin-manager-view.c | 2 +-
- libpeas/peas-engine.c | 2 +-
- libpeas/peas-extension-base.c | 3 ++-
- 3 files changed, 4 insertions(+), 3 deletions(-)
-
-diff --git a/libpeas-gtk/peas-gtk-plugin-manager-view.c b/libpeas-gtk/peas-gtk-plugin-manager-view.c
-index 7eb7361..5f8f55f 100644
---- a/libpeas-gtk/peas-gtk-plugin-manager-view.c
-+++ b/libpeas-gtk/peas-gtk-plugin-manager-view.c
-@@ -952,7 +952,7 @@ peas_gtk_plugin_manager_view_set_selected_plugin (PeasGtkPluginManagerView *view
- *
- * Returns the currently selected plugin, or %NULL if a plugin is not selected.
- *
-- * Returns: the selected plugin.
-+ * Returns: (transfer none): the selected plugin.
- */
- PeasPluginInfo *
- peas_gtk_plugin_manager_view_get_selected_plugin (PeasGtkPluginManagerView *view)
-diff --git a/libpeas/peas-engine.c b/libpeas/peas-engine.c
-index 1adf4ff..7b57d56 100644
---- a/libpeas/peas-engine.c
-+++ b/libpeas/peas-engine.c
-@@ -733,7 +733,7 @@ compare_plugin_info_and_name (PeasPluginInfo *info,
- * Gets the #PeasPluginInfo corresponding with @plugin_name,
- * or %NULL if @plugin_name was not found.
- *
-- * Returns: the #PeasPluginInfo corresponding with
-+ * Returns: (transfer none): the #PeasPluginInfo corresponding with
- * a given plugin module name.
- */
- PeasPluginInfo *
-diff --git a/libpeas/peas-extension-base.c b/libpeas/peas-extension-base.c
-index 329a25f..7c4cba0 100644
---- a/libpeas/peas-extension-base.c
-+++ b/libpeas/peas-extension-base.c
-@@ -141,7 +141,8 @@ peas_extension_base_class_init (PeasExtensionBaseClass *klass)
- *
- * Get information relative to @extbase.
- *
-- * Return value: the #PeasPluginInfo relative to the #PeasExtensionBase.
-+ * Return value: (transfer none): the #PeasPluginInfo relative
-+ * to the #PeasExtensionBase.
- */
- PeasPluginInfo *
- peas_extension_base_get_plugin_info (PeasExtensionBase *extbase)
---
-1.7.7.2
-
diff --git a/dev-libs/libpeas/files/libpeas-1.4.0-pkgconfig.patch b/dev-libs/libpeas/files/libpeas-1.4.0-pkgconfig.patch
deleted file mode 100644
index 125af02657b9..000000000000
--- a/dev-libs/libpeas/files/libpeas-1.4.0-pkgconfig.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 2d6ea307cf45af6b92b1cd708d0ee288aca0b3fe Mon Sep 17 00:00:00 2001
-From: Olav Vitters <olav@vitters.nl>
-Date: Wed, 28 Mar 2012 15:28:40 +0200
-Subject: [PATCH] fix forgotten @ in pkgconfig file
-
----
- data/libpeas-1.0.pc.in | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/data/libpeas-1.0.pc.in b/data/libpeas-1.0.pc.in
-index 9523067..704d686 100644
---- a/data/libpeas-1.0.pc.in
-+++ b/data/libpeas-1.0.pc.in
-@@ -5,7 +5,7 @@ includedir=@includedir@
-
- Name: libpeas
- Description: libpeas, a GObject plugins library
--Requires: glib-2.0 >= @GLIB_REQUIRED@, gobject-2.0 >= @GLIB_REQUIRED@, gmodule-2.0 >= @GLIB_REQUIRED@, gio-2.0 >= @GIO_REQUIRED gobject-introspection-1.0 >= @INTROSPECTION_REQUIRED@
-+Requires: glib-2.0 >= @GLIB_REQUIRED@, gobject-2.0 >= @GLIB_REQUIRED@, gmodule-2.0 >= @GLIB_REQUIRED@, gio-2.0 >= @GIO_REQUIRED@ gobject-introspection-1.0 >= @INTROSPECTION_REQUIRED@
- Version: @VERSION@
- Cflags: -I${includedir}/libpeas-1.0
- Libs: -L${libdir} -lpeas-1.0
---
-1.7.8.6
-
diff --git a/dev-libs/libpeas/libpeas-1.6.0.ebuild b/dev-libs/libpeas/libpeas-1.6.0.ebuild
deleted file mode 100644
index ce77a2d2a011..000000000000
--- a/dev-libs/libpeas/libpeas-1.6.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpeas/libpeas-1.6.0.ebuild,v 1.1 2012/09/30 07:36:54 tetromino Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_DEPEND="python? 2:2.5"
-
-inherit eutils gnome2 multilib python virtualx
-
-DESCRIPTION="A GObject plugins library"
-HOMEPAGE="http://www.gnome.org/"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-IUSE="doc gjs +gtk glade +python seed"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
-
-RDEPEND=">=dev-libs/glib-2.32:2
- >=dev-libs/gobject-introspection-0.10.1
- gjs? ( >=dev-libs/gjs-1.31.11 )
- glade? ( >=dev-util/glade-3.9.1:3.10 )
- gtk? ( >=x11-libs/gtk+-3:3[introspection] )
- python? ( >=dev-python/pygobject-3.0.0:3 )
- seed? ( >=dev-libs/seed-2.91.91 )"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.40
- >=sys-devel/gettext-0.17
- doc? ( >=dev-util/gtk-doc-1.11 )"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- $(use_enable gjs)
- $(use_enable glade glade-catalog)
- $(use_enable gtk)
- $(use_enable python)
- $(use_enable seed)
- --disable-deprecation
- --disable-static"
- # Wtf, --disable-gcov, --enable-gcov=no, --enable-gcov, all enable gcov
- # What do we do about gdb, valgrind, gcov, etc?
-
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- use python && python_clean_py-compile_files
- gnome2_src_prepare
-}
-
-src_test() {
- # FIXME: Tests fail because of some bug involving Xvfb and Gtk.IconTheme
- # DO NOT REPORT UPSTREAM, this is not a libpeas bug.
- # To reproduce:
- # >>> from gi.repository import Gtk
- # >>> Gtk.IconTheme.get_default().has_icon("gtk-about")
- # This should return True, it returns False for Xvfb
- Xemake check
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- use python && python_mod_optimize /usr/$(get_libdir)/peas-demo
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- use python && python_mod_cleanup /usr/$(get_libdir)/peas-demo
-}
diff --git a/dev-libs/libpeas/libpeas-1.6.1.ebuild b/dev-libs/libpeas/libpeas-1.6.2-r1.ebuild
index 1b9b2951ddd7..f057c0f4dc9c 100644
--- a/dev-libs/libpeas/libpeas-1.6.1.ebuild
+++ b/dev-libs/libpeas/libpeas-1.6.2-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpeas/libpeas-1.6.1.ebuild,v 1.1 2012/10/20 06:46:36 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpeas/libpeas-1.6.2-r1.ebuild,v 1.1 2012/12/16 21:23:19 tetromino Exp $
-EAPI="4"
+EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-PYTHON_DEPEND="python? 2:2.5"
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit eutils gnome2 multilib python virtualx
+inherit eutils gnome2 multilib python-single-r1 virtualx
DESCRIPTION="A GObject plugins library"
HOMEPAGE="http://developer.gnome.org/libpeas/stable/"
@@ -22,20 +22,19 @@ RDEPEND=">=dev-libs/glib-2.32:2
gjs? ( >=dev-libs/gjs-1.31.11 )
glade? ( >=dev-util/glade-3.9.1:3.10 )
gtk? ( >=x11-libs/gtk+-3:3[introspection] )
- python? ( >=dev-python/pygobject-3.0.0:3 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-3.0.0:3[${PYTHON_USEDEP}] )
seed? ( >=dev-libs/seed-2.91.91 )"
DEPEND="${RDEPEND}
>=dev-util/intltool-0.40
>=sys-devel/gettext-0.17"
pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
+ use python && python-single-r1_pkg_setup
}
src_prepare() {
- DOCS="AUTHORS ChangeLog NEWS README"
-
G2CONF="${G2CONF}
$(use_enable gjs)
$(use_enable glade glade-catalog)
@@ -47,7 +46,6 @@ src_prepare() {
# Wtf, --disable-gcov, --enable-gcov=no, --enable-gcov, all enable gcov
# What do we do about gdb, valgrind, gcov, etc?
- use python && python_clean_py-compile_files
gnome2_src_prepare
}
@@ -60,13 +58,3 @@ src_test() {
# This should return True, it returns False for Xvfb
Xemake check
}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- use python && python_mod_optimize /usr/$(get_libdir)/peas-demo
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- use python && python_mod_cleanup /usr/$(get_libdir)/peas-demo
-}