summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-26 09:24:16 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-26 09:24:16 +0000
commit1138871de4e108284cdeb38224f8baf3e6b2262a (patch)
tree0706bd54fee4c1e74bcb1add9b4471949d2762e6 /dev-libs
parentStable on ppc. (diff)
downloadgentoo-2-1138871de4e108284cdeb38224f8baf3e6b2262a.tar.gz
gentoo-2-1138871de4e108284cdeb38224f8baf3e6b2262a.tar.bz2
gentoo-2-1138871de4e108284cdeb38224f8baf3e6b2262a.zip
Version bump #92291 by Andreas Jellinghaus.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openct/ChangeLog9
-rw-r--r--dev-libs/openct/files/digest-openct-0.6.51
-rw-r--r--dev-libs/openct/openct-0.6.5.ebuild74
3 files changed, 82 insertions, 2 deletions
diff --git a/dev-libs/openct/ChangeLog b/dev-libs/openct/ChangeLog
index 845ce7280d25..4f45c383dc93 100644
--- a/dev-libs/openct/ChangeLog
+++ b/dev-libs/openct/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/openct
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openct/ChangeLog,v 1.10 2005/01/23 10:59:56 corsair Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openct/ChangeLog,v 1.11 2005/06/26 09:24:16 vapier Exp $
+
+*openct-0.6.5 (26 Jun 2005)
+
+ 26 Jun 2005; Mike Frysinger <vapier@gentoo.org> +openct-0.6.5.ebuild:
+ Version bump #92291 by Andreas Jellinghaus.
23 Jan 2005; Markus Rothe <corsair@gentoo.org> openct-0.5.0.ebuild,
openct-0.6.2.ebuild:
diff --git a/dev-libs/openct/files/digest-openct-0.6.5 b/dev-libs/openct/files/digest-openct-0.6.5
new file mode 100644
index 000000000000..4b13f4bc0d2c
--- /dev/null
+++ b/dev-libs/openct/files/digest-openct-0.6.5
@@ -0,0 +1 @@
+MD5 86bafd61788139f28671872da287fa0a openct-0.6.5.tar.gz 486355
diff --git a/dev-libs/openct/openct-0.6.5.ebuild b/dev-libs/openct/openct-0.6.5.ebuild
new file mode 100644
index 000000000000..03e40095c4b3
--- /dev/null
+++ b/dev-libs/openct/openct-0.6.5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openct/openct-0.6.5.ebuild,v 1.1 2005/06/26 09:24:16 vapier Exp $
+
+inherit eutils
+
+MY_P=${P/_/-}
+DESCRIPTION="library for accessing smart card terminals"
+HOMEPAGE="http://opensc.org/"
+SRC_URI="http://opensc.org/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="usb"
+
+RDEPEND="usb? ( >=dev-libs/libusb-0.1.7 >=sys-apps/hotplug-20030805-r1 )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ enewgroup openct
+}
+
+src_compile() {
+ econf --localstatedir=/var || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ insinto /etc
+ doins etc/openct.conf || die
+ if use usb ; then
+ insinto /etc/hotplug/usb
+ doins etc/openct.usermap || die
+ exeinto /etc/hotplug/usb
+ newexe etc/hotplug.openct openct || die
+ fi
+
+ newinitd "${FILESDIR}"/openct.rc openct
+
+ diropts -m0750 -gopenct
+ keepdir /var/run/openct
+
+ dodoc ANNOUNCE AUTHORS NEWS README TODO
+ dohtml doc/openct.{html,css}
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/usr/lib/libopenct.so.0 ]] ; then
+ cp "${ROOT}"/usr/lib/libopenct.so.0 "${IMAGE}"/usr/lib/
+ fi
+}
+
+pkg_postinst() {
+ einfo "You need to edit /etc/openct.conf to enable serial readers."
+ einfo
+ einfo "To use hotplugging (USB readers) your kernel has to be compiled"
+ einfo "with CONFIG_HOTPLUG enabled and sys-apps/hotplug must be emerged."
+ einfo
+ einfo "You should add \"openct\" to your default runlevel. To do so"
+ einfo "type \"rc-update add openct default\"."
+ einfo
+ einfo "You need to be a member of the (newly created) group openct to"
+ einfo "access smart card readers connected to this system. Set users'"
+ einfo "groups with usermod -G. root always has access."
+ if [[ -e ${ROOT}/usr/lib/libopenct.so.0 ]] ; then
+ echo
+ ewarn "Please run: revdep-rebuild --soname libopenct.so.0"
+ echo
+ fi
+}