summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-06 05:21:10 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-06 05:21:10 +0000
commit2cbf13c00fdc9c8e418c669d65e68a9265ea0522 (patch)
tree0e6c0ecd7c0631c6c9e7189cfa3dc41e9558eff0 /dev-libs
parent*** empty log message *** (diff)
downloadgentoo-2-2cbf13c00fdc9c8e418c669d65e68a9265ea0522.tar.gz
gentoo-2-2cbf13c00fdc9c8e418c669d65e68a9265ea0522.tar.bz2
gentoo-2-2cbf13c00fdc9c8e418c669d65e68a9265ea0522.zip
New packages for gnome-1.4_beta2 used in rc4
Available flags: bonobo, gtkhtml
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libunicode/files/digest-libunicode-0.4-r11
-rw-r--r--dev-libs/libunicode/libunicode-0.4-r1.ebuild31
-rw-r--r--dev-libs/libxml/libxml-1.8.11.ebuild33
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/libunicode/files/digest-libunicode-0.4-r1 b/dev-libs/libunicode/files/digest-libunicode-0.4-r1
new file mode 100644
index 000000000000..cd2fc6c37b7c
--- /dev/null
+++ b/dev-libs/libunicode/files/digest-libunicode-0.4-r1
@@ -0,0 +1 @@
+MD5 78bca1168d7f180e9cc8a3388bf7374e libunicode-0.4.gnome.tar.gz
diff --git a/dev-libs/libunicode/libunicode-0.4-r1.ebuild b/dev-libs/libunicode/libunicode-0.4-r1.ebuild
new file mode 100644
index 000000000000..4f41af1aec53
--- /dev/null
+++ b/dev-libs/libunicode/libunicode-0.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header
+
+A=${P}.gnome.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The Gnome Application Libraries"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}
+ ftp://gnome.eazel.com/pub/gnome/unstable/sources/${PN}/${A}"
+
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --prefix=/opt/gnome
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome install
+
+ dodoc AUTHORS COPYING.* ChangeLog NEWS README THANKS TODO
+}
+
+
+
+
diff --git a/dev-libs/libxml/libxml-1.8.11.ebuild b/dev-libs/libxml/libxml-1.8.11.ebuild
new file mode 100644
index 000000000000..3e4fcbad967d
--- /dev/null
+++ b/dev-libs/libxml/libxml-1.8.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml/libxml-1.8.11.ebuild,v 1.1 2001/03/06 05:21:10 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="libxml"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}
+ ftp://gnome.eazel.com/pub/gnome/stable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1"
+
+src_compile() {
+ cd ${S}
+ LDFLAGS="-lncurses" try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make install prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}
+
+
+
+
+
+
+