summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-16 12:36:10 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-16 12:36:10 +0000
commit371a76ce6496274be56b75f75826718505caa155 (patch)
tree910a3611e113dba8bd803663cf4463866a52c13d /dev-libs
parentConvert to multilib, bug #480262. Stack it for emul-baselibs r12 (diff)
downloadgentoo-2-371a76ce6496274be56b75f75826718505caa155.tar.gz
gentoo-2-371a76ce6496274be56b75f75826718505caa155.tar.bz2
gentoo-2-371a76ce6496274be56b75f75826718505caa155.zip
Convert to multilib, bug #479316. Stack it for emul-baselibs r12
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libelf/ChangeLog9
-rw-r--r--dev-libs/libelf/libelf-0.8.13-r2.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/dev-libs/libelf/ChangeLog b/dev-libs/libelf/ChangeLog
index b0c9d3cc967a..0c1858194a53 100644
--- a/dev-libs/libelf/ChangeLog
+++ b/dev-libs/libelf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libelf
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/ChangeLog,v 1.43 2012/11/29 13:42:25 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/ChangeLog,v 1.44 2013/08/16 12:36:10 aballier Exp $
+
+*libelf-0.8.13-r2 (16 Aug 2013)
+
+ 16 Aug 2013; Alexis Ballier <aballier@gentoo.org> +libelf-0.8.13-r2.ebuild:
+ Convert to multilib, bug #479316. Stack it for emul-baselibs r12
29 Nov 2012; Anthony G. Basile <blueness@gentoo.org> libelf-0.8.13-r1.ebuild:
Rapid stabilization arm and ppc64
diff --git a/dev-libs/libelf/libelf-0.8.13-r2.ebuild b/dev-libs/libelf/libelf-0.8.13-r2.ebuild
new file mode 100644
index 000000000000..b1bb4abb9311
--- /dev/null
+++ b/dev-libs/libelf/libelf-0.8.13-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/libelf-0.8.13-r2.ebuild,v 1.1 2013/08/16 12:36:10 aballier Exp $
+
+EAPI="5"
+
+inherit eutils multilib autotools multilib-minimal
+
+DESCRIPTION="A ELF object file access library"
+HOMEPAGE="http://www.mr511.de/software/"
+SRC_URI="http://www.mr511.de/software/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug nls elibc_FreeBSD"
+
+RDEPEND="!dev-libs/elfutils
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20130224-r11
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+DOCS=( ChangeLog README )
+MULTILIB_WRAPPED_HEADERS=( /usr/include/libelf/sys_elf.h )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build.patch"
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # prefix might want to play with this; unfortunately the stupid
+ # macro used to detect whether we're building ELF is so screwed up
+ # that trying to fix it is just a waste of time.
+ export mr_cv_target_elf=yes
+
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable nls) \
+ --enable-shared \
+ $(use_enable debug)
+}
+
+multilib_src_install() {
+ emake \
+ prefix="${ED}usr" \
+ libdir="${ED}usr/$(get_libdir)" \
+ install \
+ install-compat \
+ -j1 || die
+
+ # Stop libelf from stamping on the system nlist.h
+ use elibc_FreeBSD && rm "${ED}"/usr/include/nlist.h
+}