summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2006-11-09 10:12:18 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2006-11-09 10:12:18 +0000
commit3c9587b39ccdf8176bc6b902c3ae95246d646388 (patch)
tree045b2d2bdd85176c7738a77c8a41f246503770d1 /dev-libs
parentChanged automake/autoconf-dependencys to latest. (diff)
downloadgentoo-2-3c9587b39ccdf8176bc6b902c3ae95246d646388.tar.gz
gentoo-2-3c9587b39ccdf8176bc6b902c3ae95246d646388.tar.bz2
gentoo-2-3c9587b39ccdf8176bc6b902c3ae95246d646388.zip
Version bump.
Applied my patch for as-needed. Used toolchain-funcs to export CC. (Portage version: 2.1.2_rc1-r4)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cdk/ChangeLog10
-rw-r--r--dev-libs/cdk/cdk-5.0.20060507.ebuild43
-rw-r--r--dev-libs/cdk/files/cdk-5.0.20060507-as-needed.patch11
-rw-r--r--dev-libs/cdk/files/digest-cdk-5.0.200605073
4 files changed, 66 insertions, 1 deletions
diff --git a/dev-libs/cdk/ChangeLog b/dev-libs/cdk/ChangeLog
index 693a28e22e2b..212d068bc9e1 100644
--- a/dev-libs/cdk/ChangeLog
+++ b/dev-libs/cdk/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/cdk
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cdk/ChangeLog,v 1.40 2006/08/09 11:09:23 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cdk/ChangeLog,v 1.41 2006/11/09 10:12:18 drizzt Exp $
+
+*cdk-5.0.20060507 (09 Nov 2006)
+
+ 09 Nov 2006; Timothy Redaelli <drizzt@gentoo.org>
+ +files/cdk-5.0.20060507-as-needed.patch, +cdk-5.0.20060507.ebuild:
+ Version bump.
+ Applied my patch for as-needed.
+ Used toolchain-funcs to export CC.
09 Aug 2006; Simon Stelling <blubb@gentoo.org> cdk-5.0.20060220.ebuild:
stable on amd64
diff --git a/dev-libs/cdk/cdk-5.0.20060507.ebuild b/dev-libs/cdk/cdk-5.0.20060507.ebuild
new file mode 100644
index 000000000000..29ae1892903a
--- /dev/null
+++ b/dev-libs/cdk/cdk-5.0.20060507.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cdk/cdk-5.0.20060507.ebuild,v 1.1 2006/11/09 10:12:18 drizzt Exp $
+
+inherit eutils versionator toolchain-funcs
+
+MY_P="${PN}-$(replace_version_separator 2 -)"
+DESCRIPTION="A library of curses widgets"
+HOMEPAGE="http://dickey.his.com/cdk/cdk.html"
+SRC_URI="ftp://invisible-island.net/cdk/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2
+ sys-devel/libtool"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_compile() {
+ tc-export CC
+ econf \
+ --with-ncurses --with-libtool \
+ || die
+
+ emake || die
+}
+
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ DOCUMENT_DIR="${D}/usr/share/doc/${MY_P}" install \
+ || die
+}
diff --git a/dev-libs/cdk/files/cdk-5.0.20060507-as-needed.patch b/dev-libs/cdk/files/cdk-5.0.20060507-as-needed.patch
new file mode 100644
index 000000000000..93469592ec4a
--- /dev/null
+++ b/dev-libs/cdk/files/cdk-5.0.20060507-as-needed.patch
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2006-09-24 00:27:27.799270048 +0200
++++ Makefile.in 2006-09-24 00:28:10.258815216 +0200
+@@ -265,7 +265,7 @@
+ all cdklib :: $(DEFAULT)
+
+ $(CDKLIB) :: $(OBJECTS)
+- @echo creating $@; $(LIBTOOL_CREATE) $@ $(LIB_OBJECT)
++ @echo creating $@; $(LIBTOOL_CREATE) $@ $(LIB_OBJECT) $(LIBS)
+ @$(RANLIB) $@
+
+ cdkshlib $(CDKSHLIB) :: $(CDKSHOBJS)
diff --git a/dev-libs/cdk/files/digest-cdk-5.0.20060507 b/dev-libs/cdk/files/digest-cdk-5.0.20060507
new file mode 100644
index 000000000000..d7535de491a3
--- /dev/null
+++ b/dev-libs/cdk/files/digest-cdk-5.0.20060507
@@ -0,0 +1,3 @@
+MD5 0ec2460a4484d5f5595d8faca61bc9c5 cdk-5.0-20060507.tgz 396514
+RMD160 c541f758299d64218ea0ae2bfe22a43bccebb46c cdk-5.0-20060507.tgz 396514
+SHA256 e823bfcce52916727cb23d6d549a64347c45c364b3c628d6a352c407fce8f4b4 cdk-5.0-20060507.tgz 396514