summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-08-15 22:07:34 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-08-15 22:07:34 +0000
commit45c0a62865937bdb84a32b0bace5a4c71dda63c3 (patch)
tree242ebf062f9017a7884828506b475abb31e2b863 /dev-libs
parentVersion bump (diff)
downloadgentoo-2-45c0a62865937bdb84a32b0bace5a4c71dda63c3.tar.gz
gentoo-2-45c0a62865937bdb84a32b0bace5a4c71dda63c3.tar.bz2
gentoo-2-45c0a62865937bdb84a32b0bace5a4c71dda63c3.zip
Version bump, needs libsoup-gnome-2.30. Add missing gobject-introspection in DEPEND.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/totem-pl-parser/ChangeLog9
-rw-r--r--dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild5
-rw-r--r--dev-libs/totem-pl-parser/totem-pl-parser-2.30.2.ebuild46
3 files changed, 57 insertions, 3 deletions
diff --git a/dev-libs/totem-pl-parser/ChangeLog b/dev-libs/totem-pl-parser/ChangeLog
index 1587de0d4f51..f3df54cf88a0 100644
--- a/dev-libs/totem-pl-parser/ChangeLog
+++ b/dev-libs/totem-pl-parser/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/totem-pl-parser
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/ChangeLog,v 1.62 2010/08/15 21:43:15 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/ChangeLog,v 1.63 2010/08/15 22:07:34 eva Exp $
+
+*totem-pl-parser-2.30.2 (15 Aug 2010)
+
+ 15 Aug 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ totem-pl-parser-2.30.1.ebuild, +totem-pl-parser-2.30.2.ebuild:
+ Version bump, needs libsoup-gnome-2.30. Add missing gobject-introspection
+ in DEPEND.
15 Aug 2010; Gilles Dartiguelongue <eva@gentoo.org>
totem-pl-parser-2.30.1.ebuild:
diff --git a/dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild b/dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild
index 6dd96558ab3f..69167c999835 100644
--- a/dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild
+++ b/dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild,v 1.5 2010/08/15 21:43:15 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild,v 1.6 2010/08/15 22:07:34 eva Exp $
EAPI="2"
GCONF_DEBUG="no"
@@ -22,7 +22,8 @@ DEPEND="${RDEPEND}
!<media-video/totem-2.21
>=dev-util/intltool-0.35
>=dev-util/gtk-doc-am-1.11
- doc? ( >=dev-util/gtk-doc-1.11 )"
+ doc? ( >=dev-util/gtk-doc-1.11 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
DOCS="AUTHORS ChangeLog NEWS"
diff --git a/dev-libs/totem-pl-parser/totem-pl-parser-2.30.2.ebuild b/dev-libs/totem-pl-parser/totem-pl-parser-2.30.2.ebuild
new file mode 100644
index 000000000000..47ccbf364dbd
--- /dev/null
+++ b/dev-libs/totem-pl-parser/totem-pl-parser-2.30.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/totem-pl-parser-2.30.2.ebuild,v 1.1 2010/08/15 22:07:34 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="Playlist parsing library"
+HOMEPAGE="http://www.gnome.org/projects/totem/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+# TODO: Re-generate doc ?
+IUSE="doc introspection test"
+
+RDEPEND=">=dev-libs/glib-2.24
+ dev-libs/gmime:2.4
+ >=net-libs/libsoup-gnome-2.30:2.4"
+DEPEND="${RDEPEND}
+ !<media-video/totem-2.21
+ >=dev-util/intltool-0.35
+ >=dev-util/gtk-doc-am-1.11
+ doc? ( >=dev-util/gtk-doc-1.11 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.14 )"
+
+DOCS="AUTHORS ChangeLog NEWS"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-static $(use_enable introspection)"
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ emake check || die "emake check failed"
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libtotem-plparser-mini.so.12
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libtotem-plparser-mini.so.12
+}