summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-11-02 18:09:34 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-11-02 18:09:34 +0000
commit4988c8f355c08fe57597dc804c1ab66b7dd5b639 (patch)
tree4e1e65301405ab90801bc7157c785487dde33739 /dev-libs
parentKeyword ~amd64 for my own use. (diff)
downloadgentoo-2-4988c8f355c08fe57597dc804c1ab66b7dd5b639.tar.gz
gentoo-2-4988c8f355c08fe57597dc804c1ab66b7dd5b639.tar.bz2
gentoo-2-4988c8f355c08fe57597dc804c1ab66b7dd5b639.zip
Bug #471430: bump.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libmemcached/ChangeLog8
-rw-r--r--dev-libs/libmemcached/libmemcached-1.0.17.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-libs/libmemcached/ChangeLog b/dev-libs/libmemcached/ChangeLog
index d34633f6d680..1b1121f01933 100644
--- a/dev-libs/libmemcached/ChangeLog
+++ b/dev-libs/libmemcached/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libmemcached
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/ChangeLog,v 1.64 2013/08/23 14:05:44 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/ChangeLog,v 1.65 2013/11/02 18:09:34 robbat2 Exp $
+
+*libmemcached-1.0.17 (02 Nov 2013)
+
+ 02 Nov 2013; Robin H. Johnson <robbat2@gentoo.org>
+ +libmemcached-1.0.17.ebuild:
+ Bug #471430: bump.
23 Aug 2013; Agostino Sarubbo <ago@gentoo.org> libmemcached-1.0.14.ebuild:
Stable for sh, wrt bug #480460
diff --git a/dev-libs/libmemcached/libmemcached-1.0.17.ebuild b/dev-libs/libmemcached/libmemcached-1.0.17.ebuild
new file mode 100644
index 000000000000..7fc52d354768
--- /dev/null
+++ b/dev-libs/libmemcached/libmemcached-1.0.17.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/libmemcached-1.0.17.ebuild,v 1.1 2013/11/02 18:09:34 robbat2 Exp $
+
+EAPI="4"
+
+inherit eutils multilib
+
+DESCRIPTION="a C client library to the memcached server"
+HOMEPAGE="http://libmemcached.org/libMemcached.html"
+SRC_URI="http://launchpad.net/${PN}/1.0/${PV}/+download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~sparc-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug hsieh +libevent static-libs"
+
+DEPEND="net-misc/memcached
+ dev-libs/cyrus-sasl
+ libevent? ( dev-libs/libevent )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --disable-dtrace \
+ $(use_enable static-libs static) \
+ $(use_enable sasl sasl) \
+ $(use_enable debug debug) \
+ $(use_enable debug assert) \
+ $(use_enable hsieh hsieh_hash) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ use static-libs || rm -f "${D}"/usr/$(get_libdir)/lib*.la
+
+ dodoc AUTHORS ChangeLog README THANKS TODO
+ # remove manpage to avoid collision, see bug #299330
+ rm -f "${D}"/usr/share/man/man1/memdump.*
+ newman man/memdump.1 memcached_memdump.1
+}