summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-10-22 11:24:32 +0000
committerJeroen Roovers <jer@gentoo.org>2012-10-22 11:24:32 +0000
commit4d4e448d1673db7f62c0a17d44d87a8a71c6888d (patch)
tree5b18ddf336a9aaed7249847dc4ac728f1b4cd611 /dev-libs
parentRemove old. (diff)
downloadgentoo-2-4d4e448d1673db7f62c0a17d44d87a8a71c6888d.tar.gz
gentoo-2-4d4e448d1673db7f62c0a17d44d87a8a71c6888d.tar.bz2
gentoo-2-4d4e448d1673db7f62c0a17d44d87a8a71c6888d.zip
Version bump.
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libnl/ChangeLog8
-rw-r--r--dev-libs/libnl/libnl-3.2.14.ebuild50
-rw-r--r--dev-libs/libnl/libnl-3.2.9.ebuild49
3 files changed, 57 insertions, 50 deletions
diff --git a/dev-libs/libnl/ChangeLog b/dev-libs/libnl/ChangeLog
index 0bdf73aa48e2..fefa3361e5e6 100644
--- a/dev-libs/libnl/ChangeLog
+++ b/dev-libs/libnl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libnl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/ChangeLog,v 1.108 2012/10/19 16:22:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/ChangeLog,v 1.109 2012/10/22 11:24:32 jer Exp $
+
+*libnl-3.2.14 (22 Oct 2012)
+
+ 22 Oct 2012; Jeroen Roovers <jer@gentoo.org> -libnl-3.2.9.ebuild,
+ +libnl-3.2.14.ebuild:
+ Version bump.
19 Oct 2012; Jeroen Roovers <jer@gentoo.org> -libnl-3.2.11.ebuild,
-libnl-3.2.12.ebuild, -files/libnl-3.2.12-doc.patch:
diff --git a/dev-libs/libnl/libnl-3.2.14.ebuild b/dev-libs/libnl/libnl-3.2.14.ebuild
new file mode 100644
index 000000000000..474076cee791
--- /dev/null
+++ b/dev-libs/libnl/libnl-3.2.14.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/libnl-3.2.14.ebuild,v 1.1 2012/10/22 11:24:32 jer Exp $
+
+EAPI=4
+inherit eutils multilib
+
+DESCRIPTION="A library for applications dealing with netlink socket"
+HOMEPAGE="http://www.infradead.org/~tgr/libnl/"
+SRC_URI="
+ http://www.infradead.org/~tgr/libnl/files/${P}.tar.gz
+ http://www.infradead.org/~tgr/libnl/files/${PN}-doc-${PV}.tar.gz
+"
+LICENSE="LGPL-2.1"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="doc static-libs utils"
+
+DEPEND="
+ sys-devel/flex
+ sys-devel/bison
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.1-vlan-header.patch
+}
+
+src_configure() {
+ econf \
+ --disable-silent-rules \
+ $(use_enable static-libs static) \
+ $(use_enable utils cli)
+}
+
+src_install() {
+ default
+ if use doc; then
+ dohtml -r \
+ -a css,html,js,map,png \
+ "${WORKDIR}"/${PN}-doc-${PV}
+
+ fi
+
+ if ! use static-libs; then
+ rm -f "${D}"/usr/lib*/lib*.la
+ fi
+
+ dodoc ChangeLog
+}
diff --git a/dev-libs/libnl/libnl-3.2.9.ebuild b/dev-libs/libnl/libnl-3.2.9.ebuild
deleted file mode 100644
index 636ceed042dd..000000000000
--- a/dev-libs/libnl/libnl-3.2.9.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/libnl-3.2.9.ebuild,v 1.6 2012/06/29 16:36:47 jer Exp $
-
-EAPI=4
-inherit eutils multilib
-
-DESCRIPTION="A library for applications dealing with netlink socket"
-HOMEPAGE="http://www.infradead.org/~tgr/libnl/"
-SRC_URI="http://www.infradead.org/~tgr/libnl/files/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
-IUSE="doc static-libs utils"
-
-DEPEND="
- sys-devel/flex
- sys-devel/bison
- doc? (
- <app-doc/doxygen-1.8.0[latex]
- app-text/xmlstarlet
- )
-"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.1-vlan-header.patch
-}
-
-src_configure() {
- econf $(use_enable static-libs static) $(use_enable utils cli)
-}
-
-src_compile() {
- default
- use doc && emake -C doc api_ref
-}
-
-src_install() {
- default
- if use doc; then
- dohtml doc/api/*
- fi
-
- if ! use static-libs; then
- rm -f "${D}"/usr/lib*/lib*.la
- fi
-
- dodoc ChangeLog
-}