summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-09-28 15:48:57 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-09-28 15:48:57 +0000
commit4da926f8dd33fa9745bb9e4ed075291262e8faa8 (patch)
tree455f255fe932142bc078b7859c4482965c21e115 /dev-libs
parentunmask perl-5.8.8-r6 as bug#269430 is fixed now (diff)
downloadgentoo-2-4da926f8dd33fa9745bb9e4ed075291262e8faa8.tar.gz
gentoo-2-4da926f8dd33fa9745bb9e4ed075291262e8faa8.tar.bz2
gentoo-2-4da926f8dd33fa9745bb9e4ed075291262e8faa8.zip
Use has_version to print warning only if sys-devel/gcc is built with USE libffi. This can be made a blocking atom once sparc is done with gnustep-base/gnustep-base and old versions are removed from tree. Thanks to Dirkjan Ochtman and Arfrever Frehtes Taifersar Arahesis in bug 286733.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libffi/ChangeLog8
-rw-r--r--dev-libs/libffi/libffi-3.0.8.ebuild16
2 files changed, 16 insertions, 8 deletions
diff --git a/dev-libs/libffi/ChangeLog b/dev-libs/libffi/ChangeLog
index 57287dbc13e5..6f8d4aa23551 100644
--- a/dev-libs/libffi/ChangeLog
+++ b/dev-libs/libffi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libffi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/ChangeLog,v 1.75 2009/09/23 19:15:35 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/ChangeLog,v 1.76 2009/09/28 15:48:57 ssuominen Exp $
+
+ 28 Sep 2009; Samuli Suominen <ssuominen@gentoo.org> libffi-3.0.8.ebuild:
+ Use has_version to print warning only if sys-devel/gcc is built with USE
+ libffi. This can be made a blocking atom once sparc is done with
+ gnustep-base/gnustep-base and old versions are removed from tree. Thanks
+ to Dirkjan Ochtman and Arfrever Frehtes Taifersar Arahesis in bug 286733.
23 Sep 2009; Alexis Ballier <aballier@gentoo.org> libffi-3.0.8.ebuild,
+files/libffi-3.0.8-fbsd.patch:
diff --git a/dev-libs/libffi/libffi-3.0.8.ebuild b/dev-libs/libffi/libffi-3.0.8.ebuild
index 3c8f7d61a912..c477365d9191 100644
--- a/dev-libs/libffi/libffi-3.0.8.ebuild
+++ b/dev-libs/libffi/libffi-3.0.8.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/libffi-3.0.8.ebuild,v 1.17 2009/09/23 19:15:35 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/libffi-3.0.8.ebuild,v 1.18 2009/09/28 15:48:57 ssuominen Exp $
EAPI=2
-inherit eutils autotools
+inherit autotools eutils
DESCRIPTION="a portable, high level programming interface to various calling conventions."
HOMEPAGE="http://sourceware.org/libffi"
@@ -19,7 +19,7 @@ DEPEND="!<dev-libs/g-wrap-1.9.11
test? ( dev-util/dejagnu )"
src_prepare() {
- epatch "${FILESDIR}/${P}-fbsd.patch"
+ epatch "${FILESDIR}"/${P}-fbsd.patch
eautoreconf
}
@@ -31,12 +31,14 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die
dodoc ChangeLog* README TODO
}
pkg_postinst() {
- ewarn "Please unset USE flag libffi in sys-devel/gcc. There is no"
- ewarn "file collision but your package might link to wrong library."
- ebeep
+ if has_version sys-devel/gcc[libffi]; then
+ ewarn "Please unset USE flag libffi in sys-devel/gcc. There is no"
+ ewarn "file collision but your package might link to wrong library."
+ ebeep
+ fi
}