summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-03 02:16:00 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-03 02:16:00 +0000
commit5241dd90b87494ab1c0b9bfbbd14b927d26ea23f (patch)
tree255fe7d792733324c8dde33ae08dbadc8f267a5f /dev-libs
parentremove DEBUG=yes (diff)
downloadgentoo-2-5241dd90b87494ab1c0b9bfbbd14b927d26ea23f.tar.gz
gentoo-2-5241dd90b87494ab1c0b9bfbbd14b927d26ea23f.tar.bz2
gentoo-2-5241dd90b87494ab1c0b9bfbbd14b927d26ea23f.zip
cleanup old portage styles
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.5.ebuild33
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild24
2 files changed, 21 insertions, 36 deletions
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.5.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.5.ebuild
index 45e35db80b88..f6bda390c7cd 100644
--- a/dev-libs/libmcrypt/libmcrypt-2.5.5.ebuild
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.5.ebuild
@@ -1,23 +1,21 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/libmcrypt-2.5.5.ebuild,v 1.5 2003/03/25 05:20:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/libmcrypt-2.5.5.ebuild,v 1.6 2003/08/03 02:16:00 vapier Exp $
-inherit libtool
+#inherit libtool
-S=${WORKDIR}/${P}
DESCRIPTION="libmcrypt is a library that provides uniform interface to access several encryption algorithms."
-SRC_URI="ftp://mcrypt.hellug.gr/pub/mcrypt/libmcrypt/${P}.tar.gz"
HOMEPAGE="http://mcrypt.hellug.gr/"
+SRC_URI="ftp://mcrypt.hellug.gr/pub/mcrypt/libmcrypt/${P}.tar.gz"
-DEPEND=">=sys-devel/automake-1.6.1
- >=sys-devel/libtool-1.4.1-r8"
-IUSE=""
-SLOT="0"
LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
KEYWORDS="x86 sparc ppc hppa alpha"
-src_unpack() {
+DEPEND=">=sys-devel/automake-1.6.1
+ >=sys-devel/libtool-1.4.1-r8"
+src_unpack() {
unpack ${A}
cd ${S}
@@ -31,33 +29,28 @@ src_unpack() {
echo ">>> Reconfiguring package..."
export WANT_AUTOMAKE_1_6=1
export WANT_AUTOCONF_2_5=1
- autoreconf --force --install --symlink &>${T}/autoreconf.log || ( \
+ autoreconf --force --install --symlink &>${T}/autoreconf.log || {
echo "DEBUG: working directory is: `pwd`" >>${T}/autoreconf.log
eerror "Reonfigure failed, please attatch the contents of:"
eerror
eerror " ${T}/autoreconf.log"
eerror
eerror "in your bugreport."
- # we need an error here, else the ebuild do not die
- exit 1
- ) || die "running autoreconf failed"
+ die "running autoreconf failed"
+ }
}
src_compile() {
- # Doesn't work with --host bug #3517
- econf --disable-posix-threads || die
-
# PHP manual states to disable posix threads, no further explanation
# given, but i'll stick with it :)
# (Source: http://www.php.net/manual/en/ref.mcrypt.php)
-
+ # Doesn't work with --host bug #3517
+ econf --disable-posix-threads || die
emake || die
}
-src_install () {
-
+src_install() {
dodir /usr/{bin,include,lib}
-
einstall || die
dodoc AUTHORS COPYING COPYING.LIB INSTALL NEWS README THANKS TODO
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild
index 460998b526f2..7124addf149f 100644
--- a/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild
@@ -1,35 +1,27 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild,v 1.3 2003/07/23 21:20:01 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild,v 1.4 2003/08/03 02:16:00 vapier Exp $
inherit libtool
-S=${WORKDIR}/${P}
DESCRIPTION="libmcrypt is a library that provides uniform interface to access several encryption algorithms."
-SRC_URI="ftp://mcrypt.hellug.gr/pub/mcrypt/libmcrypt/${P}.tar.gz"
HOMEPAGE="http://mcrypt.hellug.gr/"
+SRC_URI="ftp://mcrypt.hellug.gr/pub/mcrypt/libmcrypt/${P}.tar.gz"
-DEPEND=">=sys-devel/automake-1.6.1
- >=sys-devel/libtool-1.4.1-r8"
-IUSE=""
-SLOT="0"
LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
KEYWORDS="x86 ~sparc ~ppc hppa ~alpha"
-src_compile() {
-
- local myconf
- myconf=""
- use pic && myconf="${myconf} --with-pic"
- econf ${myconf} || die "configure failure"
+DEPEND=">=sys-devel/automake-1.6.1
+ >=sys-devel/libtool-1.4.1-r8"
+src_compile() {
+ econf || die "configure failure"
emake || die "make failure"
}
-src_install () {
-
+src_install() {
dodir /usr/{bin,include,lib}
-
einstall || die "install failure"
dodoc AUTHORS KNOWN-BUGS COPYING COPYING.LIB INSTALL NEWS README THANKS TODO ChangeLog