summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-08-22 17:59:58 +0000
committerJonathan Callen <abcd@gentoo.org>2010-08-22 17:59:58 +0000
commit57d7c191f4993e37040b6140c3be84c1519e6256 (patch)
treedb19ca0888341da43034ec66542c6234c8b1eefa /dev-libs
parentClean up old revision. (diff)
downloadgentoo-2-57d7c191f4993e37040b6140c3be84c1519e6256.tar.gz
gentoo-2-57d7c191f4993e37040b6140c3be84c1519e6256.tar.bz2
gentoo-2-57d7c191f4993e37040b6140c3be84c1519e6256.zip
Bump to 0.9.3, from gnome overlay
(Portage version: v2.2_rc67-680-g060956c/cvs/Linux i686)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gobject-introspection/ChangeLog8
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-0.9.3.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-libs/gobject-introspection/ChangeLog b/dev-libs/gobject-introspection/ChangeLog
index d8fd2f7dce2e..355b85b82b97 100644
--- a/dev-libs/gobject-introspection/ChangeLog
+++ b/dev-libs/gobject-introspection/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/gobject-introspection
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.8 2010/07/24 17:04:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.9 2010/08/22 17:59:58 abcd Exp $
+
+*gobject-introspection-0.9.3 (22 Aug 2010)
+
+ 22 Aug 2010; Jonathan Callen <abcd@gentoo.org>
+ +gobject-introspection-0.9.3.ebuild:
+ Bump to 0.9.3, from gnome overlay
24 Jul 2010; Raúl Porcel <armin76@gentoo.org>
gobject-introspection-0.9.0.ebuild:
diff --git a/dev-libs/gobject-introspection/gobject-introspection-0.9.3.ebuild b/dev-libs/gobject-introspection/gobject-introspection-0.9.3.ebuild
new file mode 100644
index 000000000000..b6a0c5da1355
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-0.9.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-0.9.3.ebuild,v 1.1 2010/08/22 17:59:58 abcd Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.5"
+
+inherit python gnome2
+
+DESCRIPTION="Introspection infrastructure for gobject library bindings"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/glib-2.19.0
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.12 )
+ dev-util/pkgconfig
+ sys-devel/flex
+ test? ( x11-libs/cairo )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ G2CONF="${G2CONF} --disable-static"
+
+ # FIXME: Parallel compilation failure with USE=doc
+ use doc && MAKEOPTS="-j1"
+
+ # Don't pre-compile .py
+ ln -sf $(type -P true) py-compile
+}
+
+src_configure() {
+ econf $(use_enable test tests) || die "econf failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}/giscanner
+ python_need_rebuild
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/lib*/${PN}/giscanner
+}