summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-19 07:03:36 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-19 07:03:36 +0000
commit62ddfaff9e90690b4c5c019a23e6f9f42446d9da (patch)
tree194c8b3c04742db54eaeee7ace949fa5f468e732 /dev-libs
parentFix compilation of ld64, add back wrongly dropped LD64LIBS, thanks Charles Da... (diff)
downloadgentoo-2-62ddfaff9e90690b4c5c019a23e6f9f42446d9da.tar.gz
gentoo-2-62ddfaff9e90690b4c5c019a23e6f9f42446d9da.tar.bz2
gentoo-2-62ddfaff9e90690b4c5c019a23e6f9f42446d9da.zip
Change dep from quvi to libquvi (radhermit recommendation), apply marienzs
(Portage version: 2.2.0_alpha69/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/totem-pl-parser/ChangeLog15
-rw-r--r--dev-libs/totem-pl-parser/files/totem-pl-parser-2.32.6-quvi-0.4.patch29
-rw-r--r--dev-libs/totem-pl-parser/totem-pl-parser-2.32.6-r1.ebuild71
3 files changed, 114 insertions, 1 deletions
diff --git a/dev-libs/totem-pl-parser/ChangeLog b/dev-libs/totem-pl-parser/ChangeLog
index 2f00d4b1448b..0eb1e22cb1ab 100644
--- a/dev-libs/totem-pl-parser/ChangeLog
+++ b/dev-libs/totem-pl-parser/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for dev-libs/totem-pl-parser
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/ChangeLog,v 1.104 2011/10/16 17:25:59 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/ChangeLog,v 1.105 2011/10/19 07:03:36 tetromino Exp $
+
+*totem-pl-parser-2.32.6-r1 (19 Oct 2011)
+
+ 19 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +totem-pl-parser-2.32.6-r1.ebuild,
+ +files/totem-pl-parser-2.32.6-quvi-0.4.patch:
+ Change dependency from quvi to libquvi per Tim Harder's recommendation (and
+ drop keywords accordingly). Add libquvi-0.4 compatibility patch (deprecated
+ "video" interface was removed during libquvi-0.2.20 development); fixes
+ bug #386651. Many thanks to Marien Zwart for the patch and to the many users
+ in the bug's CC list for testing. Patch has not yet been applied upstream
+ (see https://bugzilla.gnome.org/show_bug.cgi?id=661451), but is obviously
+ correct by inspection.
16 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org>
totem-pl-parser-2.32.6.ebuild:
diff --git a/dev-libs/totem-pl-parser/files/totem-pl-parser-2.32.6-quvi-0.4.patch b/dev-libs/totem-pl-parser/files/totem-pl-parser-2.32.6-quvi-0.4.patch
new file mode 100644
index 000000000000..23917853a58c
--- /dev/null
+++ b/dev-libs/totem-pl-parser/files/totem-pl-parser-2.32.6-quvi-0.4.patch
@@ -0,0 +1,29 @@
+Use "media" interface instead of "video" (deprecated in libquvi-0.2.15,
+removed in 0.2.20). Fixes compatibility with libquvi-0.4.
+
+See https://bugs.gentoo.org/show_bug.cgi?id=386651,
+https://bugzilla.gnome.org/show_bug.cgi?id=661451
+
+--- a/plparse/totem-pl-parser-videosite.c
++++ b/plparse/totem-pl-parser-videosite.c
+@@ -75,7 +75,7 @@
+ #ifdef HAVE_QUVI
+ QUVIcode rc;
+ quvi_t handle;
+- quvi_video_t v;
++ quvi_media_t v;
+ char *uri;
+ /* properties */
+ const char *video_uri;
+@@ -104,8 +104,8 @@
+ return TOTEM_PL_PARSER_RESULT_ERROR;
+ }
+
+- getprop (QUVIPROP_VIDEOURL, video_uri);
+- if (quvi_getprop (v, QUVIPROP_VIDEOFILELENGTH, &length) == QUVI_OK)
++ getprop (QUVIPROP_MEDIAURL, video_uri);
++ if (quvi_getprop (v, QUVIPROP_MEDIACONTENTLENGTH, &length) == QUVI_OK)
+ length_str = g_strdup_printf ("%f", length);
+ else
+ length_str = NULL;
+
diff --git a/dev-libs/totem-pl-parser/totem-pl-parser-2.32.6-r1.ebuild b/dev-libs/totem-pl-parser/totem-pl-parser-2.32.6-r1.ebuild
new file mode 100644
index 000000000000..e09c3039aa51
--- /dev/null
+++ b/dev-libs/totem-pl-parser/totem-pl-parser-2.32.6-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/totem-pl-parser-2.32.6-r1.ebuild,v 1.1 2011/10/19 07:03:36 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="Playlist parsing library"
+HOMEPAGE="http://projects.gnome.org/totem/ http://developer.gnome.org/totem-pl-parser/stable/"
+
+# eautoreconf needs:
+#SRC_URI="${SRC_URI} mirror://gentoo/introspection-20110205.m4.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="archive doc +introspection +quvi"
+
+RDEPEND=">=dev-libs/glib-2.24:2
+ dev-libs/gmime:2.4
+ >=net-libs/libsoup-gnome-2.30:2.4
+ archive? ( >=app-arch/libarchive-2.8.4 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ quvi? ( >=media-libs/libquvi-0.2.15 )"
+DEPEND="${RDEPEND}
+ !<media-video/totem-2.21
+ >=sys-devel/gettext-0.17
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.11 )"
+# eautoreconf needs:
+# >=dev-util/gtk-doc-am-1.11
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-maintainer-mode
+ $(use_enable archive libarchive)
+ $(use_enable quvi)
+ $(use_enable introspection)"
+ DOCS="AUTHORS ChangeLog NEWS"
+}
+
+# eautoreconf needs:
+#src_unpack() {
+# # If gobject-introspection is installed, we don't need the extra .m4
+# if has_version "dev-libs/gobject-introspection"; then
+# unpack ${P}.tar.bz2
+# else
+# unpack ${A}
+# fi
+#}
+
+src_prepare() {
+ # bug #386651, https://bugzilla.gnome.org/show_bug.cgi?id=661451
+ epatch "${FILESDIR}/${PN}-2.32.6-quvi-0.4.patch"
+
+ gnome2_src_prepare
+
+ # Disable tests requiring network access, bug #346127
+ sed -e 's:\(g_test_add_func.*/parser/resolution.*\):/*\1*/:' \
+ -e 's:\(g_test_add_func.*/parser/parsing/itms_link.*\):/*\1*/:' \
+ -i plparse/tests/parser.c || die "sed failed"
+}
+
+src_test() {
+ # This is required as told by upstream in bgo#629542
+ dbus-launch emake check || die "emake check failed"
+}