summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-02-05 17:29:11 +0000
committerMarinus Schraal <foser@gentoo.org>2003-02-05 17:29:11 +0000
commit933da5b239778a3184119acc4c4c181259ba01e3 (patch)
tree5578203673609ca56a95693a1a90bbce5a135c16 /dev-libs
parentadded libxslt to gnome 2.2 list (diff)
downloadgentoo-2-933da5b239778a3184119acc4c4c181259ba01e3.tar.gz
gentoo-2-933da5b239778a3184119acc4c4c181259ba01e3.tar.bz2
gentoo-2-933da5b239778a3184119acc4c4c181259ba01e3.zip
New version
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libxml2/ChangeLog7
-rw-r--r--dev-libs/libxml2/files/digest-libxml2-2.5.21
-rw-r--r--dev-libs/libxml2/libxml2-2.5.2.ebuild52
-rw-r--r--dev-libs/libxslt/ChangeLog7
-rw-r--r--dev-libs/libxslt/files/digest-libxslt-1.0.251
-rw-r--r--dev-libs/libxslt/libxslt-1.0.25.ebuild47
6 files changed, 113 insertions, 2 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index 435bade7d194..93ac23262349 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libxml2
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.24 2003/01/31 02:33:45 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.25 2003/02/05 17:28:21 foser Exp $
+
+*libxml2-2.5.2 (05 Feb 2003)
+
+ 05 Feb 2003; foser <foser@gentoo.org> libxml2-2.5.1.ebuild :
+ New version
*libxml2-2.5.1 (30 Jan 2003)
diff --git a/dev-libs/libxml2/files/digest-libxml2-2.5.2 b/dev-libs/libxml2/files/digest-libxml2-2.5.2
new file mode 100644
index 000000000000..b7dc45335d1f
--- /dev/null
+++ b/dev-libs/libxml2/files/digest-libxml2-2.5.2
@@ -0,0 +1 @@
+MD5 0d3a106fbb8ec4198d27d8063f216f07 libxml2-2.5.2.tar.bz2 2272402
diff --git a/dev-libs/libxml2/libxml2-2.5.2.ebuild b/dev-libs/libxml2/libxml2-2.5.2.ebuild
new file mode 100644
index 000000000000..5a38ebf84592
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.5.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.5.2.ebuild,v 1.1 2003/02/05 17:28:21 foser Exp $
+
+inherit eutils libtool gnome.org
+
+IUSE="python readline"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="sys-libs/zlib
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+
+SLOT="2"
+LICENSE="MIT"
+KEYWORDS="~x86 ~ppc"
+
+src_compile() {
+ # Fix .la files of python site packages
+ elibtoolize
+
+ local myconf=""
+
+ # This breaks gnome2 (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+ #use zlib && myconf="--with-zlib" || myconf="--without-zlib"
+
+ use python && myconf="${myconf} --with-python" \
+ || myconf="${myconf} --without-python"
+ use readline && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ econf --with-zlib ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}
diff --git a/dev-libs/libxslt/ChangeLog b/dev-libs/libxslt/ChangeLog
index 684218822e00..94cafc41590c 100644
--- a/dev-libs/libxslt/ChangeLog
+++ b/dev-libs/libxslt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libxslt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.20 2003/01/30 14:21:40 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.21 2003/02/05 17:29:11 foser Exp $
+
+*libxslt-1.0.25 (05 Feb 2003)
+
+ 05 Feb 2003; foser <foser@gentoo.org> libxslt-1.0.25.ebuild :
+ New version
*libxslt-1.0.24 (30 Jan 2003)
diff --git a/dev-libs/libxslt/files/digest-libxslt-1.0.25 b/dev-libs/libxslt/files/digest-libxslt-1.0.25
new file mode 100644
index 000000000000..2df1cdfaa94a
--- /dev/null
+++ b/dev-libs/libxslt/files/digest-libxslt-1.0.25
@@ -0,0 +1 @@
+MD5 f86ffd445a05ceadf83e612b60fe7862 libxslt-1.0.25.tar.bz2 1555372
diff --git a/dev-libs/libxslt/libxslt-1.0.25.ebuild b/dev-libs/libxslt/libxslt-1.0.25.ebuild
new file mode 100644
index 000000000000..d1a34a5dbdef
--- /dev/null
+++ b/dev-libs/libxslt/libxslt-1.0.25.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.0.25.ebuild,v 1.1 2003/02/05 17:29:11 foser Exp $
+
+inherit libtool gnome.org
+
+IUSE="python"
+S=${WORKDIR}/${P}
+DESCRIPTION="XSLT libraries and tools"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+
+RDEPEND=">=dev-libs/libxml2-2.5.2
+ python? ( dev-lang/python )"
+
+DEPEND="${RDEPEND}
+ sys-devel/perl"
+
+src_compile() {
+ # Fix .la files of python site packages
+ elibtoolize
+
+ local myconf
+
+ use python && myconf="--with-python" || myconf="--without-python"
+
+ econf ${myconf} || die
+
+ #libxslt-1.0.19 didn't like parallel make; test a good deal before re-enabling
+ #(drobbins, 24 Jul 2002)
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+}