summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-09-27 21:23:34 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-09-27 21:23:34 +0000
commita1a434082734b1e454acfc6152e9c91d32340ece (patch)
treecc796bb2db158b80f71e1626a1d5b32b185454a1 /dev-libs
parentStable on amd64 wrt bug #338665 (diff)
downloadgentoo-2-a1a434082734b1e454acfc6152e9c91d32340ece.tar.gz
gentoo-2-a1a434082734b1e454acfc6152e9c91d32340ece.tar.bz2
gentoo-2-a1a434082734b1e454acfc6152e9c91d32340ece.zip
Version bump. Update for tzdata 2010k. Translation updates. Set python:2 in pkg_setup, bug #322993.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgweather/ChangeLog9
-rw-r--r--dev-libs/libgweather/libgweather-2.30.3.ebuild60
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-libs/libgweather/ChangeLog b/dev-libs/libgweather/ChangeLog
index 390ed5196557..57653d6ace8d 100644
--- a/dev-libs/libgweather/ChangeLog
+++ b/dev-libs/libgweather/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libgweather
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.63 2010/09/11 18:43:16 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.64 2010/09/27 21:23:34 eva Exp $
+
+*libgweather-2.30.3 (27 Sep 2010)
+
+ 27 Sep 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +libgweather-2.30.3.ebuild:
+ Version bump. Update for tzdata 2010k. Translation updates. Set python:2
+ in pkg_setup, bug #322993.
11 Sep 2010; Joseph Jezak <josejx@gentoo.org> libgweather-2.30.2.ebuild:
Marked ppc for bug #324077.
diff --git a/dev-libs/libgweather/libgweather-2.30.3.ebuild b/dev-libs/libgweather/libgweather-2.30.3.ebuild
new file mode 100644
index 000000000000..81380db20127
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-2.30.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-2.30.3.ebuild,v 1.1 2010/09/27 21:23:34 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="python? 2"
+
+inherit autotools gnome2 python
+
+DESCRIPTION="Library to access weather information from online services"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="python doc"
+
+# libsoup-gnome is to be used because libsoup[gnome] might not
+# get libsoup-gnome installed by the time ${P} is built
+RDEPEND=">=x11-libs/gtk+-2.11
+ >=dev-libs/glib-2.13
+ >=gnome-base/gconf-2.8
+ >=net-libs/libsoup-gnome-2.25.1:2.4
+ >=dev-libs/libxml2-2.6.0
+ python? (
+ >=dev-python/pygobject-2
+ >=dev-python/pygtk-2 )
+ !<gnome-base/gnome-applets-2.22.0"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40.3
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/gtk-doc-am-1.9
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-locations-compression
+ --disable-all-translations-in-one-xml
+ --disable-static
+ $(use_enable python)"
+ use python && python_set_active_version 2
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix building -python, Gnome bug #596660.
+ epatch "${FILESDIR}/${PN}-2.30.0-fix-automagic-python-support.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+ python_clean_installation_image
+}