summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-08-07 12:21:57 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-08-07 12:21:57 +0000
commitad5b091115abfa435427265b4a0395441d42fc09 (patch)
tree1b05ed4b6b82c14df8c0350fe23c01eb4f4d19ca /dev-libs
parentDon't assign default to S; Remove default src_compile (diff)
downloadgentoo-2-ad5b091115abfa435427265b4a0395441d42fc09.tar.gz
gentoo-2-ad5b091115abfa435427265b4a0395441d42fc09.tar.bz2
gentoo-2-ad5b091115abfa435427265b4a0395441d42fc09.zip
Fixed compile issue on sh. Bug 98418.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/ChangeLog6
-rwxr-xr-xdev-libs/openssl/files/gentoo.config-0.9.7g6
-rw-r--r--dev-libs/openssl/files/openssl-0.9.7g-superh.patch22
3 files changed, 25 insertions, 9 deletions
diff --git a/dev-libs/openssl/ChangeLog b/dev-libs/openssl/ChangeLog
index ff1a3c81028b..79c66d58be19 100644
--- a/dev-libs/openssl/ChangeLog
+++ b/dev-libs/openssl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/openssl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.129 2005/07/08 08:12:32 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.130 2005/08/07 12:21:57 matsuu Exp $
+
+ 07 Aug 2005; MATSUU Takuto <matsuu@gentoo.org> files/gentoo.config-0.9.7g,
+ files/openssl-0.9.7g-superh.patch:
+ Fixed compile issue on sh. Bug 98418.
08 Jul 2005; Hardave Riar <hardave@gentoo.org> openssl-0.9.7g.ebuild:
Marked ~mips, bug #92076.
diff --git a/dev-libs/openssl/files/gentoo.config-0.9.7g b/dev-libs/openssl/files/gentoo.config-0.9.7g
index c5e58c6a0ec0..173abe03e189 100755
--- a/dev-libs/openssl/files/gentoo.config-0.9.7g
+++ b/dev-libs/openssl/files/gentoo.config-0.9.7g
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/files/gentoo.config-0.9.7g,v 1.8 2005/08/02 22:11:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/files/gentoo.config-0.9.7g,v 1.9 2005/08/07 12:21:57 matsuu Exp $
#
# Openssl doesn't play along nicely with cross-compiling
# like autotools based projects, so let's teach it new tricks.
@@ -89,8 +89,8 @@ linux)
powerpc64*) machine=ppc64;;
powerpc*) machine=ppc;;
sh64*) machine=elf;;
- sh*b*) machine="elf -DB_ENDIAN";;
- sh*) machine="elf -DL_ENDIAN";;
+ sh*b*) machine="elf-sh -DB_ENDIAN";;
+ sh*) machine="elf-sh -DL_ENDIAN";;
sparc*v7*) machine=sparcv7;;
sparc64*) machine=sparcv9;;
sparc*) machine=sparcv8;;
diff --git a/dev-libs/openssl/files/openssl-0.9.7g-superh.patch b/dev-libs/openssl/files/openssl-0.9.7g-superh.patch
index db27373fd252..cc599fe0328b 100644
--- a/dev-libs/openssl/files/openssl-0.9.7g-superh.patch
+++ b/dev-libs/openssl/files/openssl-0.9.7g-superh.patch
@@ -1,11 +1,23 @@
---- config
-+++ config
-@@ -587,6 +587,8 @@ case "$GUESSOS" in
+diff -Naur openssl-0.9.7g.orig/Configure openssl-0.9.7g/Configure
+--- openssl-0.9.7g.orig/Configure 2005-04-08 01:06:01.000000000 +0900
++++ openssl-0.9.7g/Configure 2005-08-06 20:21:25.000000000 +0900
+@@ -438,6 +438,7 @@
+ # ARM comes in both little- and big-endian flavors. The following line is
+ # endian neutral, but ./config is free to throw in -D[BL]_ENDIAN...
+ "linux-elf-arm","gcc:-DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++"linux-elf-sh","gcc:-DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+
+ # SCO/Caldera targets.
+ #
+diff -Naur openssl-0.9.7g.orig/config openssl-0.9.7g/config
+--- openssl-0.9.7g.orig/config 2005-04-08 05:26:10.000000000 +0900
++++ openssl-0.9.7g/config 2005-08-06 20:23:09.000000000 +0900
+@@ -604,6 +604,8 @@
arm*b-*-linux2) OUT="linux-elf-arm"; options="$options -DB_ENDIAN" ;;
arm*l-*-linux2) OUT="linux-elf-arm"; options="$options -DL_ENDIAN" ;;
arm*-*-linux2) OUT="linux-elf-arm" ;;
-+ sh*b-*-linux2) OUT="linux-generic32"; options="$options -DB_ENDIAN" ;;
-+ sh*-*-linux2) OUT="linux-generic32"; options="$options -DL_ENDIAN" ;;
++ sh*b-*-linux2) OUT="linux-elf-sh"; options="$options -DB_ENDIAN" ;;
++ sh*-*-linux2) OUT="linux-elf-sh"; options="$options -DL_ENDIAN" ;;
s390-*-linux2) OUT="linux-s390" ;;
s390x-*-linux?) OUT="linux-s390x" ;;
x86_64-*-linux?) OUT="linux-x86_64" ;;