summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2010-08-01 14:48:43 +0000
committerDominik Kapusta <ayoy@gentoo.org>2010-08-01 14:48:43 +0000
commitb813a5fb2a8f6b2878acf2a1131d72286646ca63 (patch)
tree9dd0849bdd117627188af404ca75fa9b13af48f1 /dev-libs
parentStable on amd64 wrt bug #328883 (diff)
downloadgentoo-2-b813a5fb2a8f6b2878acf2a1131d72286646ca63.tar.gz
gentoo-2-b813a5fb2a8f6b2878acf2a1131d72286646ca63.tar.bz2
gentoo-2-b813a5fb2a8f6b2878acf2a1131d72286646ca63.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/qoauth/ChangeLog9
-rw-r--r--dev-libs/qoauth/qoauth-1.0.1.ebuild58
2 files changed, 65 insertions, 2 deletions
diff --git a/dev-libs/qoauth/ChangeLog b/dev-libs/qoauth/ChangeLog
index 490379d1da27..ffa584827067 100644
--- a/dev-libs/qoauth/ChangeLog
+++ b/dev-libs/qoauth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/qoauth
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/qoauth/ChangeLog,v 1.7 2009/12/20 19:34:06 ayoy Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qoauth/ChangeLog,v 1.8 2010/08/01 14:48:43 ayoy Exp $
+
+*qoauth-1.0.1 (01 Aug 2010)
+
+ 01 Aug 2010; Dominik Kapusta <ayoy@gentoo.org> +qoauth-1.0.1.ebuild:
+ Version bump
20 Dec 2009; Dominik Kapusta <ayoy@gentoo.org> qoauth-1.0-r1.ebuild:
Porting to qt4-r2.eclass
diff --git a/dev-libs/qoauth/qoauth-1.0.1.ebuild b/dev-libs/qoauth/qoauth-1.0.1.ebuild
new file mode 100644
index 000000000000..c8ae54b1086d
--- /dev/null
+++ b/dev-libs/qoauth/qoauth-1.0.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qoauth/qoauth-1.0.1.ebuild,v 1.1 2010/08/01 14:48:43 ayoy Exp $
+
+EAPI="2"
+
+inherit qt4-r2
+
+DESCRIPTION="A Qt-based library for OAuth support"
+HOMEPAGE="http://wiki.github.com/ayoy/qoauth"
+SRC_URI="http://files.ayoy.net/qoauth/release/${PV}/src/${P}-src.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc static-libs test"
+
+COMMON_DEPEND="app-crypt/qca:2[debug?]"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${COMMON_DEPEND}
+ app-crypt/qca-ossl:2[debug?]"
+
+S="${WORKDIR}/${P}-src"
+
+src_prepare() {
+ sed -i -e '/^ *docs \\$/d' \
+ -e '/^ *build_all \\$/d' \
+ -e 's/^\#\(!macx\)/\1/' \
+ src/src.pro || die "sed failed"
+
+ sed -i -e "s/\(.*\)lib$/\1$(get_libdir)/" src/pcfile.sh || die "sed failed"
+
+ if ! use test; then
+ sed -i -e 's/^\(SUBDIRS.*\) tests/\1/' ${PN}.pro || die "sed failed"
+ fi
+}
+
+src_compile() {
+ default
+ if use static-libs; then
+ emake -C src static || die "emake failed"
+ fi
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc README CHANGELOG || die "dodoc failed"
+
+ if use static-libs; then
+ dolib.a "${S}/lib/lib${PN}.a" || die "dolib failed"
+ fi
+
+ if use doc; then
+ doxygen "${S}/Doxyfile" || die "Failed to generate documentation"
+ dohtml "${S}"/doc/html/* || die "Failed to install documentation"
+ fi
+}