summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stewart <vericgar@gentoo.org>2006-06-05 04:48:14 +0000
committerMichael Stewart <vericgar@gentoo.org>2006-06-05 04:48:14 +0000
commitb9bc55b3513115503b3d48bb969c33f8c75065df (patch)
tree23eb93e51637a6818a34b5076d0a71ec3bd55b60 /dev-libs
parentRemove entry masking all old-style apache ebuilds as they have now been remov... (diff)
downloadgentoo-2-b9bc55b3513115503b3d48bb969c33f8c75065df.tar.gz
gentoo-2-b9bc55b3513115503b3d48bb969c33f8c75065df.tar.bz2
gentoo-2-b9bc55b3513115503b3d48bb969c33f8c75065df.zip
Add patch to allow correct linking with --as-needed
(Portage version: 2.1_rc4-r1)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/apr/ChangeLog6
-rw-r--r--dev-libs/apr/apr-0.9.12.ebuild14
-rw-r--r--dev-libs/apr/files/apr-0.9.12-linking.patch12
3 files changed, 27 insertions, 5 deletions
diff --git a/dev-libs/apr/ChangeLog b/dev-libs/apr/ChangeLog
index a87a86dcc44c..308d8163d77d 100644
--- a/dev-libs/apr/ChangeLog
+++ b/dev-libs/apr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/apr
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.57 2006/06/04 18:08:08 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.58 2006/06/05 04:48:14 vericgar Exp $
+
+ 05 Jun 2006; Michael Stewart <vericgar@gentoo.org>
+ +files/apr-0.9.12-linking.patch, apr-0.9.12.ebuild:
+ Add patch to allow correct linking with --as-needed
04 Jun 2006; Michael Stewart <vericgar@gentoo.org> apr-1.2.7-r1.ebuild:
Remove hardcoding of .m4 files from configure.in. Fixes bug 135463
diff --git a/dev-libs/apr/apr-0.9.12.ebuild b/dev-libs/apr/apr-0.9.12.ebuild
index 6ed638e3784a..8f8db1f51f90 100644
--- a/dev-libs/apr/apr-0.9.12.ebuild
+++ b/dev-libs/apr/apr-0.9.12.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-0.9.12.ebuild,v 1.3 2006/05/18 18:16:55 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-0.9.12.ebuild,v 1.4 2006/06/05 04:48:14 vericgar Exp $
-inherit flag-o-matic libtool
+inherit eutils flag-o-matic libtool
DESCRIPTION="Apache Portable Runtime Library"
HOMEPAGE="http://apr.apache.org/"
@@ -16,12 +16,18 @@ RESTRICT="test"
DEPEND=""
-src_compile() {
+src_unpack() {
- filter-ldflags -Wl,--as-needed --as-needed
+ unpack ${A} || die
+ cd ${S} || die
+ epatch ${FILESDIR}/apr-0.9.12-linking.patch
elibtoolize || die "elibtoolize failed"
+}
+
+src_compile() {
+
myconf="--datadir=/usr/share/apr-0"
myconf="${myconf} $(use_enable ipv6)"
diff --git a/dev-libs/apr/files/apr-0.9.12-linking.patch b/dev-libs/apr/files/apr-0.9.12-linking.patch
new file mode 100644
index 000000000000..257ddde1c6dc
--- /dev/null
+++ b/dev-libs/apr/files/apr-0.9.12-linking.patch
@@ -0,0 +1,12 @@
+Index: apr-0.9.12/Makefile.in
+===================================================================
+--- apr-0.9.12.orig/Makefile.in
++++ apr-0.9.12/Makefile.in
+@@ -12,6 +12,7 @@ APR_MAJOR_VERSION=@APR_MAJOR_VERSION@
+ INCDIR=./include
+ INCDIR1=../include
+ INCLUDES=-I$(INCDIR) -I$(INCDIR1)
++ALL_LIBS=@EXTRA_LIBS@
+
+ #
+ # Macros for target determination