summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2012-03-25 08:21:29 +0000
committerPeter Volkov <pva@gentoo.org>2012-03-25 08:21:29 +0000
commitc4643797afb53d0cb78d01cfd64dabb2e2ad69e0 (patch)
treea9f80e0a7d832d0d4239eb2933357a5744d933c5 /dev-libs
parentRemove old. (diff)
downloadgentoo-2-c4643797afb53d0cb78d01cfd64dabb2e2ad69e0.tar.gz
gentoo-2-c4643797afb53d0cb78d01cfd64dabb2e2ad69e0.tar.bz2
gentoo-2-c4643797afb53d0cb78d01cfd64dabb2e2ad69e0.zip
Version bump. Drop old. Drop optional libwww support, bug 409549 by Pacho Ramos. Thank slepnoga for this work.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xmlrpc-c/ChangeLog11
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.06.27.ebuild81
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.18.02.ebuild93
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.28.03-r1.ebuild (renamed from dev-libs/xmlrpc-c/xmlrpc-c-1.28.00.ebuild)21
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.29.02.ebuild93
5 files changed, 113 insertions, 186 deletions
diff --git a/dev-libs/xmlrpc-c/ChangeLog b/dev-libs/xmlrpc-c/ChangeLog
index 25db50f14b2d..f5cf04cff082 100644
--- a/dev-libs/xmlrpc-c/ChangeLog
+++ b/dev-libs/xmlrpc-c/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/xmlrpc-c
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/ChangeLog,v 1.112 2012/03/03 14:48:30 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/ChangeLog,v 1.113 2012/03/25 08:21:29 pva Exp $
+
+*xmlrpc-c-1.29.02 (25 Mar 2012)
+*xmlrpc-c-1.28.03-r1 (25 Mar 2012)
+
+ 25 Mar 2012; Peter Volkov <pva@gentoo.org> -xmlrpc-c-1.06.27.ebuild,
+ -xmlrpc-c-1.18.02.ebuild, -xmlrpc-c-1.28.00.ebuild,
+ +xmlrpc-c-1.28.03-r1.ebuild, +xmlrpc-c-1.29.02.ebuild:
+ Version bump. Drop old. Drop optional libwww support, bug 409549 by Pacho
+ Ramos. Thank slepnoga for this work.
03 Mar 2012; Brent Baude <ranger@gentoo.org> xmlrpc-c-1.28.03.ebuild:
Marking xmlrpc-c-1.28.03 ppc64 for bug 393267
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.06.27.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.06.27.ebuild
deleted file mode 100644
index 87490d6eecc1..000000000000
--- a/dev-libs/xmlrpc-c/xmlrpc-c-1.06.27.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/xmlrpc-c-1.06.27.ebuild,v 1.11 2011/07/25 10:21:06 angelos Exp $
-
-EAPI=1
-
-inherit eutils
-
-DESCRIPTION="A lightweigt RPC library based on XML and HTTP"
-SRC_URI="mirror://sourceforge/${PN}/${P/-c}.tgz"
-HOMEPAGE="http://xmlrpc-c.sourceforge.net/"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="+curl threads"
-LICENSE="BSD"
-SLOT="0"
-
-DEPEND="dev-libs/libxml2
- curl? ( net-misc/curl )"
-
-pkg_setup() {
- if ! use curl
- then
- ewarn "Curl support disabled: No client library will be be built"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-curl-easy-setopt.patch
- epatch "${FILESDIR}"/${P}-abyss-header-fixup.patch
-
- #CPP test suite doesn't pass, but if we were to get it to pass,
- #this is needed to get it to build.
- epatch "${FILESDIR}"/${P}-gcc43-test-fix.patch
- epatch "${FILESDIR}"/${PN}-1.06.09-asneeded.patch
- epatch "${FILESDIR}"/${PN}-1.05-pic.patch
- epatch "${FILESDIR}"/${P}-curl-headers.patch
-
- # Respect the user's CFLAGS/CXXFLAGS.
- sed -i -e "/CFLAGS_COMMON/s:-g -O3$:${CFLAGS}:" Makefile.common
- sed -i -e "/CXXFLAGS_COMMON/s:-g$:${CXXFLAGS}:" Makefile.common
-}
-
-src_compile() {
- #Bug 214137: We need to filter this.
- unset SRCDIR
-
- # Respect the user's LDFLAGS.
- export LADD=${LDFLAGS}
- econf --disable-wininet-client --enable-libxml2-backend --disable-libwww-client \
- $(use_enable threads abyss-threads) \
- $(use_enable curl curl-client) || die "econf failed"
- emake -j1 || die "emake failed"
-}
-
-src_test() {
- unset SRCDIR
- unset LDFLAGS LADD
- cd "${S}"/src/test/
- einfo "Building general tests"
- make || die "Make of general tests failed"
- einfo "Running general tests"
- ./test || die "General tests failed"
-
- #C++ tests. They fail.
- #cd "${S}"/src/cpp/test
- #einfo "Building C++ tests"
- #make || die "Make of C++ tests failed"
- #einfo "Running C++ tests"
- #./test || die "C++ tests failed"
-}
-
-src_install() {
- unset SRCDIR
- emake -j1 DESTDIR="${D}" install || die "installation failed"
-
- dodoc README doc/CREDITS doc/DEVELOPING doc/HISTORY doc/SECURITY doc/TESTING \
- doc/TODO || die "installing docs failed"
-}
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.18.02.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.18.02.ebuild
deleted file mode 100644
index 4156ac2bbe85..000000000000
--- a/dev-libs/xmlrpc-c/xmlrpc-c-1.18.02.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/xmlrpc-c-1.18.02.ebuild,v 1.18 2011/07/25 10:21:06 angelos Exp $
-
-EAPI=2
-
-inherit eutils multilib base
-
-DESCRIPTION="A lightweigt RPC library based on XML and HTTP"
-SRC_URI="mirror://gentoo/${PN}/${P}.tar.bz2"
-HOMEPAGE="http://xmlrpc-c.sourceforge.net/"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="+curl +cxx tools +cgi abyss threads"
-LICENSE="BSD"
-SLOT="0"
-
-DEPEND="dev-libs/libxml2
- tools? ( dev-perl/frontier-rpc )
- curl? ( net-misc/curl )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if ! use curl
- then
- ewarn "Curl support disabled: No client library will be be built"
- fi
-}
-
-#Bug 214137: We need to filter this.
-unset SRCDIR
-
-# Bug 255440
-export LC_ALL=C
-export LANG=C
-
-PATCHES=(
- "${FILESDIR}/${P}/dumpvalue.patch"
- "${FILESDIR}/${P}/cpp-depends.patch"
- "${FILESDIR}/${P}/dump-symlinks.patch"
- "${FILESDIR}/${P}/curl-headers.patch"
- )
-
-src_prepare() {
- base_src_prepare
-
- # Respect the user's CFLAGS/CXXFLAGS.
- sed -i \
- -e "/CFLAGS_COMMON/s|-g -O3$|${CFLAGS}|" \
- -e "/CXXFLAGS_COMMON/s|-g$|${CXXFLAGS}|" \
- "${S}"/common.mk || die "404. File not found while sedding"
-}
-
-src_configure() {
- # Respect the user's LDFLAGS.
- export LADD=${LDFLAGS}
- econf --disable-wininet-client \
- --disable-libwww-client \
- --enable-libxml2-backend \
- $(use_enable tools) \
- $(use_enable threads abyss-threads) \
- $(use_enable cgi cgi-server) \
- $(use_enable abyss abyss-server) \
- $(use_enable cxx cplusplus) \
- $(use_enable curl curl-client)
-}
-
-src_compile() {
- emake -r || die "Compiling failed"
-}
-
-src_test() {
- if use abyss && use curl
- then
- unset LDFLAGS LADD SRCDIR
- cd "${S}"/src/test/
- einfo "Building general tests"
- make || die "Make of general tests failed"
- einfo "Running general tests"
- ./test || die "General tests failed"
-
- if use cxx
- then
- cd "${S}"/src/cpp/test
- einfo "Building C++ tests"
- make || die "Make of C++ tests failed"
- einfo "Running C++ tests"
- ./test || die "C++ tests failed"
- fi
- else
- elog "${CATEGORY}/${PN} tests will fail unless USE='abyss curl' is set."
- fi
-}
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.28.00.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.28.03-r1.ebuild
index e1d159408097..bd5aa16422f4 100644
--- a/dev-libs/xmlrpc-c/xmlrpc-c-1.28.00.ebuild
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.28.03-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/xmlrpc-c-1.28.00.ebuild,v 1.2 2011/12/12 15:43:41 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/xmlrpc-c-1.28.03-r1.ebuild,v 1.1 2012/03/25 08:21:29 pva Exp $
EAPI="4"
@@ -11,7 +11,7 @@ inherit eutils multilib
# http://xmlrpc-c.svn.sourceforge.net/viewvc/xmlrpc-c/advanced/version.mk?view=log
# e.g. for 1.27.05 corresponds following revision 2182 and thus following URL:
# http://xmlrpc-c.svn.sourceforge.net/viewvc/xmlrpc-c/advanced.tar.gz?view=tar&pathrev=2182
-# Note: autogenerated tarball checksum will change everytime, thus download it
+# Note: autogenerated tarball checksum changes every download, thus download it
# manually and distribute on mirrors.
# It's possible to build net-libs/libwww without ssl support, but taking into
# account that libwww is not really well maintained and upstream is dead we
@@ -23,8 +23,8 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="abyss +cgi +curl +cxx +libxml2 libwww static-libs threads tools"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="abyss +cgi +curl +cxx +libxml2 static-libs threads tools"
REQUIRED_USE="test? ( static-libs abyss curl cxx )"
@@ -32,15 +32,13 @@ DEPEND="
tools? ( dev-perl/frontier-rpc
sys-libs/readline )
curl? ( net-misc/curl )
- libwww? ( net-libs/libwww[ssl] )
libxml2? ( dev-libs/libxml2 )"
RDEPEND="${DEPEND}"
S="${WORKDIR}/advanced"
pkg_setup() {
- use curl || use libwww || \
- ewarn "Curl support disabled: No client library will be be built"
+ use curl || ewarn "Curl support disabled: No client library will be be built"
}
#Bug 214137: We need to filter this.
@@ -51,7 +49,6 @@ export LC_ALL=C
export LANG=C
src_prepare() {
- epatch "${FILESDIR}/xmlrpc-c-1.28.00-advanced-test.patch"
sed -i \
-e "/CFLAGS_COMMON/s|-g -O3$||" \
-e "/CXXFLAGS_COMMON/s|-g$||" \
@@ -65,10 +62,12 @@ src_prepare() {
}
src_configure() {
+ #Disable libwww support due GBZ #409549 and #320253
+
econf --disable-wininet-client \
$(use_enable libxml2 libxml2-backend) \
- $(use_enable libwww libwww-client) \
- $(use_enable libwww libwww-ssl) \
+ --disable-libwww-client \
+ --disable-libwww-ssl \
$(use_enable tools) \
$(use_enable threads abyss-threads) \
$(use_enable cgi cgi-server) \
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.29.02.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.29.02.ebuild
new file mode 100644
index 000000000000..1b61e6f070ed
--- /dev/null
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.29.02.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/xmlrpc-c-1.29.02.ebuild,v 1.1 2012/03/25 08:21:29 pva Exp $
+
+EAPI="4"
+
+inherit eutils multilib
+
+# Maintainer notes: Take a look at http://xmlrpc-c.sourceforge.net/release.html
+# We use "advanced" branch, so for the current release revision take look here:
+# http://xmlrpc-c.svn.sourceforge.net/viewvc/xmlrpc-c/advanced/version.mk?view=log
+# e.g. for 1.27.05 corresponds following revision 2182 and thus following URL:
+# http://xmlrpc-c.svn.sourceforge.net/viewvc/xmlrpc-c/advanced.tar.gz?view=tar&pathrev=2182
+# Note: autogenerated tarball checksum changes every download, thus download it
+# manually and distribute on mirrors.
+# It's possible to build net-libs/libwww without ssl support, but taking into
+# account that libwww is not really well maintained and upstream is dead we
+# better use it only in case ssl is required.
+
+DESCRIPTION="A lightweigt RPC library based on XML and HTTP"
+HOMEPAGE="http://xmlrpc-c.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="abyss +cgi +curl +cxx +libxml2 static-libs threads tools"
+
+REQUIRED_USE="test? ( static-libs abyss curl cxx )"
+
+DEPEND="
+ tools? ( dev-perl/frontier-rpc
+ sys-libs/readline )
+ curl? ( net-misc/curl )
+ libxml2? ( dev-libs/libxml2 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/advanced"
+
+pkg_setup() {
+ use curl || ewarn "Curl support disabled: No client library will be be built"
+}
+
+#Bug 214137: We need to filter this.
+unset SRCDIR
+
+# Bug 255440
+export LC_ALL=C
+export LANG=C
+
+src_prepare() {
+ sed -i \
+ -e "/CFLAGS_COMMON/s|-g -O3$||" \
+ -e "/CXXFLAGS_COMMON/s|-g$||" \
+ "${S}"/common.mk || die
+
+ export LADD=${LDFLAGS} # Respect the user's LDFLAGS.
+
+ use static-libs || { sed \
+ -e '/\(^TARGET_STATIC_LIBRARIES =\)/{s:\(^TARGET_STATIC_LIBRARIES =\).*:\1:;P;N;d;}' \
+ -i common.mk || die; }
+}
+
+src_configure() {
+ #Disable libwww support due GBZ #409549 and #320253
+
+ econf --disable-wininet-client \
+ $(use_enable libxml2 libxml2-backend) \
+ --disable-libwww-client \
+ --disable-libwww-ssl \
+ $(use_enable tools) \
+ $(use_enable threads abyss-threads) \
+ $(use_enable cgi cgi-server) \
+ $(use_enable abyss abyss-server) \
+ $(use_enable cxx cplusplus) \
+ $(use_enable curl curl-client)
+}
+
+src_compile() {
+ emake -r
+}
+
+src_test() {
+ unset LDFLAGS LADD SRCDIR
+ cd "${S}"/test/
+ einfo "Building general tests"
+ make || die "Make of general tests failed"
+ einfo "Running general tests"
+ ./test || die "General tests failed"
+ cd "${S}"/test/cpp/
+ einfo "Running C++ tests"
+ ./test || die "C++ tests failed"
+}