summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-07-15 10:17:26 +0000
committerPacho Ramos <pacho@gentoo.org>2014-07-15 10:17:26 +0000
commitc6898c37ce5de7f03020711426fb85d05cac956f (patch)
tree2179c4af85ad2b219c1173727e66c237053507f8 /dev-libs
parentremove net-libs/cyassl (diff)
downloadgentoo-2-c6898c37ce5de7f03020711426fb85d05cac956f.tar.gz
gentoo-2-c6898c37ce5de7f03020711426fb85d05cac956f.tar.bz2
gentoo-2-c6898c37ce5de7f03020711426fb85d05cac956f.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/btparser/ChangeLog9
-rw-r--r--dev-libs/btparser/btparser-0.25.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/dev-libs/btparser/ChangeLog b/dev-libs/btparser/ChangeLog
index b31afee7c579..8c923067c805 100644
--- a/dev-libs/btparser/ChangeLog
+++ b/dev-libs/btparser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/btparser
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/btparser/ChangeLog,v 1.16 2013/09/12 03:57:17 tetromino Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/btparser/ChangeLog,v 1.17 2014/07/15 10:17:26 pacho Exp $
+
+*btparser-0.25 (15 Jul 2014)
+
+ 15 Jul 2014; Pacho Ramos <pacho@gentoo.org> +btparser-0.25.ebuild:
+ Version bump
12 Sep 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
-btparser-0.17.ebuild, -btparser-0.19.ebuild:
diff --git a/dev-libs/btparser/btparser-0.25.ebuild b/dev-libs/btparser/btparser-0.25.ebuild
new file mode 100644
index 000000000000..4f02f88b534a
--- /dev/null
+++ b/dev-libs/btparser/btparser-0.25.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/btparser/btparser-0.25.ebuild,v 1.1 2014/07/15 10:17:26 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit autotools gnome2 python-single-r1
+
+DESCRIPTION="Parser and analyzer for backtraces produced by gdb"
+HOMEPAGE="https://fedorahosted.org/btparser/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="static-libs"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.21:2
+"
+DEPEND="${RDEPEND}"
+
+# Incomplete tarball for tests
+RESTRICT="test"
+
+src_prepare() {
+ eautoreconf # to prevent maintainer mode
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Configure checks for python.pc; our python-2.7 installs python-2.7.pc,
+ # while python-2.6 does not install any pkgconfig file.
+ export PYTHON_CFLAGS=$(python-config --includes)
+ export PYTHON_LIBS=$(python-config --libs)
+
+ gnome2_src_configure \
+ $(use_enable static-libs static)
+}