summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-05-21 17:53:19 +0000
committerMike Frysinger <vapier@gentoo.org>2013-05-21 17:53:19 +0000
commitcd9df525f264e452aef3209b01ef4415beb8486f (patch)
tree36443ac5ffd91d33380a9ef0d75b2ea262af4cdd /dev-libs
parentDo not let $ED from the EAPI mess up the search for `ed` #470210 by Roman Ži... (diff)
downloadgentoo-2-cd9df525f264e452aef3209b01ef4415beb8486f.tar.gz
gentoo-2-cd9df525f264e452aef3209b01ef4415beb8486f.tar.bz2
gentoo-2-cd9df525f264e452aef3209b01ef4415beb8486f.zip
Update the target used for s390x systems #470740 by Agostino Sarubbo.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/ChangeLog8
-rwxr-xr-xdev-libs/openssl/files/gentoo.config-1.0.1160
-rw-r--r--dev-libs/openssl/openssl-1.0.1a.ebuild4
-rw-r--r--dev-libs/openssl/openssl-1.0.1b.ebuild4
-rw-r--r--dev-libs/openssl/openssl-1.0.1c.ebuild4
-rw-r--r--dev-libs/openssl/openssl-1.0.1d-r1.ebuild4
-rw-r--r--dev-libs/openssl/openssl-1.0.1d.ebuild4
-rw-r--r--dev-libs/openssl/openssl-1.0.1e-r1.ebuild4
-rw-r--r--dev-libs/openssl/openssl-1.0.1e.ebuild4
9 files changed, 181 insertions, 15 deletions
diff --git a/dev-libs/openssl/ChangeLog b/dev-libs/openssl/ChangeLog
index 14b2aabbe203..1a188e8de681 100644
--- a/dev-libs/openssl/ChangeLog
+++ b/dev-libs/openssl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/openssl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.478 2013/05/11 16:40:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.479 2013/05/21 17:53:18 vapier Exp $
+
+ 21 May 2013; Mike Frysinger <vapier@gentoo.org> +files/gentoo.config-1.0.1,
+ openssl-1.0.1a.ebuild, openssl-1.0.1b.ebuild, openssl-1.0.1c.ebuild,
+ openssl-1.0.1d-r1.ebuild, openssl-1.0.1d.ebuild, openssl-1.0.1e-r1.ebuild,
+ openssl-1.0.1e.ebuild:
+ Update the target used for s390x systems #470740 by Agostino Sarubbo.
11 May 2013; Mike Frysinger <vapier@gentoo.org> openssl-1.0.1c.ebuild:
Mark m68k/s390/sh/sparc stable #454566.
diff --git a/dev-libs/openssl/files/gentoo.config-1.0.1 b/dev-libs/openssl/files/gentoo.config-1.0.1
new file mode 100755
index 000000000000..bbc1aa958f37
--- /dev/null
+++ b/dev-libs/openssl/files/gentoo.config-1.0.1
@@ -0,0 +1,160 @@
+#!/usr/bin/env bash
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/files/gentoo.config-1.0.1,v 1.1 2013/05/21 17:53:19 vapier Exp $
+#
+# Openssl doesn't play along nicely with cross-compiling
+# like autotools based projects, so let's teach it new tricks.
+#
+# Review the bundled 'config' script to see why kind of targets
+# we can pass to the 'Configure' script.
+
+
+# Testing routines
+if [[ $1 == "test" ]] ; then
+ for c in \
+ "arm-gentoo-linux-uclibc |linux-generic32 -DL_ENDIAN" \
+ "armv5b-linux-gnu |linux-armv4 -DB_ENDIAN" \
+ "x86_64-pc-linux-gnu |linux-x86_64" \
+ "alpha-linux-gnu |linux-alpha-gcc" \
+ "alphaev56-unknown-linux-gnu |linux-alpha+bwx-gcc" \
+ "i686-pc-linux-gnu |linux-elf" \
+ "whatever-gentoo-freebsdX.Y |BSD-generic32" \
+ "i686-gentoo-freebsdX.Y |BSD-x86-elf" \
+ "sparc64-alpha-freebsdX.Y |BSD-sparc64" \
+ "ia64-gentoo-freebsd5.99234 |BSD-ia64" \
+ "x86_64-gentoo-freebsdX.Y |BSD-x86_64" \
+ "hppa64-aldsF-linux-gnu5.3 |linux-generic32 -DB_ENDIAN" \
+ "powerpc-gentOO-linux-uclibc |linux-ppc" \
+ "powerpc64-unk-linux-gnu |linux-ppc64" \
+ "x86_64-apple-darwinX |darwin64-x86_64-cc" \
+ "powerpc64-apple-darwinX |darwin64-ppc-cc" \
+ "i686-apple-darwinX |darwin-i386-cc" \
+ "i386-apple-darwinX |darwin-i386-cc" \
+ "powerpc-apple-darwinX |darwin-ppc-cc" \
+ "i586-pc-winnt |winnt-parity" \
+ "s390-ibm-linux-gnu |linux-generic32 -DB_ENDIAN" \
+ "s390x-linux-gnu |linux64-s390x" \
+ ;do
+ CHOST=${c/|*}
+ ret_want=${c/*|}
+ ret_got=$(CHOST=${CHOST} "$0")
+
+ if [[ ${ret_want} == "${ret_got}" ]] ; then
+ echo "PASS: ${CHOST}"
+ else
+ echo "FAIL: ${CHOST}"
+ echo -e "\twanted: ${ret_want}"
+ echo -e "\twe got: ${ret_got}"
+ fi
+ done
+ exit 0
+fi
+[[ -z ${CHOST} && -n $1 ]] && CHOST=$1
+
+
+# Detect the operating system
+case ${CHOST} in
+ *-aix*) system="aix";;
+ *-darwin*) system="darwin";;
+ *-freebsd*) system="BSD";;
+ *-hpux*) system="hpux";;
+ *-linux*) system="linux";;
+ *-solaris*) system="solaris";;
+ *-winnt*) system="winnt";;
+ x86_64-*-mingw*) system="mingw64";;
+ *mingw*) system="mingw";;
+ *) exit 0;;
+esac
+
+
+# Compiler munging
+compiler="gcc"
+if [[ ${CC} == "ccc" ]] ; then
+ compiler=${CC}
+fi
+
+
+# Detect target arch
+machine=""
+chost_machine=${CHOST%%-*}
+case ${system} in
+linux)
+ case ${chost_machine}:${ABI} in
+ alphaev56*|\
+ alphaev[678]*)machine=alpha+bwx-${compiler};;
+ alpha*) machine=alpha-${compiler};;
+ armv[4-9]*b*) machine="armv4 -DB_ENDIAN";;
+ armv[4-9]*) machine="armv4 -DL_ENDIAN";;
+ arm*b*) machine="generic32 -DB_ENDIAN";;
+ arm*) machine="generic32 -DL_ENDIAN";;
+ avr*) machine="generic32 -DL_ENDIAN";;
+ bfin*) machine="generic32 -DL_ENDIAN";;
+ # hppa64*) machine=parisc64;;
+ hppa*) machine="generic32 -DB_ENDIAN";;
+ i[0-9]86*|\
+ x86_64*:x86) machine=elf;;
+ ia64*) machine=ia64;;
+ m68*) machine="generic32 -DB_ENDIAN";;
+ mips*el*) machine="generic32 -DL_ENDIAN";;
+ mips*) machine="generic32 -DB_ENDIAN";;
+ powerpc64*) machine=ppc64;;
+ powerpc*) machine=ppc;;
+ # sh64*) machine=elf;;
+ sh*b*) machine="generic32 -DB_ENDIAN";;
+ sh*) machine="generic32 -DL_ENDIAN";;
+ sparc*v7*) machine="generic32 -DB_ENDIAN";;
+ sparc64*) machine=sparcv9;;
+ sparc*) machine=sparcv8;;
+ s390x*) machine=s390x system=linux64;;
+ s390*) machine="generic32 -DB_ENDIAN";;
+ x86_64*:x32) machine=x32;;
+ x86_64*) machine=x86_64;;
+ esac
+ ;;
+BSD)
+ case ${chost_machine} in
+ alpha*) machine=generic64;;
+ i[6-9]86*) machine=x86-elf;;
+ ia64*) machine=ia64;;
+ sparc64*) machine=sparc64;;
+ x86_64*) machine=x86_64;;
+ *) machine=generic32;;
+ esac
+ ;;
+aix)
+ machine=${compiler}
+ ;;
+darwin)
+ case ${chost_machine} in
+ powerpc64) machine=ppc-cc; system=${system}64;;
+ powerpc) machine=ppc-cc;;
+ i?86*) machine=i386-cc;;
+ x86_64) machine=x86_64-cc; system=${system}64;;
+ esac
+ ;;
+hpux)
+ case ${chost_machine} in
+ ia64) machine=ia64-${compiler} ;;
+ esac
+ ;;
+solaris)
+ case ${chost_machine} in
+ i386) machine=x86-${compiler} ;;
+ x86_64*) machine=x86_64-${compiler}; system=${system}64;;
+ sparcv9*) machine=sparcv9-${compiler}; system=${system}64;;
+ sparc*) machine=sparcv8-${compiler};;
+ esac
+ ;;
+winnt)
+ machine=parity
+ ;;
+mingw*)
+ # special case ... no xxx-yyy style name
+ echo ${system}
+ ;;
+esac
+
+
+# If we have something, show it
+[[ -n ${machine} ]] && echo ${system}-${machine}
diff --git a/dev-libs/openssl/openssl-1.0.1a.ebuild b/dev-libs/openssl/openssl-1.0.1a.ebuild
index d95f4a724c58..4abaf74bdc2a 100644
--- a/dev-libs/openssl/openssl-1.0.1a.ebuild
+++ b/dev-libs/openssl/openssl-1.0.1a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1a.ebuild,v 1.7 2013/02/08 06:17:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1a.ebuild,v 1.8 2013/05/21 17:53:18 vapier Exp $
EAPI="4"
@@ -77,7 +77,7 @@ src_prepare() {
sed -i '/^SET_X/s:=.*:=set -x:' Makefile.shared
# allow openssl to be cross-compiled
- cp "${FILESDIR}"/gentoo.config-1.0.0 gentoo.config || die
+ cp "${FILESDIR}"/gentoo.config-1.0.1 gentoo.config || die
chmod a+rx gentoo.config
append-flags -fno-strict-aliasing
diff --git a/dev-libs/openssl/openssl-1.0.1b.ebuild b/dev-libs/openssl/openssl-1.0.1b.ebuild
index 4c9e83cd105a..d9f6a13034bd 100644
--- a/dev-libs/openssl/openssl-1.0.1b.ebuild
+++ b/dev-libs/openssl/openssl-1.0.1b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1b.ebuild,v 1.4 2013/02/08 06:17:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1b.ebuild,v 1.5 2013/05/21 17:53:18 vapier Exp $
EAPI="4"
@@ -76,7 +76,7 @@ src_prepare() {
sed -i '/^SET_X/s:=.*:=set -x:' Makefile.shared
# allow openssl to be cross-compiled
- cp "${FILESDIR}"/gentoo.config-1.0.0 gentoo.config || die
+ cp "${FILESDIR}"/gentoo.config-1.0.1 gentoo.config || die
chmod a+rx gentoo.config
append-flags -fno-strict-aliasing
diff --git a/dev-libs/openssl/openssl-1.0.1c.ebuild b/dev-libs/openssl/openssl-1.0.1c.ebuild
index aac6f3a1cfba..6523ef3ec249 100644
--- a/dev-libs/openssl/openssl-1.0.1c.ebuild
+++ b/dev-libs/openssl/openssl-1.0.1c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1c.ebuild,v 1.13 2013/05/11 16:40:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1c.ebuild,v 1.14 2013/05/21 17:53:18 vapier Exp $
EAPI="4"
@@ -76,7 +76,7 @@ src_prepare() {
sed -i '/^SET_X/s:=.*:=set -x:' Makefile.shared
# allow openssl to be cross-compiled
- cp "${FILESDIR}"/gentoo.config-1.0.0 gentoo.config || die
+ cp "${FILESDIR}"/gentoo.config-1.0.1 gentoo.config || die
chmod a+rx gentoo.config
append-flags -fno-strict-aliasing
diff --git a/dev-libs/openssl/openssl-1.0.1d-r1.ebuild b/dev-libs/openssl/openssl-1.0.1d-r1.ebuild
index cd51658e391a..c7e654fe1cce 100644
--- a/dev-libs/openssl/openssl-1.0.1d-r1.ebuild
+++ b/dev-libs/openssl/openssl-1.0.1d-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1d-r1.ebuild,v 1.2 2013/02/19 04:40:52 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1d-r1.ebuild,v 1.3 2013/05/21 17:53:18 vapier Exp $
EAPI="4"
@@ -77,7 +77,7 @@ src_prepare() {
sed -i '/^SET_X/s:=.*:=set -x:' Makefile.shared
# allow openssl to be cross-compiled
- cp "${FILESDIR}"/gentoo.config-1.0.0 gentoo.config || die
+ cp "${FILESDIR}"/gentoo.config-1.0.1 gentoo.config || die
chmod a+rx gentoo.config
append-flags -fno-strict-aliasing
diff --git a/dev-libs/openssl/openssl-1.0.1d.ebuild b/dev-libs/openssl/openssl-1.0.1d.ebuild
index 41cd4f7577f2..18570c39be41 100644
--- a/dev-libs/openssl/openssl-1.0.1d.ebuild
+++ b/dev-libs/openssl/openssl-1.0.1d.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1d.ebuild,v 1.2 2013/02/08 06:17:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1d.ebuild,v 1.3 2013/05/21 17:53:18 vapier Exp $
EAPI="4"
@@ -75,7 +75,7 @@ src_prepare() {
sed -i '/^SET_X/s:=.*:=set -x:' Makefile.shared
# allow openssl to be cross-compiled
- cp "${FILESDIR}"/gentoo.config-1.0.0 gentoo.config || die
+ cp "${FILESDIR}"/gentoo.config-1.0.1 gentoo.config || die
chmod a+rx gentoo.config
append-flags -fno-strict-aliasing
diff --git a/dev-libs/openssl/openssl-1.0.1e-r1.ebuild b/dev-libs/openssl/openssl-1.0.1e-r1.ebuild
index 1895ae8398d3..254d085fa34c 100644
--- a/dev-libs/openssl/openssl-1.0.1e-r1.ebuild
+++ b/dev-libs/openssl/openssl-1.0.1e-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1e-r1.ebuild,v 1.1 2013/04/27 11:06:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1e-r1.ebuild,v 1.2 2013/05/21 17:53:18 vapier Exp $
EAPI="4"
@@ -77,7 +77,7 @@ src_prepare() {
sed -i '/^SET_X/s:=.*:=set -x:' Makefile.shared
# allow openssl to be cross-compiled
- cp "${FILESDIR}"/gentoo.config-1.0.0 gentoo.config || die
+ cp "${FILESDIR}"/gentoo.config-1.0.1 gentoo.config || die
chmod a+rx gentoo.config
append-flags -fno-strict-aliasing
diff --git a/dev-libs/openssl/openssl-1.0.1e.ebuild b/dev-libs/openssl/openssl-1.0.1e.ebuild
index b1a266df6121..af6d523a626d 100644
--- a/dev-libs/openssl/openssl-1.0.1e.ebuild
+++ b/dev-libs/openssl/openssl-1.0.1e.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1e.ebuild,v 1.1 2013/02/20 19:14:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1e.ebuild,v 1.2 2013/05/21 17:53:18 vapier Exp $
EAPI="4"
@@ -76,7 +76,7 @@ src_prepare() {
sed -i '/^SET_X/s:=.*:=set -x:' Makefile.shared
# allow openssl to be cross-compiled
- cp "${FILESDIR}"/gentoo.config-1.0.0 gentoo.config || die
+ cp "${FILESDIR}"/gentoo.config-1.0.1 gentoo.config || die
chmod a+rx gentoo.config
append-flags -fno-strict-aliasing