summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-05-27 11:50:10 +0000
committerJeroen Roovers <jer@gentoo.org>2013-05-27 11:50:10 +0000
commitda719702588f1d951e94fbb2f2eb4736f8f3b074 (patch)
tree7ec8db37569a9eb2630040ab11489bc4c435b321 /dev-libs
parentVersion bump (bug #471354). (diff)
downloadgentoo-2-da719702588f1d951e94fbb2f2eb4736f8f3b074.tar.gz
gentoo-2-da719702588f1d951e94fbb2f2eb4736f8f3b074.tar.bz2
gentoo-2-da719702588f1d951e94fbb2f2eb4736f8f3b074.zip
Fix building with automake-1.13 (bug #471372 by Jason Mours). Migrate to python-r1.eclass.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libdnet/ChangeLog10
-rw-r--r--dev-libs/libdnet/libdnet-1.11-r2.ebuild7
-rw-r--r--dev-libs/libdnet/libdnet-1.12.ebuild14
3 files changed, 20 insertions, 11 deletions
diff --git a/dev-libs/libdnet/ChangeLog b/dev-libs/libdnet/ChangeLog
index d1d6e97b79ae..2384d1baa9d3 100644
--- a/dev-libs/libdnet/ChangeLog
+++ b/dev-libs/libdnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libdnet
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/ChangeLog,v 1.59 2012/10/10 18:17:08 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/ChangeLog,v 1.60 2013/05/27 11:50:10 jer Exp $
+
+ 27 May 2013; Jeroen Roovers <jer@gentoo.org> libdnet-1.11-r2.ebuild,
+ libdnet-1.12.ebuild:
+ Fix building with automake-1.13 (bug #471372 by Jason Mours). Migrate to
+ python-r1.eclass.
10 Oct 2012; Jeroen Roovers <jer@gentoo.org> -libdnet-1.11-r1.ebuild,
libdnet-1.12.ebuild:
@@ -207,4 +212,3 @@
comments should well explained and written in clean English. The details about
writing correct changelogs are explained in the skel.ChangeLog file which you
can find in the root directory of the portage repository.
-
diff --git a/dev-libs/libdnet/libdnet-1.11-r2.ebuild b/dev-libs/libdnet/libdnet-1.11-r2.ebuild
index ffee0b37055c..3ff9a8e4fded 100644
--- a/dev-libs/libdnet/libdnet-1.11-r2.ebuild
+++ b/dev-libs/libdnet/libdnet-1.11-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/libdnet-1.11-r2.ebuild,v 1.10 2012/07/08 17:29:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/libdnet-1.11-r2.ebuild,v 1.11 2013/05/27 11:50:10 jer Exp $
EAPI=4
PYTHON_DEPEND="python? 2"
@@ -26,7 +26,8 @@ pkg_setup() {
}
src_prepare() {
- sed -i 's/suite_free(s);//' test/check/*.c || die "sed failed"
+ sed -i -e 's/suite_free(s);//' test/check/*.c || die
+ sed -i -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' configure.in || die
epatch "${FILESDIR}"/${PN}-1.10-gcc4.diff
AT_M4DIR="config"
eautoreconf
diff --git a/dev-libs/libdnet/libdnet-1.12.ebuild b/dev-libs/libdnet/libdnet-1.12.ebuild
index d24dac81f3cc..fc4ddf4d1730 100644
--- a/dev-libs/libdnet/libdnet-1.12.ebuild
+++ b/dev-libs/libdnet/libdnet-1.12.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/libdnet-1.12.ebuild,v 1.3 2012/10/10 18:17:08 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/libdnet-1.12.ebuild,v 1.4 2013/05/27 11:50:10 jer Exp $
-EAPI=4
+EAPI=5
AT_M4DIR="config"
AUTOTOOLS_AUTORECONF=1
AUTOTOOLS_IN_SOURCE_BUILD=1
PYTHON_DEPEND="python? 2"
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
-inherit autotools-utils eutils python
+inherit autotools-utils eutils python-r1
DESCRIPTION="simplified, portable interface to several low-level networking routines"
HOMEPAGE="http://code.google.com/p/libdnet/"
@@ -37,7 +38,10 @@ src_prepare() {
# Useless copy
rm -r trunk/ || die
- sed -i -e 's/libcheck.a/libcheck.so/g' configure.in || die "sed failed"
+ sed -i \
+ -e 's/libcheck.a/libcheck.so/g' \
+ -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
+ configure.in || die
use ipv6 && epatch "${WORKDIR}/${P}.ipv6-1.patch"
autotools-utils_src_prepare
}