summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-04-29 01:23:26 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-04-29 01:23:26 +0000
commitddc2231c89b112e2d1f4588484979412f2b1a3a2 (patch)
treebbc52e5e74b2c4e6b19863c884ae19632da22386 /dev-libs
parentAdd test dependencies. (diff)
downloadgentoo-2-ddc2231c89b112e2d1f4588484979412f2b1a3a2.tar.gz
gentoo-2-ddc2231c89b112e2d1f4588484979412f2b1a3a2.tar.bz2
gentoo-2-ddc2231c89b112e2d1f4588484979412f2b1a3a2.zip
Require automake-1.12, since building with 1.13 fails (bug #467086, thanks to Paramonov Valeriy et al.)
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/glib/ChangeLog7
-rw-r--r--dev-libs/glib/glib-1.2.10-r5.ebuild20
-rw-r--r--dev-libs/glib/glib-2.32.4-r1.ebuild6
-rw-r--r--dev-libs/glib/glib-2.34.3.ebuild6
4 files changed, 21 insertions, 18 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index 86a2f85219a7..4bd2c8da0862 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/glib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.556 2013/04/23 19:02:39 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.557 2013/04/29 01:23:26 tetromino Exp $
+
+ 29 Apr 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ glib-1.2.10-r5.ebuild, glib-2.32.4-r1.ebuild, glib-2.34.3.ebuild:
+ Require automake-1.12, since building with 1.13 fails (bug #467086, thanks to
+ Paramonov Valeriy et al.)
*glib-2.36.1 (23 Apr 2013)
diff --git a/dev-libs/glib/glib-1.2.10-r5.ebuild b/dev-libs/glib/glib-1.2.10-r5.ebuild
index 57b2e37b9a4d..e08e0322535e 100644
--- a/dev-libs/glib/glib-1.2.10-r5.ebuild
+++ b/dev-libs/glib/glib-1.2.10-r5.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10-r5.ebuild,v 1.55 2012/09/25 11:40:57 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10-r5.ebuild,v 1.56 2013/04/29 01:23:26 tetromino Exp $
+
+EAPI="4"
+WANT_AUTOMAKE="1.12"
inherit autotools libtool flag-o-matic eutils portability
@@ -18,10 +21,7 @@ IUSE="hardened"
DEPEND=""
RDEPEND=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${P}-automake.patch
epatch "${FILESDIR}"/${P}-m4.patch
epatch "${FILESDIR}"/${P}-configure-LANG.patch #133679
@@ -40,7 +40,7 @@ src_unpack() {
elibtoolize
}
-src_compile() {
+src_configure() {
# Bug 48839: pam fails to build on ia64
# The problem is that it attempts to link a shared object against
# libglib.a; this library needs to be built with -fPIC. Since
@@ -50,13 +50,11 @@ src_compile() {
econf \
--with-threads=posix \
- --enable-debug=yes \
- || die
- emake || die
+ --enable-debug=yes
}
src_install() {
- make install DESTDIR="${D}" || die
+ default
dodoc AUTHORS ChangeLog README* INSTALL NEWS
dohtml -r docs
diff --git a/dev-libs/glib/glib-2.32.4-r1.ebuild b/dev-libs/glib/glib-2.32.4-r1.ebuild
index bfda3727c9a6..294bd321dbd1 100644
--- a/dev-libs/glib/glib-2.32.4-r1.ebuild
+++ b/dev-libs/glib/glib-2.32.4-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.32.4-r1.ebuild,v 1.11 2013/02/19 00:08:33 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.32.4-r1.ebuild,v 1.12 2013/04/29 01:23:26 tetromino Exp $
EAPI="4"
-PYTHON_DEPEND="utils? 2"
-# Avoid runtime dependency on python when USE=test
+PYTHON_DEPEND="utils? 2" # Avoid runtime dependency on python when USE=test
+WANT_AUTOMAKE="1.12"
inherit autotools gnome.org libtool eutils flag-o-matic gnome2-utils multilib pax-utils python toolchain-funcs virtualx linux-info
diff --git a/dev-libs/glib/glib-2.34.3.ebuild b/dev-libs/glib/glib-2.34.3.ebuild
index 549f66818179..12922ce668a6 100644
--- a/dev-libs/glib/glib-2.34.3.ebuild
+++ b/dev-libs/glib/glib-2.34.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.34.3.ebuild,v 1.3 2013/02/19 00:08:33 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.34.3.ebuild,v 1.4 2013/04/29 01:23:26 tetromino Exp $
EAPI="5"
-PYTHON_DEPEND="utils? 2"
-# Avoid runtime dependency on python when USE=test
+PYTHON_DEPEND="utils? 2" # Avoid runtime dependency on python when USE=test
+WANT_AUTOMAKE="1.12"
inherit autotools gnome.org libtool eutils flag-o-matic gnome2-utils multilib pax-utils python toolchain-funcs virtualx linux-info