summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-11-11 19:17:50 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-11-11 19:17:50 +0000
commitddcceed354569852a017376e3e98b6913734f58b (patch)
tree91cd2136575b0c03c56a4eff9326d496506954ed /dev-libs
parentStable on amd64 wrt bug #390141 (diff)
downloadgentoo-2-ddcceed354569852a017376e3e98b6913734f58b.tar.gz
gentoo-2-ddcceed354569852a017376e3e98b6913734f58b.tar.bz2
gentoo-2-ddcceed354569852a017376e3e98b6913734f58b.zip
Use EAPI=4. Add static-libs USE flag. Patch by Arfrever.
(Portage version: 2.2.0_alpha73/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/apr/ChangeLog5
-rw-r--r--dev-libs/apr/apr-1.4.5.ebuild26
2 files changed, 19 insertions, 12 deletions
diff --git a/dev-libs/apr/ChangeLog b/dev-libs/apr/ChangeLog
index 574bb7c597af..9555f7b2b290 100644
--- a/dev-libs/apr/ChangeLog
+++ b/dev-libs/apr/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/apr
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.180 2011/10/29 18:36:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.181 2011/11/11 19:17:50 hwoarang Exp $
+
+ 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> apr-1.4.5.ebuild:
+ Use EAPI=4. Add static-libs USE flag. Patch by Arfrever.
29 Oct 2011; Raúl Porcel <armin76@gentoo.org> apr-1.4.5.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #385859
diff --git a/dev-libs/apr/apr-1.4.5.ebuild b/dev-libs/apr/apr-1.4.5.ebuild
index fafc5c9d4ae0..8a243ad11bd9 100644
--- a/dev-libs/apr/apr-1.4.5.ebuild
+++ b/dev-libs/apr/apr-1.4.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.4.5.ebuild,v 1.7 2011/10/29 18:36:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.4.5.ebuild,v 1.8 2011/11/11 19:17:50 hwoarang Exp $
-EAPI="3"
+EAPI="4"
inherit autotools eutils libtool multilib
@@ -13,13 +13,15 @@ SRC_URI="mirror://apache/apr/${P}.tar.bz2"
LICENSE="Apache-2.0"
SLOT="1"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="doc elibc_FreeBSD older-kernels-compatibility +urandom +uuid"
+IUSE="doc elibc_FreeBSD older-kernels-compatibility static-libs +urandom +uuid"
RESTRICT="test"
RDEPEND="uuid? ( !elibc_FreeBSD? ( >=sys-apps/util-linux-2.16 ) )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
+DOCS=(CHANGES NOTICE README)
+
src_prepare() {
# Ensure that system libtool is used.
sed -e 's:${installbuilddir}/libtool:/usr/bin/libtool:' -i apr-config.in || die "sed failed"
@@ -63,25 +65,27 @@ src_configure() {
}
src_compile() {
- emake || die "emake failed"
+ emake
if use doc; then
- emake dox || die "emake dox failed"
+ emake dox
fi
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- find "${ED}" -name "*.la" -print0 | xargs -0 rm -f
+ default
- dodoc CHANGES NOTICE README
+ find "${ED}" -name "*.la" -exec rm -f {} +
if use doc; then
- dohtml -r docs/dox/html/* || die "dohtml failed"
+ dohtml -r docs/dox/html/*
+ fi
+
+ if ! use static-libs; then
+ find "${ED}" -name "*.a" -exec rm -f {} +
fi
# This file is only used on AIX systems, which Gentoo is not,
# and causes collisions between the SLOTs, so remove it.
- rm -f "${D}usr/$(get_libdir)/apr.exp"
+ rm -f "${ED}usr/$(get_libdir)/apr.exp"
}