summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-23 21:20:47 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-23 21:20:47 +0000
commite5d21987a4ecf7340e2bd0a3ecead2e2f269dc30 (patch)
tree8ed9b2fb865b02870a7042cc6fc5504038e0cd61 /dev-libs
parentppc/ppc64 stable wrt #355441 (diff)
downloadgentoo-2-e5d21987a4ecf7340e2bd0a3ecead2e2f269dc30.tar.gz
gentoo-2-e5d21987a4ecf7340e2bd0a3ecead2e2f269dc30.tar.bz2
gentoo-2-e5d21987a4ecf7340e2bd0a3ecead2e2f269dc30.zip
Version bump.
(Portage version: 2.2.0_alpha28_p4/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/icu/ChangeLog8
-rw-r--r--dev-libs/icu/icu-4.6.1.ebuild84
2 files changed, 91 insertions, 1 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index 1d4d75bd52b2..a729ebdb486c 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.141 2011/02/27 13:59:57 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.142 2011/03/23 21:20:47 arfrever Exp $
+
+*icu-4.6.1 (23 Mar 2011)
+
+ 23 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +icu-4.6.1.ebuild:
+ Version bump.
27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> icu-4.6.ebuild:
Stable on alpha, bug #350861
diff --git a/dev-libs/icu/icu-4.6.1.ebuild b/dev-libs/icu/icu-4.6.1.ebuild
new file mode 100644
index 000000000000..b362854a8057
--- /dev/null
+++ b/dev-libs/icu/icu-4.6.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.6.1.ebuild,v 1.1 2011/03/23 21:20:47 arfrever Exp $
+
+EAPI="3"
+
+inherit versionator
+
+MAJOR_MINOR_VERSION="$(get_version_component_range 1-2)"
+MICRO_VERSION="$(get_version_component_range 3)"
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/"
+
+BASE_URI="http://download.icu-project.org/files/icu4c/${PV}"
+DOCS_BASE_URI="http://download.icu-project.org/files/icu4c/${MAJOR_MINOR_VERSION}"
+SRC_ARCHIVE="icu4c-${PV//./_}-src.tgz"
+DOCS_ARCHIVE="icu4c-${MAJOR_MINOR_VERSION//./_}-docs.zip"
+
+SRC_URI="${BASE_URI}/${SRC_ARCHIVE}
+ doc? ( ${DOCS_BASE_URI}/${DOCS_ARCHIVE} )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples static-libs"
+
+DEPEND="doc? ( app-arch/unzip )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}/source"
+
+QA_DT_NEEDED="/usr/lib.*/libicudata.so.${MAJOR_MINOR_VERSION/./}.${MICRO_VERSION:-0}"
+
+src_unpack() {
+ unpack "${SRC_ARCHIVE}"
+ if use doc; then
+ mkdir docs
+ pushd docs > /dev/null
+ unpack "${DOCS_ARCHIVE}"
+ popd > /dev/null
+ fi
+}
+
+src_prepare() {
+ # Do not hardcode flags into icu-config.
+ # https://ssl.icu-project.org/trac/ticket/6102
+ local variable
+ for variable in ARFLAGS CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
+ sed -i -e "/^${variable} =.*/s:@${variable}@::" config/Makefile.inc.in || die "sed failed"
+ done
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable examples samples) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ # INTLTEST_OPTS: intltest options
+ # -e: Exhaustive testing
+ # -l: Reporting of memory leaks
+ # -v: Increased verbosity
+ # IOTEST_OPTS: iotest options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ # CINTLTST_OPTS: cintltst options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ emake -j1 check || die "emake check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dohtml ../readme.html
+ dodoc ../unicode-license.txt
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html/api
+ doins -r "${WORKDIR}/docs/"* || die "doins failed"
+ fi
+}