summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-07-04 13:32:16 +0000
committerJeroen Roovers <jer@gentoo.org>2013-07-04 13:32:16 +0000
commite618079bd19c4d4a9025aaf7ab93c263c9486a23 (patch)
tree45a4376a6969feb8d2b3b9f83b8a9c6be560841a /dev-libs
parentStable for ppc64, wrt bug #475650 (diff)
downloadgentoo-2-e618079bd19c4d4a9025aaf7ab93c263c9486a23.tar.gz
gentoo-2-e618079bd19c4d4a9025aaf7ab93c263c9486a23.tar.bz2
gentoo-2-e618079bd19c4d4a9025aaf7ab93c263c9486a23.zip
Old.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libnl/ChangeLog7
-rw-r--r--dev-libs/libnl/files/libnl-1.1-glibc-2.8-ULONG_MAX.patch13
-rw-r--r--dev-libs/libnl/files/libnl-1.1-inline.patch22
-rw-r--r--dev-libs/libnl/files/libnl-1.1-minor-leaks.patch40
-rw-r--r--dev-libs/libnl/libnl-1.1-r3.ebuild45
-rw-r--r--dev-libs/libnl/libnl-3.2.14.ebuild47
6 files changed, 6 insertions, 168 deletions
diff --git a/dev-libs/libnl/ChangeLog b/dev-libs/libnl/ChangeLog
index 6aad81a7629d..3b19118a7880 100644
--- a/dev-libs/libnl/ChangeLog
+++ b/dev-libs/libnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libnl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/ChangeLog,v 1.168 2013/06/30 18:04:38 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/ChangeLog,v 1.169 2013/07/04 13:32:14 jer Exp $
+
+ 04 Jul 2013; Jeroen Roovers <jer@gentoo.org> -libnl-1.1-r3.ebuild,
+ -libnl-3.2.14.ebuild, -files/libnl-1.1-glibc-2.8-ULONG_MAX.patch,
+ -files/libnl-1.1-inline.patch, -files/libnl-1.1-minor-leaks.patch:
+ Old.
30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> libnl-3.2.21.ebuild:
Stable for s390, wrt bug #471046
diff --git a/dev-libs/libnl/files/libnl-1.1-glibc-2.8-ULONG_MAX.patch b/dev-libs/libnl/files/libnl-1.1-glibc-2.8-ULONG_MAX.patch
deleted file mode 100644
index 67c67128c306..000000000000
--- a/dev-libs/libnl/files/libnl-1.1-glibc-2.8-ULONG_MAX.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=225393
-
---- a/include/netlink-local.h
-+++ b/include/netlink-local.h
-@@ -26,6 +26,7 @@
- #include <sys/socket.h>
- #include <inttypes.h>
- #include <assert.h>
-+#include <limits.h>
-
- #include <arpa/inet.h>
- #include <netdb.h>
-
diff --git a/dev-libs/libnl/files/libnl-1.1-inline.patch b/dev-libs/libnl/files/libnl-1.1-inline.patch
deleted file mode 100644
index 2d48aefe5510..000000000000
--- a/dev-libs/libnl/files/libnl-1.1-inline.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/include/netlink/object.h
-+++ b/include/netlink/object.h
-@@ -55,7 +55,7 @@
- /* Access Functions */
- extern int nl_object_get_refcnt(struct nl_object *);
- extern struct nl_cache * nl_object_get_cache(struct nl_object *);
--extern inline void * nl_object_priv(struct nl_object *);
-+extern void * nl_object_priv(struct nl_object *);
-
- #ifdef __cplusplus
- }
---- a/lib/object.c
-+++ b/lib/object.c
-@@ -376,7 +376,7 @@
- return obj->ce_cache;
- }
-
--inline void *nl_object_priv(struct nl_object *obj)
-+void *nl_object_priv(struct nl_object *obj)
- {
- return obj;
- }
diff --git a/dev-libs/libnl/files/libnl-1.1-minor-leaks.patch b/dev-libs/libnl/files/libnl-1.1-minor-leaks.patch
deleted file mode 100644
index 855a6ab3912e..000000000000
--- a/dev-libs/libnl/files/libnl-1.1-minor-leaks.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From: Patrick McHardy <kaber@trash.net>
-Date: Fri, 18 Jan 2008 16:55:49 +0000 (+0100)
-Subject: [LIBNL]: Fix minor memleaks on exit
-X-Git-Url: http://git.kernel.org/?p=libs%2Fnetlink%2Flibnl.git;a=commitdiff_plain;h=b64f15d6f947839236fa276d473d238f8c9b9d57;hp=e91bb2ffb090955d443e643a25b250bf3d33534a
-
-[LIBNL]: Fix minor memleaks on exit
-
-Make valgrind happy ...
-
-Signed-off-by: Patrick McHardy <kaber@trash.net>
----
-
-diff --git a/lib/route/route_utils.c b/lib/route/route_utils.c
-index a12d169..1386cda 100644
---- a/lib/route/route_utils.c
-+++ b/lib/route/route_utils.c
-@@ -63,6 +63,11 @@ static void __init init_routing_table_names(void)
- add_routing_table_name(RT_TABLE_LOCAL, "local");
- };
-
-+static void __exit release_routing_table_names(void)
-+{
-+ __trans_list_clear(&table_names);
-+}
-+
- int rtnl_route_read_table_names(const char *path)
- {
- __trans_list_clear(&table_names);
-@@ -104,6 +109,11 @@ static void __init init_proto_names(void)
- add_proto_name(RTPROT_STATIC, "static");
- };
-
-+static void __exit release_proto_names(void)
-+{
-+ __trans_list_clear(&proto_names);
-+}
-+
- int rtnl_route_read_protocol_names(const char *path)
- {
- __trans_list_clear(&proto_names);
diff --git a/dev-libs/libnl/libnl-1.1-r3.ebuild b/dev-libs/libnl/libnl-1.1-r3.ebuild
deleted file mode 100644
index 25601560c79e..000000000000
--- a/dev-libs/libnl/libnl-1.1-r3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/libnl-1.1-r3.ebuild,v 1.12 2013/05/21 16:40:25 jer Exp $
-
-EAPI=4
-
-inherit eutils multilib
-
-DESCRIPTION="A collection of libraries providing APIs to netlink protocol based Linux kernel interfaces"
-HOMEPAGE="http://www.infradead.org/~tgr/libnl/"
-SRC_URI="http://www.infradead.org/~tgr/libnl/files/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="1.1"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~ia64-linux ~x86-linux"
-IUSE="doc"
-
-DEPEND="doc? ( app-doc/doxygen )"
-DOCS=( ChangeLog )
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-vlan-header.patch \
- "${FILESDIR}"/${P}-minor-leaks.patch \
- "${FILESDIR}"/${P}-glibc-2.8-ULONG_MAX.patch \
- "${FILESDIR}"/${P}-flags.patch \
- "${FILESDIR}"/${P}-inline.patch
-}
-
-src_compile() {
- default
-
- if use doc ; then
- cd "${S}/doc"
- emake gendoc || die "emake gendoc failed"
- fi
-}
-
-src_install() {
- default
-
- if use doc ; then
- cd "${S}/doc"
- dohtml -r html/*
- fi
-}
diff --git a/dev-libs/libnl/libnl-3.2.14.ebuild b/dev-libs/libnl/libnl-3.2.14.ebuild
deleted file mode 100644
index 831218a8366f..000000000000
--- a/dev-libs/libnl/libnl-3.2.14.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/libnl-3.2.14.ebuild,v 1.17 2013/05/21 16:40:25 jer Exp $
-
-EAPI=4
-inherit eutils libtool multilib
-
-DESCRIPTION="A collection of libraries providing APIs to netlink protocol based Linux kernel interfaces"
-HOMEPAGE="http://www.infradead.org/~tgr/libnl/"
-SRC_URI="
- http://www.infradead.org/~tgr/libnl/files/${P}.tar.gz
- doc? ( http://www.infradead.org/~tgr/libnl/files/${PN}-doc-${PV}.tar.gz )
-"
-LICENSE="LGPL-2.1 doc? ( GPL-2 ) utils? ( GPL-2 )"
-SLOT="3"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~ia64-linux ~x86-linux"
-IUSE="doc static-libs utils"
-
-DEPEND="
- sys-devel/flex
- sys-devel/bison
-"
-
-src_prepare() {
- elibtoolize
- epatch "${FILESDIR}"/${PN}-1.1-vlan-header.patch
-}
-
-src_configure() {
- econf \
- --disable-silent-rules \
- $(use_enable static-libs static) \
- $(use_enable utils cli)
-}
-
-src_install() {
- default
- if use doc; then
- dohtml -r \
- -a css,html,js,map,png \
- "${WORKDIR}"/${PN}-doc-${PV}/*
- fi
-
- use static-libs || rm -f "${ED}"/usr/$(get_libdir)/lib*.la
-
- dodoc ChangeLog
-}