summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-11-08 08:52:32 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-11-08 08:52:32 +0000
commitf0e2f606f4970b8369b03d7a71333e088dc576c6 (patch)
treefddfc52c4399e5737e35e6641402cf4faa3fd1d4 /dev-libs
parentSmall fix, closes #10406. (diff)
downloadgentoo-2-f0e2f606f4970b8369b03d7a71333e088dc576c6.tar.gz
gentoo-2-f0e2f606f4970b8369b03d7a71333e088dc576c6.tar.bz2
gentoo-2-f0e2f606f4970b8369b03d7a71333e088dc576c6.zip
new package -ntl - library for efficient computation
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ntl/ChangeLog14
-rw-r--r--dev-libs/ntl/files/digest-ntl-5.31
-rw-r--r--dev-libs/ntl/ntl-5.3.ebuild42
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/ntl/ChangeLog b/dev-libs/ntl/ChangeLog
new file mode 100644
index 000000000000..8bef5dd24600
--- /dev/null
+++ b/dev-libs/ntl/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for dev-libs/ntl
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ntl/ChangeLog,v 1.1 2002/11/08 08:52:32 george Exp $
+
+*ntl-5.3 (07 Nov 2002)
+
+ 07 Nov 2002; George Shapovalov <george@gentoo.org> ntl-5.3.ebuild :
+
+ Initial release
+ NTL is a high-performance, portable C++ library providing data structures and algorithms for arbitrary
+ length integers; for vectors, matrices, and polynomials over the integers and over finite fields; and for
+ arbitrary precision floating point arithmetic.
+
+ ebuild submitted by Brendan Johnson <johnsobm@clarkson.edu>
diff --git a/dev-libs/ntl/files/digest-ntl-5.3 b/dev-libs/ntl/files/digest-ntl-5.3
new file mode 100644
index 000000000000..4004e6eb3503
--- /dev/null
+++ b/dev-libs/ntl/files/digest-ntl-5.3
@@ -0,0 +1 @@
+MD5 0292a808e2d2420f8e00c1ac5da4b7a4 ntl-5.3.tar.gz 670004
diff --git a/dev-libs/ntl/ntl-5.3.ebuild b/dev-libs/ntl/ntl-5.3.ebuild
new file mode 100644
index 000000000000..df441ba75d69
--- /dev/null
+++ b/dev-libs/ntl/ntl-5.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ntl/ntl-5.3.ebuild,v 1.1 2002/11/08 08:52:32 george Exp $
+
+IUSE=""
+
+DESCRIPTION="high-performance, portable C++ ci-computational ibrar"
+HOMEPAGE="http://shoup.net/ntl/"
+SRC_URI="http://www.shoup.net/ntl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+DEPEND=">=gmp-4.1-r1"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ cd src
+ ./configure \
+ PREFIX=/usr \
+ NTL_GMP_LIP=on \
+ "CFLAGS=$CFLAGS -Wno-deprecated" || die "./configure failed"
+
+ make || die "make failed"
+ make check || die "make check failed - make did not make something good..."
+}
+
+src_install() {
+ cd src
+ make PREFIX=${D}/usr/ install || die
+
+ #now somewhat clean-up docs
+ cd ${S}
+ dodoc README
+ cd ${S}/doc
+ dodoc *.txt
+ dohtml *.html *.gif
+
+ rm -rf ${D}/usr/doc
+}