summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-11-01 17:45:29 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-11-01 17:45:29 +0000
commitf1cc9a4d1649f3dda0163fb8a67926cc25c1bb50 (patch)
treec1d9406f7ddf96ff29a8b486680108670af000f7 /dev-libs
parentAdd stricts deps on ~babl-0.0.22 and ~gegl-0.0.22 due to API/ABI changes in 0... (diff)
downloadgentoo-2-f1cc9a4d1649f3dda0163fb8a67926cc25c1bb50.tar.gz
gentoo-2-f1cc9a4d1649f3dda0163fb8a67926cc25c1bb50.tar.bz2
gentoo-2-f1cc9a4d1649f3dda0163fb8a67926cc25c1bb50.zip
Version bump. Install docs in one place, clean up old revisions.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libdaemon/ChangeLog10
-rw-r--r--dev-libs/libdaemon/libdaemon-0.10.ebuild38
-rw-r--r--dev-libs/libdaemon/libdaemon-0.14.ebuild49
3 files changed, 57 insertions, 40 deletions
diff --git a/dev-libs/libdaemon/ChangeLog b/dev-libs/libdaemon/ChangeLog
index 6689f3edc351..c37699d0818d 100644
--- a/dev-libs/libdaemon/ChangeLog
+++ b/dev-libs/libdaemon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libdaemon
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/ChangeLog,v 1.57 2009/02/11 07:40:38 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/ChangeLog,v 1.58 2009/11/01 17:45:29 eva Exp $
+
+*libdaemon-0.14 (01 Nov 2009)
+
+ 01 Nov 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ -libdaemon-0.10.ebuild, +libdaemon-0.14.ebuild:
+ Version bump. Install docs in one place, clean up old revisions.
11 Feb 2009; Alexis Ballier <aballier@gentoo.org>
+files/libdaemon-0.13-bsd.patch, libdaemon-0.13-r1.ebuild:
diff --git a/dev-libs/libdaemon/libdaemon-0.10.ebuild b/dev-libs/libdaemon/libdaemon-0.10.ebuild
deleted file mode 100644
index 45a10051d930..000000000000
--- a/dev-libs/libdaemon/libdaemon-0.10.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/libdaemon-0.10.ebuild,v 1.19 2008/10/02 21:13:05 eva Exp $
-
-DESCRIPTION="Simple library for creating daemon processes in C"
-HOMEPAGE="http://0pointer.de/lennart/projects/libdaemon/"
-SRC_URI="http://0pointer.de/lennart/projects/libdaemon/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="arm s390 sh"
-IUSE="doc"
-
-RDEPEND=""
-DEPEND="doc? ( app-doc/doxygen )"
-
-src_compile() {
- econf --disable-lynx || die "econf failed"
- emake || die "emake failed"
-
- if use doc ; then
- einfo "Building documentation"
- make doxygen || die "make doxygen failed"
- fi
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- if use doc; then
- ln -sf doc/reference/html reference
- dohtml -r doc/README.html reference
- doman doc/reference/man/man*/*
- fi
-
- dodoc README
- docinto examples ; dodoc examples/testd.c
-}
diff --git a/dev-libs/libdaemon/libdaemon-0.14.ebuild b/dev-libs/libdaemon/libdaemon-0.14.ebuild
new file mode 100644
index 000000000000..a20d1d7d4f74
--- /dev/null
+++ b/dev-libs/libdaemon/libdaemon-0.14.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/libdaemon-0.14.ebuild,v 1.1 2009/11/01 17:45:29 eva Exp $
+
+inherit libtool eutils
+
+DESCRIPTION="Simple library for creating daemon processes in C"
+HOMEPAGE="http://0pointer.de/lennart/projects/libdaemon/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf \
+ --docdir=/usr/share/doc/${PF}
+ --localstatedir=/var \
+ --disable-examples \
+ --disable-lynx
+ emake || die "emake failed"
+
+ if use doc ; then
+ einfo "Building documentation"
+ emake doxygen || die "make doxygen failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if use doc; then
+ ln -sf doc/reference/html reference
+ dohtml -r doc/README.html doc/style.css reference || die "dohtml failed"
+ doman doc/reference/man/man*/* || "doman failed"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc examples/testd.c || die "dodoc 1 failed"
+ fi
+
+ rm -rf "${D}"/usr/share/doc/${PF}/{README.html,style.css} || die "rm failed"
+ dodoc README || die "dodoc 2 failed"
+}