summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-08-13 20:53:07 +0000
committerMichał Górny <mgorny@gentoo.org>2014-08-13 20:53:07 +0000
commitf1d2ac2fd3ebc10747aab265472f64426c01b0f7 (patch)
treeaaf5566578638e5c911a87578dd46b217cb6f784 /dev-libs
parent3dprint herd added (diff)
downloadgentoo-2-f1d2ac2fd3ebc10747aab265472f64426c01b0f7.tar.gz
gentoo-2-f1d2ac2fd3ebc10747aab265472f64426c01b0f7.tar.bz2
gentoo-2-f1d2ac2fd3ebc10747aab265472f64426c01b0f7.zip
Short-circuit the $MAKEDEPEND-is-gcc to always-on since we are overriding MAKEDEPEND unconditionally anyway. Pass -Qunused-arguments when clang is used to silence the unused flag warnings that can not be fixed without major changes to the build system, and to make -Werror in "make depend" happier. Fixes build with CC values that do not end with "gcc", bug #499818, and with clang, bug #417795. Reviewed by Chainsaw.
(Portage version: 2.2.11_p72/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/ChangeLog11
-rw-r--r--dev-libs/openssl/openssl-0.9.8z_p2.ebuild12
-rw-r--r--dev-libs/openssl/openssl-1.0.1i.ebuild12
-rw-r--r--dev-libs/openssl/openssl-1.0.2_beta2.ebuild12
4 files changed, 43 insertions, 4 deletions
diff --git a/dev-libs/openssl/ChangeLog b/dev-libs/openssl/ChangeLog
index f67eb30c8d3e..df43853fd598 100644
--- a/dev-libs/openssl/ChangeLog
+++ b/dev-libs/openssl/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/openssl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.586 2014/08/13 15:22:41 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.587 2014/08/13 20:53:07 mgorny Exp $
+
+ 13 Aug 2014; Michał Górny <mgorny@gentoo.org> openssl-0.9.8z_p2.ebuild,
+ openssl-1.0.1i.ebuild, openssl-1.0.2_beta2.ebuild:
+ Short-circuit the $MAKEDEPEND-is-gcc to always-on since we are overriding
+ MAKEDEPEND unconditionally anyway. Pass -Qunused-arguments when clang is used
+ to silence the unused flag warnings that can not be fixed without major
+ changes to the build system, and to make -Werror in "make depend" happier.
+ Fixes build with CC values that do not end with "gcc", bug #499818, and with
+ clang, bug #417795. Reviewed by Chainsaw.
13 Aug 2014; Markus Meier <maekke@gentoo.org> openssl-0.9.8z_p2.ebuild:
arm stable, bug #519264
diff --git a/dev-libs/openssl/openssl-0.9.8z_p2.ebuild b/dev-libs/openssl/openssl-0.9.8z_p2.ebuild
index e2d0cf07223c..e1187f829e9d 100644
--- a/dev-libs/openssl/openssl-0.9.8z_p2.ebuild
+++ b/dev-libs/openssl/openssl-0.9.8z_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.8z_p2.ebuild,v 1.5 2014/08/13 15:22:41 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.8z_p2.ebuild,v 1.6 2014/08/13 20:53:07 mgorny Exp $
# this ebuild is only for the libcrypto.so.0.9.8 and libssl.so.0.9.8 SONAME for ABI compat
@@ -63,6 +63,16 @@ src_prepare() {
-e "/foo.*engines/s|/lib/engines|/$(get_libdir)/engines|" \
Configure || die
+ # since we're forcing $(CC) as makedep anyway, just fix
+ # the conditional as always-on
+ # helps clang (#417795), and versioned gcc (#499818)
+ sed -i 's/expr.*MAKEDEPEND.*;/true;/' util/domd || die
+
+ # quiet out unknown driver argument warnings since openssl
+ # doesn't have well-split CFLAGS and we're making it even worse
+ # and 'make depend' uses -Werror for added fun (#417795 again)
+ [[ ${CC} == *clang* ]] && append-flags -Qunused-arguments
+
# allow openssl to be cross-compiled
cp "${FILESDIR}"/gentoo.config-0.9.8 gentoo.config || die "cp cross-compile failed"
chmod a+rx gentoo.config
diff --git a/dev-libs/openssl/openssl-1.0.1i.ebuild b/dev-libs/openssl/openssl-1.0.1i.ebuild
index 0e6d0e628732..21caafcf558a 100644
--- a/dev-libs/openssl/openssl-1.0.1i.ebuild
+++ b/dev-libs/openssl/openssl-1.0.1i.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1i.ebuild,v 1.7 2014/08/13 15:21:57 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1i.ebuild,v 1.8 2014/08/13 20:53:07 mgorny Exp $
EAPI="4"
@@ -81,6 +81,16 @@ src_prepare() {
# show the actual commands in the log
sed -i '/^SET_X/s:=.*:=set -x:' Makefile.shared
+ # since we're forcing $(CC) as makedep anyway, just fix
+ # the conditional as always-on
+ # helps clang (#417795), and versioned gcc (#499818)
+ sed -i 's/expr.*MAKEDEPEND.*;/true;/' util/domd || die
+
+ # quiet out unknown driver argument warnings since openssl
+ # doesn't have well-split CFLAGS and we're making it even worse
+ # and 'make depend' uses -Werror for added fun (#417795 again)
+ [[ ${CC} == *clang* ]] && append-flags -Qunused-arguments
+
# allow openssl to be cross-compiled
cp "${FILESDIR}"/gentoo.config-1.0.1 gentoo.config || die
chmod a+rx gentoo.config
diff --git a/dev-libs/openssl/openssl-1.0.2_beta2.ebuild b/dev-libs/openssl/openssl-1.0.2_beta2.ebuild
index 313c2c443bbb..b5a15c73b3c3 100644
--- a/dev-libs/openssl/openssl-1.0.2_beta2.ebuild
+++ b/dev-libs/openssl/openssl-1.0.2_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.2_beta2.ebuild,v 1.1 2014/07/23 05:26:08 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.2_beta2.ebuild,v 1.2 2014/08/13 20:53:07 mgorny Exp $
EAPI="4"
@@ -80,6 +80,16 @@ src_prepare() {
# show the actual commands in the log
sed -i '/^SET_X/s:=.*:=set -x:' Makefile.shared
+ # since we're forcing $(CC) as makedep anyway, just fix
+ # the conditional as always-on
+ # helps clang (#417795), and versioned gcc (#499818)
+ sed -i 's/expr.*MAKEDEPEND.*;/true;/' util/domd || die
+
+ # quiet out unknown driver argument warnings since openssl
+ # doesn't have well-split CFLAGS and we're making it even worse
+ # and 'make depend' uses -Werror for added fun (#417795 again)
+ [[ ${CC} == *clang* ]] && append-flags -Qunused-arguments
+
# allow openssl to be cross-compiled
cp "${FILESDIR}"/gentoo.config-1.0.1 gentoo.config || die
chmod a+rx gentoo.config