summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-04-23 21:15:06 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-04-23 21:15:06 +0000
commitf3ba7012943205fde0679e02893947e728ee0463 (patch)
tree9d85ebb4a00f49238831004785a84d5feef9a25e /dev-libs
parentVersion bump, bug#175758 (diff)
downloadgentoo-2-f3ba7012943205fde0679e02893947e728ee0463.tar.gz
gentoo-2-f3ba7012943205fde0679e02893947e728ee0463.tar.bz2
gentoo-2-f3ba7012943205fde0679e02893947e728ee0463.zip
Bump to 2.6.28
(Portage version: 2.1.2.4)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libxml2/ChangeLog7
-rw-r--r--dev-libs/libxml2/files/digest-libxml2-2.6.289
-rw-r--r--dev-libs/libxml2/libxml2-2.6.28.ebuild111
3 files changed, 126 insertions, 1 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index 2352ab8f597d..57ea57ae3f08 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libxml2
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.178 2007/02/04 23:47:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.179 2007/04/23 21:15:06 dang Exp $
+
+*libxml2-2.6.28 (23 Apr 2007)
+
+ 23 Apr 2007; Daniel Gryniewicz <dang@gentoo.org> +libxml2-2.6.28.ebuild:
+ Bump to 2.6.28
04 Feb 2007; Jeroen Roovers <jer@gentoo.org> libxml2-2.6.27.ebuild:
Stable for HPPA (bug #164978).
diff --git a/dev-libs/libxml2/files/digest-libxml2-2.6.28 b/dev-libs/libxml2/files/digest-libxml2-2.6.28
new file mode 100644
index 000000000000..bb6beef2cd08
--- /dev/null
+++ b/dev-libs/libxml2/files/digest-libxml2-2.6.28
@@ -0,0 +1,9 @@
+MD5 ddf3c369964980a238fad0b6ad40532c libxml2-2.6.28.tar.gz 4716025
+RMD160 65d0c2cef5ce40751bd72bb54462d9122558fa17 libxml2-2.6.28.tar.gz 4716025
+SHA256 384db143d8ccdf1904439150ef5081f78d7f9f05ac15306f685c10c2bd3e1cb2 libxml2-2.6.28.tar.gz 4716025
+MD5 073bb1181a019a3f49ed2a8018e56ffe xsts-2002-01-16.tar.gz 6894439
+RMD160 e8905fe1451a1c367b0104af24edca73bad1db08 xsts-2002-01-16.tar.gz 6894439
+SHA256 55e5c08db29946a91ea8e70e8f2418d3fd30d8b6777941dfba7f54726ffd9914 xsts-2002-01-16.tar.gz 6894439
+MD5 0267eb5d9c0e9a76324a51d2ebef4a11 xsts-2006-11-06.tar.gz 4349266
+RMD160 a64caae64dd82c703a94fa63ce1291dc289df376 xsts-2006-11-06.tar.gz 4349266
+SHA256 542db1d583061f3f713481aab6aa6cb382efec87716d74b94c4a0155981e2d09 xsts-2006-11-06.tar.gz 4349266
diff --git a/dev-libs/libxml2/libxml2-2.6.28.ebuild b/dev-libs/libxml2/libxml2-2.6.28.ebuild
new file mode 100644
index 000000000000..147919f95b03
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.6.28.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.6.28.ebuild,v 1.1 2007/04/23 21:15:06 dang Exp $
+
+inherit libtool flag-o-matic eutils
+
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.xmlsoft.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug doc ipv6 python readline test"
+
+XSTS_HOME="http://www.w3.org/XML/2004/xml-schema-test-suite"
+XSTS_NAME_1="xmlschema2002-01-16"
+XSTS_NAME_2="xmlschema2006-11-06"
+XSTS_TARBALL_1="xsts-2002-01-16.tar.gz"
+XSTS_TARBALL_2="xsts-2006-11-06.tar.gz"
+
+SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz
+ test? (
+ ${XSTS_HOME}/${XSTS_NAME_1}/${XSTS_TARBALL_1}
+ ${XSTS_HOME}/${XSTS_NAME_2}/${XSTS_TARBALL_2} )"
+
+RDEPEND="sys-libs/zlib
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ hppa? ( >=sys-devel/binutils-2.15.92.0.2 )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ if use test; then
+ cp ${DISTDIR}/${XSTS_TARBALL_1} \
+ ${DISTDIR}/${XSTS_TARBALL_2} \
+ ${S}/xstc/ \
+ || die "Failed to install test tarballs"
+ fi
+
+ # Pass --wildcards option to tar when needed (bug #158386)
+ epatch "${FILESDIR}"/${PN}-2.6.27-tar_in_tests.patch
+
+ epunt_cxx
+}
+
+src_compile() {
+ # USE zlib support breaks gnome2
+ # (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+
+ # The meaning of the 'debug' USE flag does not apply to the --with-debug
+ # switch (enabling the libxml2 debug module). See bug #100898.
+
+ # --with-mem-debug causes unusual segmentation faults (bug #105120).
+
+ local myconf="--with-zlib \
+ $(use_with debug run-debug) \
+ $(use_with python) \
+ $(use_with readline) \
+ $(use_with readline history) \
+ $(use_enable ipv6)"
+
+ # Please do not remove, as else we get references to PORTAGE_TMPDIR
+ # in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
+ elibtoolize
+
+ # filter seemingly problematic CFLAGS (#26320)
+ filter-flags -fprefetch-loop-arrays -funroll-loops
+
+ econf $myconf || die "Configuration failed"
+
+ # Patching the Makefiles to respect get_libdir
+ # Fixes BUG #86766, please keep this.
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ for x in $(find ${S} -name "Makefile") ; do
+ sed \
+ -e "s|^\(PYTHON_SITE_PACKAGES\ =\ \/usr\/\).*\(\/python.*\)|\1$(get_libdir)\2|g" \
+ -i ${x} \
+ || die "sed failed"
+ done
+
+ emake || die "Copilation failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog Copyright NEWS README* TODO*
+
+ if ! use doc; then
+ rm -rf ${D}/usr/share/gtk-doc
+ rm -rf ${D}/usr/share/doc/${P}/html
+ fi
+}
+
+pkg_postinst() {
+ # need an XML catalog, so no-one writes to a non-existent one
+ CATALOG="${ROOT}etc/xml/catalog"
+
+ # we dont want to clobber an existing catalog though,
+ # only ensure that one is there
+ # <obz@gentoo.org>
+ if [ ! -e ${CATALOG} ]; then
+ [ -d "${ROOT}etc/xml" ] || mkdir -p "${ROOT}etc/xml"
+ /usr/bin/xmlcatalog --create > ${CATALOG}
+ einfo "Created XML catalog in ${CATALOG}"
+ fi
+}