summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-05-30 18:16:18 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-05-30 18:16:18 +0000
commitfaa2ea7a3b363d32cbad9e7d4207df9635cc6640 (patch)
tree8f4e87163772f7bd55acbfbb0d848e001d6a7461 /dev-libs
parentppc stable #263878 (diff)
downloadgentoo-2-faa2ea7a3b363d32cbad9e7d4207df9635cc6640.tar.gz
gentoo-2-faa2ea7a3b363d32cbad9e7d4207df9635cc6640.tar.bz2
gentoo-2-faa2ea7a3b363d32cbad9e7d4207df9635cc6640.zip
Initial commit of boolstuff library. Partially fixes bug 257933
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boolstuff/ChangeLog12
-rw-r--r--dev-libs/boolstuff/boolstuff-0.1.12.ebuild22
-rw-r--r--dev-libs/boolstuff/metadata.xml20
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/boolstuff/ChangeLog b/dev-libs/boolstuff/ChangeLog
new file mode 100644
index 000000000000..6a366493bd00
--- /dev/null
+++ b/dev-libs/boolstuff/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-libs/boolstuff
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boolstuff/ChangeLog,v 1.1 2009/05/30 18:16:18 hwoarang Exp $
+
+*boolstuff-0.1.12 (30 May 2009)
+
+ 30 May 2009; Markos Chandras <hwoarang@gentoo.org>
+ +boolstuff-0.1.12.ebuild, +metadata.xml:
+ Initial commit of boolstuff library. Partially fixes bug 257933. Thanks to
+ Mike Gualtieri <mike.gualtieri@gmail.com> for the initial ebuild. Giorgos
+ Kargiotakis <kargig@void.gr> will be proxy maintainer.
+
diff --git a/dev-libs/boolstuff/boolstuff-0.1.12.ebuild b/dev-libs/boolstuff/boolstuff-0.1.12.ebuild
new file mode 100644
index 000000000000..b4d304a1510e
--- /dev/null
+++ b/dev-libs/boolstuff/boolstuff-0.1.12.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boolstuff/boolstuff-0.1.12.ebuild,v 1.1 2009/05/30 18:16:18 hwoarang Exp $
+
+EAPI="2"
+
+DESCRIPTION="A C++ library that supports a few operations on boolean expression binary trees."
+HOMEPAGE="http://perso.b2b2c.ca/sarrazip/dev/boolstuff.html"
+SRC_URI="http://perso.b2b2c.ca/sarrazip/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static"
+
+src_configure(){
+ econf $(use_enable static)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+}
diff --git a/dev-libs/boolstuff/metadata.xml b/dev-libs/boolstuff/metadata.xml
new file mode 100644
index 000000000000..95210ada3238
--- /dev/null
+++ b/dev-libs/boolstuff/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+</maintainer>
+<maintainer>
+ <email>kargig@void.gr</email>
+ <name>Giorgos Kargiotakis</name>
+ <description>Proxy Maintainer</description>
+</maintainer>
+<use>
+ <flag name="static">Enable static linking</flag>
+</use>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+