summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-05-09 06:25:34 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-05-09 06:25:34 +0000
commit7b23263f80cca8ba7ac5f0c9aa556f6f169dd416 (patch)
tree9f7d7b69ff94478add7d64e1e8f9023e8c2df441 /dev-lisp/cl-imho/cl-imho-1.3.2.ebuild
parent (Manifest recommit) (diff)
downloadgentoo-2-7b23263f80cca8ba7ac5f0c9aa556f6f169dd416.tar.gz
gentoo-2-7b23263f80cca8ba7ac5f0c9aa556f6f169dd416.tar.bz2
gentoo-2-7b23263f80cca8ba7ac5f0c9aa556f6f169dd416.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-imho/cl-imho-1.3.2.ebuild')
-rw-r--r--dev-lisp/cl-imho/cl-imho-1.3.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-lisp/cl-imho/cl-imho-1.3.2.ebuild b/dev-lisp/cl-imho/cl-imho-1.3.2.ebuild
new file mode 100644
index 000000000000..d410fbabcf1a
--- /dev/null
+++ b/dev-lisp/cl-imho/cl-imho-1.3.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-imho/cl-imho-1.3.2.ebuild,v 1.1 2004/05/09 06:25:34 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="IMHO is a toolkit that provides facilities for building highly interactive web applications"
+HOMEPAGE="http://freesw.onshored.com/wwwdist/imho/
+ http://alpha.onshored.com/lisp-software/"
+SRC_URI="http://alpha.onshored.com/debian/local/${PN}_${PV}.orig.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="dev-lisp/common-lisp-controller
+ dev-lisp/cl-odcl
+ =net-www/apache-1*"
+
+CLPACKAGE=imho
+
+S=${WORKDIR}/${P}.orig
+
+src_compile() {
+ cd apache && make CFLAGS="${CFLAGS} -Wall -Wstrict-prototypes -fPIC" || die
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe apache/apache-1.3/mod_webapp.so
+
+ insinto /usr/include/webapplib
+ doins apache/webapplib/*.h
+ dolib.so apache/webapplib/libwebapp.so
+
+ dodoc apache/doc/*.txt
+ dodoc doc/*.txt doc/*.pdf
+ dohtml doc/*.html
+
+ insinto /usr/share/common-lisp/source/imho
+ doins *.lisp imho.asd imho.system
+ dodir /usr/share/common-lisp/systems
+ dosym /usr/share/common-lisp/source/imho/imho.asd \
+ /usr/share/common-lisp/systems/imho.asd
+ dosym /usr/share/common-lisp/source/imho/imho.system \
+ /usr/share/common-lisp/systems/imho.system
+}