summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-10-18 10:13:23 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-10-18 10:13:23 +0000
commit95251320fd0fce2e95e203d7ba842e880a8e9fb2 (patch)
treed4db40b819e482fe44c00f1a442d405df73294e6 /dev-lisp/cl-rsm-random
parentinitial import (diff)
downloadgentoo-2-95251320fd0fce2e95e203d7ba842e880a8e9fb2.tar.gz
gentoo-2-95251320fd0fce2e95e203d7ba842e880a8e9fb2.tar.bz2
gentoo-2-95251320fd0fce2e95e203d7ba842e880a8e9fb2.zip
initial import
Diffstat (limited to 'dev-lisp/cl-rsm-random')
-rw-r--r--dev-lisp/cl-rsm-random/ChangeLog9
-rw-r--r--dev-lisp/cl-rsm-random/Manifest4
-rw-r--r--dev-lisp/cl-rsm-random/cl-rsm-random-1.1.ebuild42
-rw-r--r--dev-lisp/cl-rsm-random/files/digest-cl-rsm-random-1.11
-rw-r--r--dev-lisp/cl-rsm-random/metadata.xml5
5 files changed, 59 insertions, 2 deletions
diff --git a/dev-lisp/cl-rsm-random/ChangeLog b/dev-lisp/cl-rsm-random/ChangeLog
new file mode 100644
index 000000000000..3a7036f309a9
--- /dev/null
+++ b/dev-lisp/cl-rsm-random/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-lisp/cl-rsm-random
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rsm-random/ChangeLog,v 1.1 2003/10/18 10:13:19 mkennedy Exp $
+
+*cl-rsm-random-1.1 (18 Oct 2003)
+
+ 18 Oct 2003; Matthew Kennedy <mkennedy@gentoo.org> :
+ Initial import. Ebuild submitted by Matthew Kennedy <mkennedy@genoo.org>.
+ Based on work from the Debian Project.
diff --git a/dev-lisp/cl-rsm-random/Manifest b/dev-lisp/cl-rsm-random/Manifest
index e3d163cb188f..5f0dca75fff1 100644
--- a/dev-lisp/cl-rsm-random/Manifest
+++ b/dev-lisp/cl-rsm-random/Manifest
@@ -1,4 +1,4 @@
MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
-MD5 4ed03b16246558d114005f66fe348091 cl-rsm-random-1.1.ebuild 919
-MD5 db4fda4d6c2e362614a054c563da219a ChangeLog 338
+MD5 3394a39c83221676235948ff94738b0c cl-rsm-random-1.1.ebuild 1021
+MD5 bbbb49a7afcbf98063d7ad2c8d5e9edf ChangeLog 435
MD5 7c5dd579d5c1d0fb741c5f6465bc931a files/digest-cl-rsm-random-1.1 68
diff --git a/dev-lisp/cl-rsm-random/cl-rsm-random-1.1.ebuild b/dev-lisp/cl-rsm-random/cl-rsm-random-1.1.ebuild
new file mode 100644
index 000000000000..4088460ec83a
--- /dev/null
+++ b/dev-lisp/cl-rsm-random/cl-rsm-random-1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rsm-random/cl-rsm-random-1.1.ebuild,v 1.1 2003/10/18 10:13:19 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="McIntire's Common Lisp Random Number Library"
+HOMEPAGE="http://packages.debian.org/unstable/devel/cl-rsm-random.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-rsm-random/cl-rsm-random_1.1.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ dev-lisp/cl-uffi"
+
+CLPACKAGE=rsm-random
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ make linux || die
+}
+
+src_install() {
+ exeinto /usr/lib/rsm-random
+ doexe random.so
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc copying copyright
+ dohtml *.html *.jpg
+ do-debian-credits
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
diff --git a/dev-lisp/cl-rsm-random/files/digest-cl-rsm-random-1.1 b/dev-lisp/cl-rsm-random/files/digest-cl-rsm-random-1.1
new file mode 100644
index 000000000000..9fbb0b6d13ae
--- /dev/null
+++ b/dev-lisp/cl-rsm-random/files/digest-cl-rsm-random-1.1
@@ -0,0 +1 @@
+MD5 974bcfce16b27fea670afeba6157cefb cl-rsm-random_1.1.tar.gz 11189
diff --git a/dev-lisp/cl-rsm-random/metadata.xml b/dev-lisp/cl-rsm-random/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-rsm-random/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>