summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-21 17:28:06 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-21 17:28:06 +0000
commitf5d139bf97745c7c45c3201f4e0febb91d3338df (patch)
tree736d7f6a68be88f487924978c64bf2ba795d443c /dev-lisp/cl-sql
parentadd inherit eutils (diff)
downloadgentoo-2-f5d139bf97745c7c45c3201f4e0febb91d3338df.tar.gz
gentoo-2-f5d139bf97745c7c45c3201f4e0febb91d3338df.tar.bz2
gentoo-2-f5d139bf97745c7c45c3201f4e0febb91d3338df.zip
add inherit eutils
Diffstat (limited to 'dev-lisp/cl-sql')
-rw-r--r--dev-lisp/cl-sql/cl-sql-1.7.6.ebuild10
-rw-r--r--dev-lisp/cl-sql/cl-sql-1.8.7.ebuild11
-rw-r--r--dev-lisp/cl-sql/cl-sql-1.8.8.ebuild10
3 files changed, 15 insertions, 16 deletions
diff --git a/dev-lisp/cl-sql/cl-sql-1.7.6.ebuild b/dev-lisp/cl-sql/cl-sql-1.7.6.ebuild
index 0495d81aa5c6..8d8bfc48bff9 100644
--- a/dev-lisp/cl-sql/cl-sql-1.7.6.ebuild
+++ b/dev-lisp/cl-sql/cl-sql-1.7.6.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sql/cl-sql-1.7.6.ebuild,v 1.3 2004/04/21 16:47:06 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sql/cl-sql-1.7.6.ebuild,v 1.4 2004/04/21 17:25:14 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="A multi-platform SQL interface for Common Lisp"
-HOMEPAGE="http://clsql.med-info.com/
- http://packages.debian.org/unstable/devel/cl-sql.html
- http://www.cliki.net/CLSQL"
+HOMEPAGE="http://clsql.med-info.com/ http://packages.debian.org/unstable/devel/cl-sql.html http://www.cliki.net/CLSQL"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-sql/cl-sql_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-sql/cl-sql_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
IUSE="postgres mysql"
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp
dev-lisp/cl-uffi
diff --git a/dev-lisp/cl-sql/cl-sql-1.8.7.ebuild b/dev-lisp/cl-sql/cl-sql-1.8.7.ebuild
index 86a84f23189c..6423d3976f29 100644
--- a/dev-lisp/cl-sql/cl-sql-1.8.7.ebuild
+++ b/dev-lisp/cl-sql/cl-sql-1.8.7.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sql/cl-sql-1.8.7.ebuild,v 1.1 2004/01/27 21:44:41 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sql/cl-sql-1.8.7.ebuild,v 1.2 2004/04/21 17:26:15 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="A multi-platform SQL interface for Common Lisp"
-HOMEPAGE="http://clsql.med-info.com/
- http://packages.debian.org/unstable/devel/cl-sql.html
- http://www.cliki.net/CLSQL"
+HOMEPAGE="http://clsql.med-info.com/ http://packages.debian.org/unstable/devel/cl-sql.html http://www.cliki.net/CLSQL"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-sql/cl-sql_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-sql/cl-sql_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
IUSE="postgres mysql"
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp
dev-lisp/cl-md5
@@ -116,7 +116,6 @@ pkg_prerm() {
use mysql && /usr/sbin/unregister-common-lisp-source clsql-mysql
}
-
pkg_preinst() {
rm -rf /usr/lib/common-lisp/*/clsql* || true
}
diff --git a/dev-lisp/cl-sql/cl-sql-1.8.8.ebuild b/dev-lisp/cl-sql/cl-sql-1.8.8.ebuild
index ab9a6a660bba..82b3e956e9ba 100644
--- a/dev-lisp/cl-sql/cl-sql-1.8.8.ebuild
+++ b/dev-lisp/cl-sql/cl-sql-1.8.8.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sql/cl-sql-1.8.8.ebuild,v 1.1 2004/02/12 09:13:20 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sql/cl-sql-1.8.8.ebuild,v 1.2 2004/04/21 17:26:33 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="A multi-platform SQL interface for Common Lisp"
-HOMEPAGE="http://clsql.med-info.com/
- http://packages.debian.org/unstable/devel/cl-sql.html
- http://www.cliki.net/CLSQL"
+HOMEPAGE="http://clsql.med-info.com/ http://packages.debian.org/unstable/devel/cl-sql.html http://www.cliki.net/CLSQL"
SRC_URI="http://files.b9.com/clsql/clsql-${PV}.tar.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
IUSE="postgres mysql"
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp
dev-lisp/cl-md5