summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-01-22 08:56:50 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-01-22 08:56:50 +0000
commit4173a2ae0e6399aac8428c32951f04eae8e40db1 (patch)
treedbfd68804ffc1a1f05009ee0ae669b781294d3fd /dev-lisp/cl-tbnl
parentStable on ppc64; bug #113826 (diff)
downloadgentoo-2-4173a2ae0e6399aac8428c32951f04eae8e40db1.tar.gz
gentoo-2-4173a2ae0e6399aac8428c32951f04eae8e40db1.tar.bz2
gentoo-2-4173a2ae0e6399aac8428c32951f04eae8e40db1.zip
New upstream version.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-lisp/cl-tbnl')
-rw-r--r--dev-lisp/cl-tbnl/ChangeLog7
-rw-r--r--dev-lisp/cl-tbnl/Manifest12
-rw-r--r--dev-lisp/cl-tbnl/cl-tbnl-0.9.6.ebuild36
-rw-r--r--dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.61
4 files changed, 45 insertions, 11 deletions
diff --git a/dev-lisp/cl-tbnl/ChangeLog b/dev-lisp/cl-tbnl/ChangeLog
index 7bee78338da2..f17f56d306bc 100644
--- a/dev-lisp/cl-tbnl/ChangeLog
+++ b/dev-lisp/cl-tbnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-tbnl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.27 2006/01/04 04:50:10 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.28 2006/01/22 08:56:50 mkennedy Exp $
+
+*cl-tbnl-0.9.6 (22 Jan 2006)
+
+ 22 Jan 2006; Matthew Kennedy <mkennedy@gentoo.org> +cl-tbnl-0.9.6.ebuild:
+ New upstream version.
*cl-tbnl-0.9.4 (04 Jan 2006)
diff --git a/dev-lisp/cl-tbnl/Manifest b/dev-lisp/cl-tbnl/Manifest
index a75ac0fc1d2c..56470da53f8d 100644
--- a/dev-lisp/cl-tbnl/Manifest
+++ b/dev-lisp/cl-tbnl/Manifest
@@ -1,18 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 4092752d735212e4058609ffbdb671c3 ChangeLog 4680
MD5 e4051610958787d2ff87c2ebdcbe773c cl-tbnl-0.8.9.ebuild 1012
MD5 dc448481b49565620c5214d44dd67139 cl-tbnl-0.9.3.ebuild 962
MD5 90dbd40fb4d0a0f699d6f08cacbb1a92 cl-tbnl-0.9.4.ebuild 962
+MD5 90dbd40fb4d0a0f699d6f08cacbb1a92 cl-tbnl-0.9.6.ebuild 962
MD5 b7377fe929b0307f2d7b4c8cf44965f0 files/digest-cl-tbnl-0.8.9 66
MD5 8eb91cfadf45362db4b3c887a96d4f0f files/digest-cl-tbnl-0.9.3 66
MD5 4ab7caeab29bdede1f8a48626723a184 files/digest-cl-tbnl-0.9.4 66
+MD5 872163a8a0421c3ed547bd1db33d6235 files/digest-cl-tbnl-0.9.6 66
MD5 a2199253dbe57d398c785af8f7744485 metadata.xml 804
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDu1QOyiNZaEAZA+ARArVLAJ4sNq7cV2b4E+4WwPEk4Ym3sVNLogCfQZQI
-iMhgP+VruLkYW3aWNUMV8xw=
-=EN32
------END PGP SIGNATURE-----
diff --git a/dev-lisp/cl-tbnl/cl-tbnl-0.9.6.ebuild b/dev-lisp/cl-tbnl/cl-tbnl-0.9.6.ebuild
new file mode 100644
index 000000000000..a70f6c471d0f
--- /dev/null
+++ b/dev-lisp/cl-tbnl/cl-tbnl-0.9.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/cl-tbnl-0.9.6.ebuild,v 1.1 2006/01/22 08:56:50 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="TBNL is a toolkit for building dynamic websites with Common Lisp based on mod_lisp."
+HOMEPAGE="http://www.weitz.de/tbnl/"
+SRC_URI="mirror://gentoo/tbnl_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="standalone apache2"
+
+DEPEND="dev-lisp/cl-kmrcl
+ dev-lisp/cl-md5
+ dev-lisp/cl-base64
+ dev-lisp/cl-url-rewrite
+ dev-lisp/cl-ppcre
+ dev-lisp/cl-rfc2388"
+
+RDEPEND="${DEPEND}
+ !standalone? ( apache2? ( >=www-apache/mod_lisp2-1.2 ) !apache2? ( www-apache/mod_lisp ) )"
+
+S=${WORKDIR}/tbnl-${PV}
+
+CLPACKAGE=tbnl
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ insinto $CLSOURCEROOT/$CLPACKAGE/
+ doins -r test contrib
+ dodoc CHANGELOG README
+ dohtml doc/index.html
+}
diff --git a/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.6 b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.6
new file mode 100644
index 000000000000..53681cca98b2
--- /dev/null
+++ b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.6
@@ -0,0 +1 @@
+MD5 c118317aca2dae6631b90a503092e0a6 tbnl_0.9.6.orig.tar.gz 93679